Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Feature Requests
 Namespace Coloring
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

BigHands
Senior Member

28 Posts

Posted - Feb 04 2010 :  07:51:18 AM  Show Profile  Reply with Quote
I would love a way to customize the color of namespace identifiers.
For example:

std::vector<int> foo;

std could be colored orange and vector blue.

I work with a lot of code that doesn't use "using namespace ..." and I believe this feature would help improve readability.

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Feb 08 2010 :  03:41:59 AM  Show Profile  Reply with Quote
I have put in a feature request to see what the developers make of it:

case=39380
Go to Top of Page

sean
Whole Tomato Software

USA
2698 Posts

Posted - Jul 12 2019 :  3:11:55 PM  Show Profile  Reply with Quote
case=39380 is implemented in build 2341
https://support.wholetomato.com/default.asp?W404#2341
Go to Top of Page

Slm
New Member

United Kingdom
2 Posts

Posted - Sep 04 2019 :  12:14:43 PM  Show Profile  Reply with Quote
No matter what I do on 2341.2 I cannot change the colour of namespaces. A lot of the color options appear to be broken when on Dark theme. I.e. they get overridden by VA's defaults in some cases, and not in others.


Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16086 Posts

Posted - Sep 04 2019 :  2:44:38 PM  Show Profile  Reply with Quote
Which IDE are you using?

Have you restarted the IDE since installing Visual Assist?

Is this the first time you have installed Visual Assist on this machine, or have you upgraded a previously installed version of Visual Assist?

I have just checked both VS2017 and VS2019 with VA 2341.2, and this is working correctly for me in both IDE's, with the IDE set to the dark theme.

If you look in the IDE options dialog, do you have the entry:

IDE tools menu -> Options -> Environment -> Fonts and Colors -> Display items = VA Namespace

this should be one of several VA items in the colour list in the IDE options dialog, and this allows you to set both the foreground and background colour used by VA for namespaces.

zen is the art of being at one with the two'ness
Go to Top of Page

Slm
New Member

United Kingdom
2 Posts

Posted - Sep 05 2019 :  04:33:34 AM  Show Profile  Reply with Quote
Going to Tools -> Extensions disabling and then enabling, whilst also deleting .vs folder, along with a reset to default fonts and colors in VS has managed to fix everything. Was sure I had done this yesterday so unsure if computer restart may have affected it in some way as well.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16086 Posts

Posted - Sep 06 2019 :  08:00:17 AM  Show Profile  Reply with Quote
Thank you for the update. You should not have had to do all of this, but I am glad that it has worked and fixed the problem. Hopefully everything will now work correctly for you.

zen is the art of being at one with the two'ness
Go to Top of Page

manu
New Member

3 Posts

Posted - Sep 16 2019 :  04:20:30 AM  Show Profile  Reply with Quote
Hello,

Same thing for me, after upgrade (2333 -> 2341.2), coloring is completely broken (only in Text Editor view, not VA Outline or others).
Disabling VA coloring makes things readable, but I would like to use VA coloring.

See attached image


All VA color parameters are gone from Font and Colors section in VS options.

Disabling/Enabling VA was enough to restore previous behavior: problem solved :)

I'm using VS2015.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3212 Posts

Posted - Sep 16 2019 :  04:30:58 AM  Show Profile  Reply with Quote
I'm glad your problem is now solved. Unfortunately, it can happen sometimes, but thankfully it's quite rare.
My understanding is that Visual Studio's coloring cache or coloring priority (the order in which things are drawn) is sometimes changed for some reason. The enable/disable cycle of Visual Assist in the extension manager resets the order.

Edited by - accord on Sep 16 2019 04:31:26 AM
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000