Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 License activation behind a proxy
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

darktears
Junior Member

USA
10 Posts

Posted - Sep 26 2023 :  09:21:18 AM  Show Profile  Reply with Quote
Hi,

Like many users of Visual Assist I'm often behind a proxy. Activating the license does not work behind a proxy, the request times out. I'm well aware that there are other means of activations and I end up using them (or jump out of the VPN to avoid the proxy). I remember this being an issue years ago and I would say that I'm disappointed that the Visual Assist team still has not spend a bit of time to fix this issue, after all it's usually not that hard to support a proxy. And I'm sure there are quite a few Visual Assist corp users here.

Now what seems to be new for me is that every time I launch Visual Studio when on VPN, Visual Assist asks me to activate again my license and that's quite annoying. I need to jump out of the VPN, find my serial number etc etc. It seems that even if I use the offline activation the issue still comes back (and sometimes I get weird errors about purchasing a new license because the installed version doesn't match or something).

I would say that there is nothing more frustrating than a paying customer having to deal with stupid/buggy license/activation system. I'm not talking about bugs or issues but simply to use what I paid for.

feline
Whole Tomato Software

United Kingdom
18658 Posts

Posted - Sep 26 2023 :  10:13:13 AM  Show Profile  Reply with Quote
Apologies for this.

You may be running into a problem where your license isn't being saved out correctly. This does come up occasionally. Can you please try closing all instances of Visual Studio and then deleting the directory:

%USERPROFILE%\AppData\Roaming\Embarcadero
next time you load Visual Studio you will need to enter your license once more, but this time it should be saved out correctly, no longer prompting you all the time.

As for the proxy, does the proxy requires authentication, or is it supposed to be a transparent proxy? I would not expect a transparent proxy to be a problem.

zen is the art of being at one with the two'ness
Go to Top of Page

darktears
Junior Member

USA
10 Posts

Posted - Sep 26 2023 :  11:52:14 AM  Show Profile  Reply with Quote
I'll try the suggested steps.

If it was a transparent proxy then nothing would be needed from Visual Assist. It's a set address proxy and no authentication is required. If Visual Assist reads the proxy settings then it should just work. https://learn.microsoft.com/en-us/windows/win32/api/winhttp/nf-winhttp-winhttpgetdefaultproxyconfiguration is probably a good start assuming that's available from the extension code.
Go to Top of Page

darktears
Junior Member

USA
10 Posts

Posted - Jan 17 2024 :  11:56:15 AM  Show Profile  Reply with Quote
It keeps happening, it's just plain annoying.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18658 Posts

Posted - Jan 17 2024 :  12:02:36 PM  Show Profile  Reply with Quote
Do you mean that VA keeps on "loosing" the license, so you have to re-enter it? If so, can you please once more try closing all instances of Visual Studio, then deleting the folder:

%USERPROFILE%\AppData\Roaming\Embarcadero

doing this will cause VA to prompt you for your license the next time you load Visual Studio, but it should now be saved out correctly, and remembered.

If this isn't the problem you are seeing, could you please explain the problem you are actually seeing?

zen is the art of being at one with the two'ness
Go to Top of Page

darktears
Junior Member

USA
10 Posts

Posted - Jan 18 2024 :  09:16:15 AM  Show Profile  Reply with Quote
Yes I did delete all folder as you suggested. It keeps happening at random.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18658 Posts

Posted - Jan 18 2024 :  10:56:52 AM  Show Profile  Reply with Quote
That isn't supposed to happen. Can you give me a sense of how often this is happening? Several times a day? A couple of times a week?

It shouldn't be happening at all, but some sense of the frequency might help.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000