Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Installation of older version in VS-2019 fails
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 08 2022 :  07:55:17 AM  Show Profile  Reply with Quote
I have a build 2339.
For some reason VS updated to the newest version where I don't have a registration key.

So I uninstalled the new version and reinstalled the old version.

I always get the failure
---------------------------
An error was reported by Visual Studio VSIXInstaller. See the next window for access to its error log.
---------------------------
But the log file says that the installation succeeded.
Than I get a message that the product is already installed for all programs.

When I now launch VS-2019, the Visual Assist menu doesn't show up.

I tried to repair VS and reinstalled Visual Assist.
No avail.




Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming

accord
Whole Tomato Software

United Kingdom
3281 Posts

Posted - Nov 08 2022 :  08:03:33 AM  Show Profile  Reply with Quote
We're sorry for the inconvenience. Visual Studio updates extensions by default. We try disabling it for Visual Assist, but it seems it wasn't successful in your case.

Regarding the problem you are facing right now: Can you please trigger the following dialog to see if Visual Assist is listed?

Extensions -> Manage Extensions...

Now please click on "Installed" on the left.

In case Visual Assist is listed here, is it Enabled? When you select it from the list, do you see an "Enable" button? If so, pressing that button should solve your problem.

Edited by - accord on Nov 08 2022 08:03:52 AM
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 08 2022 :  08:27:19 AM  Show Profile  Reply with Quote
1. I see in in the list
2. There is an Enable button and it is enabled.

Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 08 2022 :  09:37:01 AM  Show Profile  Reply with Quote
Succeeded.

1. VS Repair
2. No Extensions are available
3. Switch to English disable Auto Update for Extension
4. Restart
5. Install some Standard Extension (Powertools)
6. Exit
7. Install VA_X_Setup2399_0.exe
---------------------------
An error was reported by Visual Studio VSIXInstaller. See the next window for access to its error log.
---------------------------

Dialog with progess but not buttons.
Closes automtcally.

---------------------------
VSIX Installer
---------------------------
This Extension is already installed for all versions
---------------------------
OK
---------------------------


Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 11 2022 :  12:37:41 PM  Show Profile  Reply with Quote
If you check the install log you might see some "odd" error that is why the installer said there was a problem, but VA still installed successfully. I have seen this a few times now.

Hopefully VA is now active and working correctly for you.

You might want to make sure that automatically update is disabled for Visual Assist, which can be done in the:

IDE Extensions menu -> Manage Extensions

dialog on an extension by extension basis, or globally via:

IDE tools menu -> Options -> Environment -> Extensions and Updates -> Automatically update extensions

to avoid the IDE updating VA when you don't want this to happen.

zen is the art of being at one with the two'ness
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 14 2022 :  01:16:37 AM  Show Profile  Reply with Quote
Because I had to start the installer in compatibility mode, something going wrong.

Finally I didn't get it to run. But I bought a new update... :-|


Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 14 2022 :  10:50:10 AM  Show Profile  Reply with Quote
Are you saying you still cannot install the latest version of VA?

Is VA showing up as an installed extension inside VS2019 in the dialog:

IDE Extensions menu -> Manage Extensions

I have seen a number of cases where VA installs successfully, it shows up as an installed extension, it is enabled, but there is no sign of it when you load the IDE. So it is possible you have run into this problem. If so there is a fairly simple test, to see if its the same problem, and if so a solution for it.

zen is the art of being at one with the two'ness
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 14 2022 :  11:30:26 AM  Show Profile  Reply with Quote
No. I can ONLY install the latest version.
In fact this was the first time I wasn't able to install an older build of VA X on a machine.

The installer of the build 2339 doesn't start on my Windows 10 PC.
I can set the compatible mode to Windows 7. But in this case something seams to be wrong. Uninstalling the version doesn't work and leaves artifacts (like the VA View Window).

So I decided to by an update. It took me 4 hours to try to repair my old 2339 build. This wasn't worth the time...

Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming

Edited by - xMRi on Nov 14 2022 11:31:11 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 14 2022 :  11:34:56 AM  Show Profile  Reply with Quote
So far compatibility mode has always fixed the crashes that I have seen. It sounds like there is a problem with your default profile instead. Can you please try running the command:

"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\devenv.exe" /RootSuffix VATest

this will create and load a new, default profile for Visual Studio, so you will be asked which basic settings you want to use, and you should only have the standard, default IDE extensions installed. Visual Assist will not be installed into this profile, so you will need to go into the dialog:

IDE Extensions menu -> Manage Extensions

and install Visual Assist from the online extension store, to install VA for this test profile. This won't install the just released version of VA, but it will let us test to see if you can get a new install of Visual Assist working in this test profile without problems.

To load your normal, default profile just load the IDE normally. To return to this test profile again, pass the /RootSuffix command line switch when loading the IDE. You can run both profiles at the same time, next to each other. In VS2019 and VS2022 the profile name will be shown just under the close button, in the top right hand corner of the main IDE window. If you export your IDE settings from your main profile you can them import them into the test profile.

Does this help at all? If the problem is specific to your default profile then we should be able to fix this, but I don't want to make assumptions about what is going wrong here.

zen is the art of being at one with the two'ness
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 15 2022 :  04:52:34 AM  Show Profile  Reply with Quote
With the new version I don't have any problems...
Currently I have no time to check this.

Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

xMRi
Tomato Guru

Germany
299 Posts

Posted - Nov 15 2022 :  05:37:38 AM  Show Profile  Reply with Quote
I may test this later:
Other question how do I delete this hive VATest?

Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 15 2022 :  07:43:15 AM  Show Profile  Reply with Quote
At least the current version is working correctly, this is what matters! Thank you for the update.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000