Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Suggesstions are committed on dot
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Kinstewar
Junior Member

19 Posts

Posted - Aug 22 2021 :  07:07:27 AM  Show Profile  Reply with Quote
VS2019
C#

When I type var name and suggestion list appears then if I type "." a first suggestion is committed but I expect a member list to appear

The docs says there is a list of committing chars in the VS settings but I cant find that

It's definitely VA issue cause it disappears if I turn off VA completely

Edited by - Kinstewar on Aug 23 2021 06:02:21 AM

feline
Whole Tomato Software

United Kingdom
17384 Posts

Posted - Aug 23 2021 :  07:09:54 AM  Show Profile  Reply with Quote
I am not really following what you are typing. For the very simple C# code:

var name = "hello world";
var nameLong = "Another hello world";
name|

where | is the caret, when I have just typed "name" I have a listbox open, since I might want "name" or "nameLong" or something else. If I type a dot at this point the listbox is being accepted, but that is reasonable since I have typed a full variable name.

If I disable VA via:

VAssistX -> Enable/Disable Visual Assist X

and retype the "name" line and again type the dot, I get the same behaviour.

Can you please explain what you are doing, and what you are expecting to happen?

zen is the art of being at one with the two'ness
Go to Top of Page

Kinstewar
Junior Member

19 Posts

Posted - Aug 23 2021 :  08:29:08 AM  Show Profile  Reply with Quote
Ive captched a video with the issue, take a look https://youtu.be/sbcHMjCLv7M

So I type 'i' then '.' and expect to get 'i.' along with the dropdown with list of members
instead I get 'int.'

and I meant it happens with any variable not only with the ones declared as 'var'

Edited by - Kinstewar on Aug 23 2021 08:34:00 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17384 Posts

Posted - Aug 23 2021 :  09:45:20 AM  Show Profile  Reply with Quote
OK, so you are writing a C# lambda expression inside the Find function on a List.

Testing the same thing here, I don't get this problem even with VA active.

If you escape the listbox and type the code, does VA show the variable "i" in bold? This assumes you have:

VA Options -> Coloring and Attributes -> Show local symbols in bold

turned On. I am trying to work out if VA understands what is going on here, or if it is confused in this code.

There is a list of characters for committing a listbox, but its a C++ setting, not a C# setting. But it does look like a setting is having an effect.

Can you please export your VA and IDE settings and send them to me:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

I can then import them here and see if I can reproduce the problem. Please send me the files via email:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

Kinstewar
Junior Member

19 Posts

Posted - Aug 23 2021 :  12:10:20 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline
If you escape the listbox and type the code, does VA show the variable "i" in bold? This assumes you have:
VA Options -> Coloring and Attributes -> Show local symbols in bold



yes I have this option enabled but never get 'i' in listboxes neither bold nor normal

Edited by - Kinstewar on Aug 23 2021 5:40:50 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17384 Posts

Posted - Aug 24 2021 :  07:16:11 AM  Show Profile  Reply with Quote
Apologies, I wasn't clear enough. I was talking about symbols in the editor, in your code, being shown in bold.

I have your settings, thank you for these. Turning on:

VA Options -> Coloring and Attributes -> Show local symbols in bold

"i" in my test code isn't shown in bold, but I haven't yet worked out why. It is being shown in bold with my normal settings. I am looking into this.

A temporary solution is to turn Off:

VA Options -> Suggestions -> Enable Suggestion Lists

zen is the art of being at one with the two'ness
Go to Top of Page

Kinstewar
Junior Member

19 Posts

Posted - Aug 24 2021 :  09:48:10 AM  Show Profile  Reply with Quote
quote:
Originally posted by feline

Apologies, I wasn't clear enough. I was talking about symbols in the editor, in your code, being shown in bold.

I have your settings, thank you for these. Turning on:

VA Options -> Coloring and Attributes -> Show local symbols in bold




Ah, I've always kept it turned off, never used
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17384 Posts

Posted - Aug 24 2021 :  11:48:28 AM  Show Profile  Reply with Quote
This is actually being caused by:

case=88596

VA does not understand the parameter you are creating at the start of the Lambda / Linq statement, so it does not know to suggest it. In my test case there was already a variable called "i" so VA knew to suggest "i" in this case, so I wasn't seeing the problem.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000