Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Create implementation missing
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

xMRi
Tomato Guru

Germany
289 Posts

Posted - Mar 30 2021 :  02:22:45 AM  Show Profile  Reply with Quote
I have an existing class.
I add the declaration for a function. For example I add the destructor.
I don't leave the line.
Than I open the context menu on this line.

"Create implementation" is missing.

I have to leave the line. Return to the line and than the menu contains this item.
Is there a setting missing in my installation or is this a bug.

Also it seams that waiting some time helps.

Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming

feline
Whole Tomato Software

United Kingdom
17242 Posts

Posted - Mar 30 2021 :  07:22:42 AM  Show Profile  Reply with Quote
If our parser hasn't yet parsed your change, then VA won't know what commands to offer on the function name. The obvious way to watch for this, to check for this, is if the new symbol is coloured correctly.

Testing this here, using VS2019 and VA 2399.0, in a small .h file, I added a new function to an existing class. I typed the semi-colon at the end of the line and paused for a moment, mainly to move my fingers to the cursor keys, while watching the screen. This pause was long enough for the new function to be coloured by VA as a function. When I triggered the Alt-Shift-Q, refactoring context menu, on the function name, Create Implementation was listed.

I was careful that the caret didn't leave the line during this test.

Which IDE and version of VA are you using?

How large, how many lines, in the file where you are seeing this problem?

File size and complexity can effect how quickly VA parses your changes. But for context, my large test file 23,000 lines long. In a "normal" file there should be very little delay before VA understands the code, assuming the code is well formed. If your code is mid edit, and is full of mismatched brackets then this will confuse our parser to a degree, but this doesn't sound like its the problem you have.

zen is the art of being at one with the two'ness
Go to Top of Page

xMRi
Tomato Guru

Germany
289 Posts

Posted - Mar 31 2021 :  02:42:53 AM  Show Profile  Reply with Quote
I am using VS-2019 19.9.2, latest VAX version.

More than 200 Header and 200 CPP files. (including library includes maybe 500 header files?)
The file and class were I saw it header = 200 lines, CPP source 3300 lines.


Martin Richter [rMVP] WWJD http://blog.m-ri.de
"A well-written program is its own heaven; a poorly written
program is its own hell!" The Tao of Programming
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17242 Posts

Posted - Mar 31 2021 :  07:57:52 AM  Show Profile  Reply with Quote
How responsive is VA when it comes to applying its syntax highlighting, and bold for local variables, assuming you have this turned on, when you edit?

If you were talking a really massive solution or file then that might explain the delay and problem you are seeing, but these numbers are not that large at all. Which suggests that something else is behind this problem, now we just need to try and find it.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000