Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VA 2393 - IntelliSense boxes in text editor
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Mike
New Member

United Kingdom
3 Posts

Posted - Nov 14 2020 :  12:37:07 PM  Show Profile  Reply with Quote
The IDE IntelliSense boxes that display when hovering on variables, functions etc. on the right hand side of the screen are running beyond the screen limits on my laptop. Sometimes the box displays correctly for a frame or two before shitfing right into a new position and remaining there. Much/most of the text within disappears beyond the screen edge rendering the box largely useless.

Disabling Visual Assist cures this problem and the IDE displays the same box with its right edge correctly aligned to the screen edge.

This problem was present in build 2389 and remains in build 2393.

This is happening with Visual Studio 2015 Professional on Windows 10 Home with a screen resolution of 1366 x 768 (and no windows zoom enabled). Screens attached. The second screen (with the _IDE suffix) was taken with Visual Assist disabled from the menu and shows the correct behaviour.









Edited by - Mike on Nov 14 2020 12:37:39 PM

ChrisG
Whole Tomato Software

USA
220 Posts

Posted - Nov 14 2020 :  12:40:47 PM  Show Profile  Reply with Quote
I am sorry you are having this issue. I remember we reported a very similar issue to Microsoft for VS 2019 and they fixed it. I suppose upgrading might not be an option. Can you reproduce it fairly reliably? It is interesting and unexpected that the issue goes away when you disable Visual Assist.
Go to Top of Page

Mike
New Member

United Kingdom
3 Posts

Posted - Nov 14 2020 :  1:13:12 PM  Show Profile  Reply with Quote
Hi Chris,

This happens almost all of the time for any box that's wide enough to need clipping to the screen boundary. I also thought it strange that it only occurs with VA enabled.

I'm not sure if it's related to my limited screen space. I don't have access to my external displays just at the moment to check behaviour at higher resolutions. If that situation changes I'll update here with my findings. I don't recall seeing it before at 1920x1080 or better, but I haven't done any coding for a few months so I really don't remember.

If it's a Microsoft problem then I guess I'll have to live with it anyway given the lack of support for 2015 now.
Go to Top of Page

Mike
New Member

United Kingdom
3 Posts

Posted - Nov 14 2020 :  1:34:01 PM  Show Profile  Reply with Quote
Update: I've discovered that the problem is linked to "Show floating button for Quick Actions and Refactoring". Disabling that in VA stops the problem completely.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17013 Posts

Posted - Nov 16 2020 :  09:29:38 AM  Show Profile  Reply with Quote
Thank you for the update. This makes a degree of sense, since the tooltip can shift to make sure that both the tooltip and the VA quick action floating button both display near the caret.

Now I know what to look for, I am seeing the same problem here:

case=143094

monitor resolution doesn't seem to matter, its just easier to end up encountering this problem with a lower screen resolution.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000