Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Parsing issue
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Steve Peters
New Member

USA
4 Posts

Posted - Mar 04 2020 :  12:29:43 PM  Show Profile  Reply with Quote
Every time I open an Unreal Engine project in VS 2019, VA parses the project.

feline
Whole Tomato Software

United Kingdom
16714 Posts

Posted - Mar 05 2020 :  06:27:25 AM  Show Profile  Reply with Quote
When you say VA parses the project, do you mean your game project, or the Unreal Engine project, or both?

Which version of VA are you using?

Do you have:

VA Options -> Unreal Engine -> Enable support for Unreal Engine 4

turned On or Off?

If you look in:

VA Options -> C/C++ Directories

are your Unreal Engine directories being listed in the list of stable include directories? They should be, but I wonder if they are not being listed.

zen is the art of being at one with the two'ness
Go to Top of Page

Steve Peters
New Member

USA
4 Posts

Posted - Mar 05 2020 :  5:24:50 PM  Show Profile  Reply with Quote
Under VA Options->C?C++ Directories there are no Unreal Engine directories
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16714 Posts

Posted - Mar 06 2020 :  2:43:25 PM  Show Profile  Reply with Quote
How have you downloaded Unreal Engine? Have you downloaded and installed the Epic Games Launcher, and installed the Unreal Engine editor from here?

Or did you download the source code for Unreal Engine, compile it, and launch the engine from here?

How did you create your current solution? Was it created via the Unreal Editor, or some other method?

Inside Visual Studio, if you show Solution Explorer, do you have an "Engine" project holding a UE4 folder inside your project?

zen is the art of being at one with the two'ness
Go to Top of Page

Steve Peters
New Member

USA
4 Posts

Posted - Mar 07 2020 :  12:30:40 AM  Show Profile  Reply with Quote
The project was built with the Unreal Editor, and I have not compiled the source code. The engine folder is in the solution in VS
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16714 Posts

Posted - Mar 09 2020 :  07:26:04 AM  Show Profile  Reply with Quote
I am going to describe what I have here, for a newly created, default C++ First Person shooter Unreal project, which VA understands quite happily. Can you please compare this with what you have on your system, and see if there are any obvious differences that might help to explain why this is not working for you.

I am using VS2017 and VA 2366.0

The solution was generated in the default location of:

C:\Users\colin\Documents\Unreal Projects\CppFirstPerson
so I have the two files:

C:\Users\colin\Documents\Unreal Projects\CppFirstPerson\CppFirstPerson.sln
C:\Users\colin\Documents\Unreal Projects\CppFirstPerson\CppFirstPerson.uproject

the SLN file references the two project files:

C:\Users\colin\Documents\Unreal Projects\CppFirstPerson\Intermediate\ProjectFiles\CppFirstPerson.vcxproj
C:\Users\colin\Documents\Unreal Projects\CppFirstPerson\Intermediate\ProjectFiles\UE4.vcxproj

The "CppFirstPerson.vcxproj" file references the source code inside this project directory, as expected.

The "UE4.vcxproj" file references the Engine source code inside:

..\..\..\..\..\..\..\Program Files\Epic Games\UE_4.20\Engine
which gives me the absolute path:

C:\Program Files\Epic Games\UE_4.20\Engine
When I load Visual Studio 2017 and look at Solution Explorer, the solution says it contains 2 projects, the very first line in Solution Explorer, the root of the tree.

zen is the art of being at one with the two'ness
Go to Top of Page

Steve Peters
New Member

USA
4 Posts

Posted - Mar 24 2020 :  12:57:43 PM  Show Profile  Reply with Quote
I'm using VS 2019, unreal engine 4.24, and VA 2366.

All other info is essentially the same. It only seems to parse if I shut the computer down for the night. If I close and reopen the project it doesn't parse.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16714 Posts

Posted - Mar 25 2020 :  06:05:10 AM  Show Profile  Reply with Quote
Is your solution, or version of Unreal Engine, being updated? Shutting down or rebooting the computer should have no effect on VA, but if you are also doing a source control update at the same time then this would help to explain why VA thinks something has changed.

If you watch the status bar messages, at the bottom of the IDE window, is VA parsing just your solution, or is it also parsing the Unreal Engine source code as well? Since you have not compiled the Unreal Engine from source code, the engine its self should not be changing on a daily basis.

If you turn On:

VA Options -> Coloring and Attributes -> Show stable symbols in italics

are Unreal Engine symbols being shown in Italic? I want to make sure that VA is picking up your Unreal Engine library as a set of stable include directories.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000