Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Capital 'T' autocompletes to 'typename'
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

tommie
New Member

8 Posts

Posted - Feb 18 2020 :  04:40:11 AM  Show Profile  Reply with Quote
After I type the following lines of code:

template< typename T >
std::pair<T

Visual Assist autocompletes the capital 'T' to the 'typename' keyword, so that I end up with:

template< typename T >
std::pair<typename, 

which is obviously wrong. Is there any way to disable this? I already unchecked all sub-tick-boxes under "Enable suggestion lists", but only disabling "Enable suggestion lists" altogether makes the issue go away. I'm using Visual Studio 2019.

feline
Whole Tomato Software

United Kingdom
16433 Posts

Posted - Feb 18 2020 :  07:46:45 AM  Show Profile  Reply with Quote
Can you please try Enabling the following options:

VA Options -> Suggestions -> Enable Suggestion Lists
VA Options -> Suggestions -> Show only suggestions in completion lists
VA Options -> Suggestions -> Suggestion and Completion lists
Enable in C++

and see what effect this has? If you are still seeing the problem, can you please look and see if you have:

VA Options -> Enhanced Listboxes -> Commit selection with - Additional characters

turned On or Off, and if this is turned On, try turning it Off?

I think this is covered by:

case=83212

but it seems to only happen with specific combinations of settings and certain code.

zen is the art of being at one with the two'ness
Go to Top of Page

tommie
New Member

8 Posts

Posted - Mar 04 2020 :  10:26:42 AM  Show Profile  Reply with Quote
My apologies for the slow reply!

I tried your suggestions, with the following results:

VA Options -> Suggestions -> Enable Suggestion Lists <-- problem goes away (but no autocompletion)
VA Options -> Suggestions -> Show only suggestions in completion lists <-- problem remains
VA Options -> Suggestions -> Suggestion and Completion lists -> Enable in C++ <-- problem goes away (but no autocompletion)
VA Options -> Enhanced Listboxes -> Commit selection with - Additional characters <-- no autocompletion, but wrong suggestion remains

These results are as expected, the problem is only omitted if autocomplete features are turned off all together. The basic issue seems to be that the suggestion is wrong, and that the template name 'T' itself doesn't come up as a valid suggestion. The latter is also true if I change it to something longer:

template< typename LongParameterName >
std::pair<LongParam  <- the word 'LongParameterName' never comes up as a suggestion

So the real solution might be to somehow include template parameters in the suggestions.

Edited by - tommie on Mar 04 2020 10:30:31 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16433 Posts

Posted - Mar 09 2020 :  10:05:42 AM  Show Profile  Reply with Quote
No problems with the slow reply, there are always things to be done. Agreed, it would be more helpful if VA suggested the template parameter, which is something we are aware of:

case=8462

For the listbox being accepted on typing, I am finding slightly different settings required in different versions of the IDE. In VS2015 and VS2017, turning On:

VA Options -> Suggestions -> Enable Suggestion Lists

even if you don't enable any of the other settings should be enough to fix the problem. For VS2019 turning Off

VA Options -> Suggestions -> Show only suggestions in completion lists = OFF

should help.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000