Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Capital 'T' autocompletes to 'typename'

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
tommie Posted - Feb 18 2020 : 04:40:11 AM
After I type the following lines of code:

template< typename T >
std::pair<T

Visual Assist autocompletes the capital 'T' to the 'typename' keyword, so that I end up with:

template< typename T >
std::pair<typename, 

which is obviously wrong. Is there any way to disable this? I already unchecked all sub-tick-boxes under "Enable suggestion lists", but only disabling "Enable suggestion lists" altogether makes the issue go away. I'm using Visual Studio 2019.
3   L A T E S T    R E P L I E S    (Newest First)
feline Posted - Mar 09 2020 : 10:05:42 AM
No problems with the slow reply, there are always things to be done. Agreed, it would be more helpful if VA suggested the template parameter, which is something we are aware of:

case=8462

For the listbox being accepted on typing, I am finding slightly different settings required in different versions of the IDE. In VS2015 and VS2017, turning On:

VA Options -> Suggestions -> Enable Suggestion Lists

even if you don't enable any of the other settings should be enough to fix the problem. For VS2019 turning Off

VA Options -> Suggestions -> Show only suggestions in completion lists = OFF

should help.
tommie Posted - Mar 04 2020 : 10:26:42 AM
My apologies for the slow reply!

I tried your suggestions, with the following results:

VA Options -> Suggestions -> Enable Suggestion Lists <-- problem goes away (but no autocompletion)
VA Options -> Suggestions -> Show only suggestions in completion lists <-- problem remains
VA Options -> Suggestions -> Suggestion and Completion lists -> Enable in C++ <-- problem goes away (but no autocompletion)
VA Options -> Enhanced Listboxes -> Commit selection with - Additional characters <-- no autocompletion, but wrong suggestion remains

These results are as expected, the problem is only omitted if autocomplete features are turned off all together. The basic issue seems to be that the suggestion is wrong, and that the template name 'T' itself doesn't come up as a valid suggestion. The latter is also true if I change it to something longer:

template< typename LongParameterName >
std::pair<LongParam  <- the word 'LongParameterName' never comes up as a suggestion

So the real solution might be to somehow include template parameters in the suggestions.
feline Posted - Feb 18 2020 : 07:46:45 AM
Can you please try Enabling the following options:

VA Options -> Suggestions -> Enable Suggestion Lists
VA Options -> Suggestions -> Show only suggestions in completion lists
VA Options -> Suggestions -> Suggestion and Completion lists
Enable in C++

and see what effect this has? If you are still seeing the problem, can you please look and see if you have:

VA Options -> Enhanced Listboxes -> Commit selection with - Additional characters

turned On or Off, and if this is turned On, try turning it Off?

I think this is covered by:

case=83212

but it seems to only happen with specific combinations of settings and certain code.

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000