Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Comments from source files
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

rtalan
Starting Member

1 Posts

Posted - Jan 02 2007 :  10:00:00 AM  Show Profile  Reply with Quote
I'm not getting my triple slash XML doc comments (VS 2005) and was wondering if VA X might be interfering with that. I am using "Display comments from source files when avaialable." (Yes, I am generating XML docs with /doc from the compiler settings and copying the .xml file to my assembly directory).

Any ideas?

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Jan 02 2007 :  11:38:23 AM  Show Profile  Reply with Quote
Unfortunately all tooltips when hovering the mouse over functions come from the IDE in VS2005. This is on our list of things to fix, but overriding the IDE's tooltips can be rather difficult.

As a result VA's setting to show comments in tooltips does not have any effect, since VA is not actually showing any tooltips.

case=1084

zen is the art of being at one with the two'ness
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Mar 17 2007 :  4:04:10 PM  Show Profile  Reply with Quote
Case 1084 is fixed in build 1549. For VS2005, requires enabling of Quick Info Tooltips in Advanced|General.
Go to Top of Page

computercrustie
Starting Member

1 Posts

Posted - Apr 18 2012 :  01:46:56 AM  Show Profile  Reply with Quote
Hello Guys,

sorry for re-opening such an old post, but it still matches my problem.
I downloaded a trial (10.7.1901.0) before purchasing a license, because I need something showing my xml-comments as tool-tips (such as VS2010 using C# is doing it).

It would be quite ok to see the xml-doc comment as it is (although a preformatted would be nicer), but it still doesn't work.

The comments are mainly written into the source files to avoid rebuilding large projects on header changes if only a documentation has changed.
Each comment-line is preceded by triple slash.

I configured VA(X) to display comments from source files and rebuild everything.

It seems as if doxygen-style comments are working and tooltips for such commented methods are shown. But since VS2010 we're using the XML-Doc syntax of MS, and comments formatted this way aren't shown - no matter if they are written in the header or the source.

What I'm dooing wrong?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Apr 19 2012 :  9:31:53 PM  Show Profile  Reply with Quote
I am seeing the same problem here, thank you for the clear description. /// comments in VS2010 are not showing up in tooltips for me:

case=66239

As a test, can you try changing some of your XML comments to use // rather than /// at the start of the line, and see if this makes a difference? These // comments are being shown in tooltips for me.

zen is the art of being at one with the two'ness
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - May 14 2012 :  11:29:19 PM  Show Profile  Reply with Quote
case=66239 is fixed in build 1906
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000