Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Visual Assist Menu not Showing
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dgregorius
New Member

USA
6 Posts

Posted - Apr 23 2019 :  5:58:06 PM  Show Profile  Reply with Quote
I tried to install the latest update yesterday and due to the broken link it seems it destroyed my installation. When I start Visual Studio 2017 (Community Edition) Visual Assist is not showing in the menu bar anymore and it also doesn't seem to be active. It shows to be installed and enabled in Tools -> Extension and Updates.

I tried re-installing both the current and last version, but the problem persists. I also tried to disable and re-enable in Tools -> Extension and Updates with no success.

This is very frustrating. Any ideas?

accord
Whole Tomato Software

United Kingdom
3280 Posts

Posted - Apr 23 2019 :  9:47:30 PM  Show Profile  Reply with Quote
Have you tried to completely uninstall Visual Assist from the extension manager, and restart Visual Studio before you try installing it again?

Also, after the uninstall and restart, can you please try installing Visual Assist via the extension manager rather then the exe installer to see if it makes any difference?

Edited by - accord on Apr 23 2019 9:48:16 PM
Go to Top of Page

dgregorius
New Member

USA
6 Posts

Posted - Apr 27 2019 :  7:00:11 PM  Show Profile  Reply with Quote
Thanks! I tried all this. In the end I un-installed VS2017 and then installed VS2019. I wasn't planning on upgrading yet, but now it is working again. Pretty annoying issue.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17822 Posts

Posted - Apr 29 2019 :  10:46:46 AM  Show Profile  Reply with Quote
In case you wanted to stick with VS2017 a bit longer, a repair of your install might fix the problem, without having to change IDE's.

Assuming you still have access to VS2017, try running the command:

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv.exe" /RootSuffix VATest

this will load VS2017 with a new, default profile, so you will normally be asked about the settings you want to use. VA will not be installed, but you will be able to download and install VA from the online extension store:

IDE tools menu -> Extensions and Updates...

and install it for this profile. If the problem is due to a problem with your default profile then VA should work correctly here. To load your default profile load VS2017 normally. To return to this profile use the same command line switch again.

zen is the art of being at one with the two'ness
Go to Top of Page

PHansson
New Member

Sweden
2 Posts

Posted - May 27 2022 :  12:12:43 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline

In case you wanted to stick with VS2017 a bit longer, a repair of your install might fix the problem, without having to change IDE's.

Assuming you still have access to VS2017, try running the command:

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv.exe" /RootSuffix VATest

this will load VS2017 with a new, default profile, so you will normally be asked about the settings you want to use. VA will not be installed, but you will be able to download and install VA from the online extension store:

IDE tools menu -> Extensions and Updates...

and install it for this profile. If the problem is due to a problem with your default profile then VA should work correctly here. To load your default profile load VS2017 normally. To return to this profile use the same command line switch again.



Having the same problem as OP in VS2019 with latest VA builds - tried reinstalling VA and re-enabling to no avail.

Then I tried your steps here. I do get VA running inside a different profile specified by /RootSuffix. However, I would rather not be forced to ever run with this command line argument. So is there a way to reset the default profile, or do something else to solve the problem? Just doing a settings reset doesn't work (not too surprising).

Thanks in advance.

Edited by - PHansson on May 27 2022 12:13:07 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17822 Posts

Posted - May 27 2022 :  12:39:21 PM  Show Profile  Reply with Quote
Thank you for trying this, and yes, it is fairly easy to reset the default profile. Before doing so can you please make sure you export your VA and IDE settings, just to be on the safe side, since doing this will reset all of your IDE settings, and you might want them back again afterwards:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

Now close all instances of the IDE and you need to locate the VS2019 default profile directory, which should be:

C:\Users\%USERNAME%\AppData\Local\Microsoft\VisualStudio\16.0*
There should be two directories matching this pattern, both with a hashed directory name. The test profile directory will have VATest on the end of the hashed name, while the default profile will have the shorter directory name. Go into the default profile directory, and then delete the file:

C:\Users\%USERNAME%\AppData\Local\Microsoft\VisualStudio\16.0_*\privateregistry.bin

Now load the IDE, tell it what settings you want to use, and if you go to:

IDE Extensions menu -> Manage Extensions

Visual Assist should still be installed, but shown as disabled. You can now enable Visual Assist, which will require an IDE restart to take effect. Everything should now, hopefully, work correctly in your default profile, and you can reimport your IDE settings, which should be quite safe.

zen is the art of being at one with the two'ness
Go to Top of Page

PHansson
New Member

Sweden
2 Posts

Posted - May 27 2022 :  2:46:55 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline

Thank you for trying this, and yes, it is fairly easy to reset the default profile. Before doing so can you please make sure you export your VA and IDE settings, just to be on the safe side, since doing this will reset all of your IDE settings, and you might want them back again afterwards:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

Now close all instances of the IDE and you need to locate the VS2019 default profile directory, which should be:

C:\Users\%USERNAME%\AppData\Local\Microsoft\VisualStudio\16.0*
There should be two directories matching this pattern, both with a hashed directory name. The test profile directory will have VATest on the end of the hashed name, while the default profile will have the shorter directory name. Go into the default profile directory, and then delete the file:

C:\Users\%USERNAME%\AppData\Local\Microsoft\VisualStudio\16.0_*\privateregistry.bin

Now load the IDE, tell it what settings you want to use, and if you go to:

IDE Extensions menu -> Manage Extensions

Visual Assist should still be installed, but shown as disabled. You can now enable Visual Assist, which will require an IDE restart to take effect. Everything should now, hopefully, work correctly in your default profile, and you can reimport your IDE settings, which should be quite safe.



Perfect, that worked! Thanks so much, this was a very vexing issue overall and I'm glad I found this thread.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17822 Posts

Posted - May 30 2022 :  08:07:25 AM  Show Profile  Reply with Quote
Excellent news, thank you for the update, I am glad that everything is working correctly once more

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000