Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Git extensions brake tooltips
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

bugmenot
New Member

4 Posts

Posted - Jun 18 2014 :  04:46:18 AM  Show Profile  Reply with Quote
I don't know how but turning on Git extensions brake localised letters in tooltips.

If I start without git extensions it's good, but turning it on will change that.





License: trial
VA_X.dll file version 10.8.2036.0 built 2014.05.22
DevEnv.exe version 9.0.30729.1 Professional
msenv.dll version 9.0.30729.1
Font: Courier New 13 (pixels)
Comctl32.dll version 6.10.9200.16384
Windows 8 6.2 Build 9200
4 processors (x86-64, WOW64)
Language info: 1250, 0x415

Platform: Win32
Stable Includes:
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\include;
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\atlmfc\\include;
C:\\Program Files\\Microsoft SDKs\\Windows\\v6.0A\\include;
C:\\Program Files\\Microsoft SDKs\\Windows\\v6.0A\\include;
C:\\Program Files (x86)\\Microsoft DirectX SDK (June 2010)\\Include;
C:\\Program Files (x86)\\Visual Leak Detector\\include;

Other Includes:

Stable Source Directories:
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\atlmfc\\src\\mfc;
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\atlmfc\\src\\mfcm;
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\atlmfc\\src\\atl;
c:\\Program Files (x86)\\Microsoft Visual Studio 9.0\\VC\\crt\\src;



IDE: Visual Studio 2008

Edited by - bugmenot on Jun 18 2014 11:26:48 AM

feline
Whole Tomato Software

United Kingdom
17863 Posts

Posted - Jun 26 2014 :  8:52:09 PM  Show Profile  Reply with Quote
What language are the letters in this comment from? This is not English.

Can you send me a code file that shows this problem, as a zip file, to make sure the encoding is preserved.

Is this where you got the Git extension from?

http://sourceforge.net/projects/gitextensions/

zen is the art of being at one with the two'ness
Go to Top of Page

bugmenot
New Member

4 Posts

Posted - Jun 27 2014 :  08:58:46 AM  Show Profile  Reply with Quote
This is written in polish. PSPad says that is't encoded in UTF-8.

Yes I downloaded it from official site.

I don't know to what email send that but here is link to file at dropbox: https://www.dropbox.com/s/rq442a8mafs4ibd/VAX_t1.zip
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17863 Posts

Posted - Jul 02 2014 :  9:03:55 PM  Show Profile  Reply with Quote
Apologies, I should have included the link for emailing me the files, but I forgot to do so. The dropbox link works just as well though.

I cannot reproduce this problem here. I have tried under both Windows 7 64bit and Windows 8.1, and in both cases the tooltip's I am seeing with your test file are the same before and after installing the Git extension.

What do you mean by "turning on Git extensions"? I have just installed the Git extensions program, only making one change to the defaults in the installer, which was to turn On installing "MsysGit" since the installer said this was required for Git Extensions.

I have a new IDE menu called "Git" in VS2008, but I have not created any form of Git repository. So I am wondering if I am missing a key step here.

Can you please go to Windows Control Panel, and search for "Region"
After you load the Region settings dialog, please look on the Administrative tab, what do you have set for your "Language for non-Unicode programs"? I am testing on a system wit this set to "English (United Kingdom)". This setting might be a factor.

zen is the art of being at one with the two'ness
Go to Top of Page

bugmenot
New Member

4 Posts

Posted - Jul 03 2014 :  4:03:14 PM  Show Profile  Reply with Quote
In region settings i had set Polish, after changing it to Engligh and restarting windows in visual all letters in comment looks like that in tooltip (with git turned on or off).

This works without any repository.

I can turn it off in Tools -> Add-In manager and restarting IDE. Then tooltips are ok but turning git on will change that.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17863 Posts

Posted - Jul 03 2014 :  8:00:33 PM  Show Profile  Reply with Quote
In your first post, which screen shot is which?

I am unable to get VA to show the tooltips "correctly" with or without the Git extension running, but I am not sure what I should be seeing. The Polish letters in the comments changed when I set the Region to Poland. This is what I am seeing, with the Region set to Poland, both for the comment and the tooltip on the first function in the file you sent me:



Since I seem to be seeing something different to what you are seeing, I am wondering what the difference is in our systems. Do you have any thoughts?

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000