Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 [VS11] Syntax coloring issues
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

kufa
New Member

5 Posts

Posted - Apr 11 2012 :  3:06:35 PM  Show Profile  Reply with Quote
Hello,

I'm using VAX 10.7.1903.0 built 2012.04.03, and have the following issues on VS11 (while everything works fine with my VS2010 installation):
- Coloring is not affecting the text editors when switching to the dark theme. The tooltips, VA Navigation bar, etc work fine
- Automatically highlight references doesn't work

Regards,

/d

accord
Whole Tomato Software

United Kingdom
3277 Posts

Posted - Apr 11 2012 :  8:10:01 PM  Show Profile  Reply with Quote
You may find this helpful:
http://forum.wholetomato.com/forum/topic.asp?TOPIC_ID=10640

Does it help?
Go to Top of Page

kufa
New Member

5 Posts

Posted - Apr 12 2012 :  09:33:56 AM  Show Profile  Reply with Quote
Hey hey,

I didn't manage to get VAx colors to work fine when switching to the dark theme, even after importing font/colors settings for a dark theme.
Automatically highlight references doesn't work in both light and dark theme.

/d
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17026 Posts

Posted - Apr 13 2012 :  5:56:05 PM  Show Profile  Reply with Quote
For automatically highlighting references, please try setting:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Reference Highlighting = True

this should stop the IDE highlighting the symbol under the caret, allowing VA's highlighting to show.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17026 Posts

Posted - Apr 13 2012 :  7:11:17 PM  Show Profile  Reply with Quote
I am seeing problems getting VA colours to work correctly in the editor with the dark theme as well, this is a known problem:

case=64155

Have you tried setting the IDE theme to Light, and then changing the editor colours, to set the background colour for Text to black, or a dark colour, and then adjusting your VA colours to match? This is working for me here. Its not the same as the dark theme, but this should help a bit.

zen is the art of being at one with the two'ness
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Apr 16 2012 :  11:36:55 AM  Show Profile  Reply with Quote
We are still working on getting editor colors working properly in the dark theme. Some colors start to work if you set the Foreground and Background settings for the Identifier item to be Automatic.
Go to Top of Page

kufa
New Member

5 Posts

Posted - Apr 23 2012 :  04:35:05 AM  Show Profile  Reply with Quote
Hi Felin and Sean,

I tried changing the 'Disable Reference Highlighting' setting, it indeed make the 'Automatically highlight references to symbol under cursor' to work. That said, I have the 'Disable Database' setting set to True, so the 'Disable Reference Highlighting' option is greyed out. (i.e. I had to temporarily set 'Disable Database' to False to be able to change it).

Looking forward for a proper fix on the color scheme! Will do some tests as soon as I can!

Regards,

/d
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17026 Posts

Posted - Apr 23 2012 :  1:59:07 PM  Show Profile  Reply with Quote
Thank you for the update on 'Disable Reference Highlighting', it is good to know changing this setting helped, and what you had to do to make this change.

zen is the art of being at one with the two'ness
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Jun 01 2012 :  8:54:13 PM  Show Profile  Reply with Quote
case=64155 is fixed in build 1908
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000