Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VS2022 (17.8.0) OpenCorrespondingFile not working

You must be registered to post a reply.
Click here to register.

Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji

Forum code is on.
Html is off.

Check to subscribe to this topic.

T O P I C    R E V I E W
Sassafras Posted - Nov 19 2023 : 5:43:11 PM
My visual studio just updated and this function stopped working. i use it constantly. you can click the little button on the vassist toolbar which does work, but my key bind for it (alt-o) doesn't. i confirmed it is correctly bound (the vassist button displays my bind).

16   L A T E S T    R E P L I E S    (Newest First)
feline Posted - Nov 29 2023 : 08:31:28 AM
I am just not seeing this happen here. OK, new test, starting with VS2022 version 17.6.6, I have just set the keyboard scheme to C# 2005, installed VA 2502, made sure Alt-O is working normally, then installed the VS2022 17.8.2 update.

OK, that reproduces the problem, now Alt-O has been mapped to "Edit.IntilliCode.APIUsageExamples", so it looks like it is a function of the keyboard mapping scheme, at least in part. Remapping Alt-O to open corresponding file works just fine.

By the time we get the next version out with a "fix", assuming this is something we can actually do much about, nearly everyone who is going to install this update will have already done so. I think for now we need to just manually remap Alt-O for those who run into.
FAN Posted - Nov 29 2023 : 07:05:38 AM
For me, it was set to Visual C# 2005. (However, I have never intentionally set it to anything other than Default).

Anyway, after changing the scheme to Default, there was still no "Open Corresponding File" shortcut.

In the default schema, the Alt + O key was again used for the IntelliCode.APIUsageExamples.

feline Posted - Nov 29 2023 : 05:49:56 AM
Which keyboard layout mapping scheme are you using? I am using (Default) as my base.
FAN Posted - Nov 29 2023 : 04:58:55 AM
I had to remove it from Edit.IntelliCode to get it to work.

feline Posted - Nov 28 2023 : 06:31:22 AM
Are you able to map Alt-O to the VisualAssist.OpenCorrespondingFile command, either using the above settings file, or directly in the IDE keyboard settings?

Clearly this is a problem, but I still have no idea what the trigger is, since it is only effecting some people / systems.
FAN Posted - Nov 28 2023 : 04:11:09 AM
After updating Visual Studio to 17.8 I have the same problem.

feline Posted - Nov 24 2023 : 06:53:23 AM
No keyboard mapping is set for the command "Edit.IntilliCode.APIUsageExamples", and I am working with the Default keyboard layout.

It all suggests there is a pattern to when this problem crops up, but I really don't have any good sense of what the pattern could be yet.

Thank you for your kind words, we do try to make sure everything "just works" before it gets to you, so it is good this is working as well as it is
Sassafras Posted - Nov 23 2023 : 2:45:31 PM
Originally posted by feline

Sassafras, can you please go into:

sorry for coming back late to this. work work work. anyways yes. the VS update seemed to have added "Edit.IntilliCode.APIUsageExamples" to alt-o as well. and having two bindings makes neither work it would seem. i did as Eddie mentioned, deleting the extraneous bind, and all as it should be once again.

edit: note fyi, i use visual c++ 6 keyboard mapping scheme

edit 2: it is testament to how wonderful vassist has been in my life, that this is my first tech support post (that the forum labels me "new member"). I've been using vassist since it first launched. I force any employer to buy it for me, and have had it licensed on my own rig for always. I will remain loyal to you guys even if vs 2030 duplicates every one of your features. much love <3
feline Posted - Nov 23 2023 : 11:29:42 AM
The keyboard shortcut is set and exported in the IDE settings for me, so I am still not sure what is going on here. For anyone else who runs into this problem, if you save out the following IDE settings file, as "vs2022_alt_o_keymapping.vssettings" and then import this settings file, this will set the Alt-O keyboard shortcut, without doing anything else:

    <ApplicationIdentity version="17.0"/>
    <ToolsOptions><ToolsOptionsCategory name="Environment" RegisteredName="Environment"/></ToolsOptions>
    <Category name="Environment_Group" RegisteredName="Environment_Group">
        <Category name="Environment_KeyBindings" Category="{F09035F1-80D2-4312-8EC4-4D354A4BCB4C}" Package="{DA9FB551-C724-11d0-AE1F-00A0C90FFFC3}" RegisteredName="Environment_KeyBindings" PackageName="Visual Studio Environment Package">
            <KeyboardShortcuts><UserShortcuts><Shortcut Command="VisualAssist.OpenCorrespondingFile" Scope="Text Editor">Alt+O</Shortcut></UserShortcuts></KeyboardShortcuts>
NOPcode Posted - Nov 21 2023 : 12:59:30 PM
Since I am paranoid, I did a complete disk image before I upgraded VS2022 and was able to pull the config .xml file and diff it between then and now (I used Notepad++ to 'pretty format' the xml so I could actually diff them).
Prior to the 17.8 update, my config DID NOT have the control-O key mapped, which tells me VAX is probably in-memory setting it or handling the keyboard directly to get the action to happen.
After the 17.8, the config file ALSO DID NOT have the control-O key mapped, until I went in and explicitly set it. As pointed out above, without this, control-O default mapping to the File Open command.
My complete outsider takeaway is that 17.8 is doing something different in how it handles keystrokes and/or how VAX is hooking into this system. My gut feeling is that whatever method VAX is doing to get the control-O and other key handling is being affected by this, and I would not be surprised other issues pop up.

PS: one thing I didn't try as a possible test is to remove the control-O setting from the IDE after it's set to see what changes.
feline Posted - Nov 21 2023 : 11:00:53 AM
Even after installing the update on several machines myself, no sign of this keyboard shortcut being reset for me. So what ever is happening here it isn't universal, making it harder to anticipate. The fact that we now have 3 reports though really is NOT reassuring.

If anyone who has run into this is willing to take a moment to export their VA and IDE settings, and send them to me I can try and reproduce the effect by importing the settings on VS2022 17.7.5, and then doing the update, and see what happens. It won't fix the problem, but will at least let me try a few things to see if I can suggest an easy fix.

To export your VA and IDE settings use:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

Then please send me the files via email:

[email protected]

including this thread ID or URL in the description, so we can match it up.
NOPcode Posted - Nov 21 2023 : 08:32:14 AM
FWIW, the update also did this to me, too. The 17.8 update reset it back to File Open, and forcing it back to VAX resolved it.

(and this is why I was asking before if anything odd was going on with 17.8 - Microsoft has gotten VERY bad with updates lately)
feline Posted - Nov 20 2023 : 12:03:51 PM
Thank you for the update. I didn't see this problem, but it is good to know this is "all" that happened. Still, its a concern if the update is going to start doing this on quite a few systems.
Eddie_cz Posted - Nov 20 2023 : 12:02:52 PM
Only key mapping was removed, I guess update overrided it, after deleting intellicode mapping and assigning it to VAssist, it works.
feline Posted - Nov 20 2023 : 11:04:15 AM
This is working correctly for me, using VS2022 version 17.8.0 and VA 2502.0

I have tried the toolbar button, the Alt-O keyboard shortcut and the menu entry:

VAssistX -> Open Corresponding File (h/cpp, aspx/cs)

Sassafras, can you please go into:

IDE tools menu -> Options -> Environment -> Keyboard

and try to map Alt-O to a new command, which will show you which commands, if any, this is currently mapped to, and their scopes. I am wondering if Alt-O isn't correctly mapped to:


or if it is mapped to more than one command at the same time, which might mean a different command is taking the keyboard shortcut instead.

Eddie_cz is this command working via any methods?
Eddie_cz Posted - Nov 20 2023 : 09:14:22 AM
Not working for me too;-(

© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000