Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VA2451. No icons on VS2022

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
MikMik Posted - May 09 2022 : 01:33:22 AM
Hi,
I've just installed VA2451 (Build 2022.2) and I can see no VA icons on the toolbar in VS2022 Enterprise (version 17.1.2, in Spanish).
This is what I get:



6   L A T E S T    R E P L I E S    (Newest First)
AlfredS Posted - May 16 2022 : 12:31:17 PM
Hi ChrisG!
Thanks for the hint. He solved the problem.
BR
Alfred
ChrisG Posted - May 13 2022 : 7:26:53 PM
AlfredS, please try running devenv.exe /setup. It requires elevated privileges. It should reset your VS caches and allow the icons to be loaded in. It should not modify your settings.
feline Posted - May 12 2022 : 07:37:33 AM
Which OS are you using?

I have just installed VS2022 Enterprise version 17.0.5 under Windows 10, on a machine with no instances of the IDE at all, and then installed first VA 2443 and then VA 2451.

Loading a new, default C++ solution both versions of VA show the toolbar icons correctly for me.

So this problem doesn't automatically happen with this version of VS2022, which is something.

Can you please try making a new, default C++ solution and see if you still see this problem, just in case this is somehow solution specific.

How are you loading the IDE? Are you double clicking on a SLN file? Passing any command line arguments to the IDE?

Can you please export your VA and IDE settings and send them to me:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

I can then import them here and see if I can reproduce the problem.

Please send me the files via email:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.
AlfredS Posted - May 12 2022 : 01:17:32 AM
Hi,
I have the same problem with the empty toolbar in Visual Studio Enterprise 2022 (64-bit) Version 17.0.5 when VA2451 is installed.
At the moment we are not able to update to a newer VS-Version.
My previous VA was 10.9.2443.0 built 2022.01.21
Uninstall, and installation of VA doesn't help.
The restart of the VS, PC, and reload of the sln doesn't help.
Any other suggestions?
ChrisG Posted - May 09 2022 : 09:14:37 AM
Thanks for following up. Before you updated VS and the issue resolved, did you try opening a solution? Did you have VA previously installed on this copy of VS?
MikMik Posted - May 09 2022 : 01:44:05 AM
Ok, I've just updated Visual Studio, and now I see the icons...

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000