Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Skip All Breakpoints in VS2015: $tid not defined

You must be registered to post a reply.
Click here to register.

Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji

Forum code is on.
Html is off.

Check to subscribe to this topic.

T O P I C    R E V I E W
tbrammer Posted - Jan 07 2019 : 04:44:25 AM
With VS 2015 C++ "Skip All Breakpoints" brings up an error message for each breakpoint that says (translated from German):

Cant set this breakpoint:
At Filename.cpp, Line 526 ('FuncName()'), if "($tid == 1 && $pid == 1 && "__VAssist_do_not_touch!0$WhenTrue"[0])" is "True"
The identifier ""$tid"" is not definied.

It seems that VS 2015 doesn't fully support $TID.
It is possible print $TID under breakpoint actions. But $tid doesn't work. In the breakpoint conditions neither $TID nor $tid work.

Any possible workaround for this?
12   L A T E S T    R E P L I E S    (Newest First)
tbrammer Posted - Feb 06 2019 : 02:55:10 AM
Thanks :)
sean Posted - Feb 05 2019 : 6:31:36 PM
case=134666 is fixed in build 2316.
sean Posted - Jan 08 2019 : 7:30:52 PM
I've opened a bug report for this: case=134666.
gmit Posted - Jan 08 2019 : 3:20:15 PM
Conclusion so far is:
- works on VS2017
- doesn't work on VS2015 that attaches to x64
- doesn't work on VS2015 that attaches to 32-bit process if "Use native compatibility mode" debugger option is checked (the default is unchecked)

tbrammer is currently happy with VS2017 workaround, but we will see if there is something that can be done for VS2015.
tbrammer Posted - Jan 08 2019 : 11:20:00 AM
In the meantime I have installed VS2017 and use it with VS2015 toolset.
This works fine even with 64 bit debugging. So I'm quite happy now :)
feline Posted - Jan 08 2019 : 11:15:49 AM
Ah, thank you for the update, I will leave Goran looking at this with you. At least now we know why I was not seeing this, but you were.
tbrammer Posted - Jan 08 2019 : 11:12:57 AM
Currently I have a mail dialog with Goran M. from WholeTomato.
It turned out that the problem occurs when debugging 64 bit applications only. 32 bit apps are working fine.

My VS2015 version is:
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.7.03056

Details have been sent to Goran.
feline Posted - Jan 08 2019 : 11:07:42 AM
Apologies, I did not realise VA was setting these conditions. I am seeing VA set the same conditions here, but VS2015 does not have any problems with this for me.

Which version of VS2015 are you using? Which OS are you using?

I am testing Windows 7 64bit, VS2015 version 14.0.25431.01 Update 3.
tbrammer Posted - Jan 07 2019 : 08:34:23 AM
Please don't just disable it! This is the most useful new feature since years!!
We are considering to renew mentainence just to get it. I even intalled VS 2017 to use it (which works great :)
tbrammer Posted - Jan 07 2019 : 08:32:14 AM
VA adds the breakpoint condition if "($tid == 1 && $pid == 1 && ...)" to all breakpoints if you choose "Skip All Breakpoints".
I suppose it just adds a condition that is never TRUE. Just adding if "($pid == 1 && ...)" would work in VS2015 without error messages.
Also it might be better to use the uppercase $PID.
sean Posted - Jan 07 2019 : 08:27:17 AM
ugh... sorry for the problem. We will investigate and see if there are alternatives for us. We may have to simply disable the new commands in VS2015.
feline Posted - Jan 07 2019 : 06:49:54 AM
This is nothing to do with VA, it sounds like Microsoft are working on a fix in the latest version of Visual Studio, based on this page:


© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000