Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VA 2515 Installer recognizes VS components running
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Uniwares
Tomato Guru

Portugal
2320 Posts

Posted - Mar 25 2024 :  06:36:07 AM  Show Profile  Reply with Quote
The installer recognizes executables from the Azure Functions SDK as part of he Visual Studio IDE and does not install while they are running. Specifically the Azurite.exe (Azure Functions Emulator for local debugging) which IS launched by the IDE but can not be ended by existing the IDE.

feline
Whole Tomato Software

United Kingdom
18755 Posts

Posted - Mar 25 2024 :  12:18:10 PM  Show Profile  Reply with Quote
Trying to set up a proper test for this, I have just discovered you cannot uninstall VA from inside VS2022 with the "azurite.exe" process running in the background. Found while downgrading VA so I can properly test installing a new version via either the exe or VSIX installer.

Having "fixed" that, I have confirmed that you cannot install VA with a VSIX installer either if the "azurite.exe" process is running. The VSIX file is just a renamed zip file, so the restriction isn't coming from us, its coming from Visual Studio its self.

I am not sure how much our exe installer knows about what blocking process was the problem, but we do have an open feature request to better inform the end user about problems installing, and this makes for a good test case for testing this reliably:

case=137927

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000