Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Unrecognized Symbols with Unreal Engine
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

notis4044
Starting Member

1 Posts

Posted - Jan 18 2024 :  12:32:21 PM  Show Profile  Reply with Quote
After Visual Assist has fully finished parsing the solution, there are still a large number of engine symbols that are not recognized and are non-navigable. My first thought was that this was an issue with Visual Assist missing part of the UE directories in its included files but I checked the paths of the source files for some of the unrecognized symbols and Visual Assist has their directories properly listed under the "C/C++ Directories" tab in the VA options so seemingly it is aware of the existence of these files. Interestingly, I also noticed that when I manually navigate to the source file for the missing symbol in Visual Studio, VA will then properly find and highlight the symbol. I have tried this with both the binary and the source versions of the engine and have experienced the issue with both versions (in the same way with the same exact symbols). I've also attempted the junction solution that is usually suggested in the forums as a workaround to Unreal directory issues (adding a junction in C:\Program Files\Epic Games to a source version of the engine) but that did not resolve this issue.

Most of the information I've found online addresses problems where VA is not properly including the engine files and that doesn't appear to be the case here so I'm not quite sure what's going but any help would be great appreciated!

feline
Whole Tomato Software

United Kingdom
18746 Posts

Posted - Jan 19 2024 :  06:32:19 AM  Show Profile  Reply with Quote
Having made the file system junction point, have you loaded the Unreal Engine Editor via the junction point path? Or are you still running the UE Editor via its actual path?

My first guess is that VA isn't properly picking up that you are working with Unreal Engine.

Assuming you have:

VA Options -> Coloring and Attributes -> Show system symbols in italics

turned On, are any of the UE symbols being shown in italics in your solution? This is a simple test to see if VA is handling UE as a stable library correctly.

What do you have:

VA Options -> Game Development -> Index plugins (requires restart) = None / Referenced / All

set to? If this is set to None, then obviously this will have some effect.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000