Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Missing buttons in "VA Find References" for vs2022
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

quagfeng
New Member

Germany
2 Posts

Posted - Nov 19 2022 :  4:53:01 PM  Show Profile  Reply with Quote
Hi,

I am using VA 2463. It works fine for vs2019, but for vs2022, some buttons are missing for "VA Find References Results".

Here is a screenshot for vs2019.



But in vs2022, some buttons are missing (marked with red):



Does anyone know how to solve this problem?

The system info is:
Microsoft Visual Studio Community 2022 (64-bit) - Current
Version 17.2.5

VA_X64.dll file version 10.9.2463.0 built 2022.10.25
DevEnv.exe version 17.2.32616.157 Community
msenv.dll version 17.0.32602.167
Comctl32.dll version 6.10.19041.1110
Windows 10 10.0 21H2 Build 19044.2251

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 21 2022 :  06:45:54 AM  Show Profile  Reply with Quote
This is a known bug that we are struggling to reproduce internally:

case=148132

Thankfully normally easy to fix. Can you please close all instances of Visual Studio, and then open a Windows command prompt, running as Administrator. Inside this command prompt please run the command:

"C:\Program Files\Microsoft Visual Studio\2022\Community\Common7\IDE\devenv.exe" /setup

this should fix the missing icons for you.

zen is the art of being at one with the two'ness
Go to Top of Page

quagfeng
New Member

Germany
2 Posts

Posted - Nov 26 2022 :  02:51:24 AM  Show Profile  Reply with Quote
Thx, this fix the issue :)

quote:
Originally posted by feline

This is a known bug that we are struggling to reproduce internally:

case=148132

Thankfully normally easy to fix. Can you please close all instances of Visual Studio, and then open a Windows command prompt, running as Administrator. Inside this command prompt please run the command:

"C:\Program Files\Microsoft Visual Studio\2022\Community\Common7\IDE\devenv.exe" /setup

this should fix the missing icons for you.

Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 28 2022 :  06:44:01 AM  Show Profile  Reply with Quote
Thank you for the update

zen is the art of being at one with the two'ness
Go to Top of Page

tkontos
Junior Member

USA
13 Posts

Posted - Nov 29 2022 :  10:56:49 AM  Show Profile  Reply with Quote
I have had this problem for a while and the 'devenv /setup' always fixes the problem. Since the Win11 22H2 update it happens only after every Windows reboot (hope this helps in your troubleshooting)

Thanos Kontos
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 29 2022 :  11:41:19 AM  Show Profile  Reply with Quote
Thank you for the update. This happening again on reboot is definitely unexpected, but it is another fact to consider, so I have updated the case with this. We are still working on this, but the evidence points to a bug in the IDE, but why we are running into it and not other extensions I am not sure.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000