Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Whole Tomato causing Visual Studio to Crash?
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

karl_loveridge@yahoo.com
New Member

USA
5 Posts

Posted - Sep 21 2022 :  2:22:26 PM  Show Profile  Reply with Quote
I'm using Visual Studio 2019 v. 16.9.4. I've recently been having a lot of crashes where I'm typing a line of code and intellisense will suddenly hang. I always see the Whole Tomato extension trying to do something with suggesting code just before the crash. So the Whole Tomato extension is squarely in my sites as the culprit.

I've disabled the Whole Tomato extension. I haven't seen the crash for a while now. I'm trying to use Visual Studio for the day without it just to be sure.

My extension is up to date. Just wondering if there is something I could delete or cleanup that might fix this?

klove

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Sep 22 2022 :  07:24:22 AM  Show Profile  Reply with Quote
To state the obvious this should not be happening, and I don't think anyone else has reported this problem.

Which programming language or languages are you working in? Corruption in the IDE intellisense database is very rare, but can happen, and can trigger crashes.

So as a first step, can you please try pressing the button:

VA Options -> Performance -> Rebuild symbol databases

which will require an IDE restart to take effect. The next step is to disable IDE intellisense via:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

but obviously this won't have much effect if you only work in C#.

If this doesn't have any effect a mini dump or two of the crash would be most appreciated. There are also further tests we can try as well.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Sep 22 2022 :  07:25:23 AM  Show Profile  Reply with Quote
A random follow up thought, are you working with Unreal Engine? If so, do you have the Unreal Engine extension installed? We did just get a report from one user of regular crashing with VA and the UE extension installed, but we don't have any further details on that yet.

zen is the art of being at one with the two'ness
Go to Top of Page

karl_loveridge@yahoo.com
New Member

USA
5 Posts

Posted - Sep 22 2022 :  08:32:08 AM  Show Profile  Reply with Quote
Haven't tried your solution yet. But to answer your questions. I am working on a custom game engine written in c++. I will give this a try and see if it resolves the issue. Thank you for your response.

klove
Go to Top of Page

karl_loveridge@yahoo.com
New Member

USA
5 Posts

Posted - Sep 22 2022 :  09:08:36 AM  Show Profile  Reply with Quote
Just did your suggestions and will let you know how things go.

klove
Go to Top of Page

karl_loveridge@yahoo.com
New Member

USA
5 Posts

Posted - Sep 22 2022 :  6:05:01 PM  Show Profile  Reply with Quote
Been using VA all day since I did the above recommendations. Haven't seen a crash yet. I'm going to say this is fixed. If it comes back I'll be sure to report it. Thanks again!

klove

Edited by - karl_loveridge@yahoo.com on Sep 22 2022 6:05:23 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Sep 23 2022 :  06:01:32 AM  Show Profile  Reply with Quote
Thank you for the update, it sounds like there was a corruption problem with either the VA or IDE symbol database then. Hopefully this stays fixed and working well for you

zen is the art of being at one with the two'ness
Go to Top of Page

karl_loveridge@yahoo.com
New Member

USA
5 Posts

Posted - Oct 12 2022 :  3:10:48 PM  Show Profile  Reply with Quote
Okay, further working with this issue. So When I did what you suggested, indeed Visual Studio stopped crashing. However, setting IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True means I lost a bunch of useful functions. For instance, I could no longer alt-click on a function or variable to look it up and other similar issues.

So I re-enabled the database (ie, set Disable Database = false), and went again to work. The core functionality all worked as expected but then boom! The crash came back.

So, it appears that the crash is related to the suggestions feature of VA. I went into VA Options, and went to the suggestions catagory and turned off "Enable Suggestion Lists" and have been working. No further crashes at this point.

So somehow, this crash bug might be related to the suggestions list that VA puts up.

klove
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17995 Posts

Posted - Nov 11 2022 :  12:49:53 PM  Show Profile  Reply with Quote
Apologies for the slow reply.

Firstly, can you please try upgrading to VA 2463, https://www.wholetomato.com/downloads

having you on the most recent version always makes debugging things a bit easier. Assuming this doesn't fix the problem, would it be possible to get a mini dump of the crash? If so can you please send it, or a link to it, via email:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.

The fact that it seems to be triggered by VA suggestions firmly suggests that VA is the problem, so it would be good to try and get to the bottom of this, if possible.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000