Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Peek definition really slow with Visual Assist on
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

natdo
New Member

USA
3 Posts

Posted - Oct 25 2020 :  11:23:09 AM  Show Profile  Reply with Quote
Whenever I have Visual Assist turned on and I use peek definition, closing the window takes a really long time. It takes upwards of a few minutes for each peek definition window to close, if it closes at all. As soon as I turn off Visual Assist, the problem completely goes away.

Does anyone know what's going on here? Thanks in advance

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Oct 26 2020 :  07:11:32 AM  Show Profile  Reply with Quote
That is really strange and odd. First up can you please go to:

VA Options -> System Info -> Copy Info

and paste the details (from the clipboard) into your reply. This will give us the basic information about your setup.


How many files do you have in your solution?

If you open VA's Open File in Solution dialog (Alt-Shift-O) the title bar contains two numbers. The first number is the number of files currently listed, which changes as you filter the list. The second number is the total number of files in the list, which is normally the number of files in your solution. What is this second number?

I am just looking to get the basic information here, to give me a sense of your system.

Can you run a CPU monitor when you do this please, and see if the "devenv.exe" process uses most of a CPU core while trying to close the window? It shouldn't, but something is clearly going on here.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Oct 26 2020 :  1:46:14 PM  Show Profile  Reply with Quote
Being discussed via email, case=143010

zen is the art of being at one with the two'ness
Go to Top of Page

Alan Baljeu
New Member

Canada
7 Posts

Posted - Oct 27 2020 :  3:05:57 PM  Show Profile  Reply with Quote
I also have this issue. I tried the Task manager, and found Devenv.exe was using CPU cycles but secondly the source control background process was using cycles. I killed this process and things seemed to improve. Will reply again when the issue recurs.
Go to Top of Page

natdo
New Member

USA
3 Posts

Posted - Oct 27 2020 :  3:48:43 PM  Show Profile  Reply with Quote
I have a monitor setup with mismatched refresh rates (one at 144hz and the other at 60hz). Setting them both to 60hz fixes the issue. I'm currently working with Whole Tomato to detail the bug better.
Go to Top of Page

Alan Baljeu
New Member

Canada
7 Posts

Posted - Oct 27 2020 :  4:23:20 PM  Show Profile  Reply with Quote
My monitors are at 59, 59 and 60.
Go to Top of Page

natdo
New Member

USA
3 Posts

Posted - Oct 27 2020 :  7:21:51 PM  Show Profile  Reply with Quote
As another potential workaround to the bug:

In VA Options->Display, unchecking "Display VA Navigation Bar" also solves the problem.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Oct 28 2020 :  08:52:44 AM  Show Profile  Reply with Quote
natdo, thank you for updating both here and email. Looking at your settings now.

Alan, normally I would say that if disabling the VA context and navigation fields "fixes" the problem then we have an interaction problem between VA and something else, normally another extension installed in your IDE. But it is possible that the monitor refresh rates are interacting, somehow, with the context and definition fields.

Alan, can you please try turning Off:

VA Options -> Display -> Display VA Navigation Bar:

and see if this has any effect?

Do you have any utilities installed to help you work with multiple monitors? Perhaps something that came with your video card drivers?

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17027 Posts

Posted - Oct 28 2020 :  12:40:13 PM  Show Profile  Reply with Quote
Alan, another simple test. If you simply trigger peek definition but don't then move the caret (keyboard cursor) and press Escape to close the peek definition window, do you still see this problem?

If you use the arrow keys to move the keyboard cursor inside the peek definition window, so that VA "moves" it's context and definition fields from the top of the editor window and into the peek definition window, and now press Escape to close the window, do you see any difference?

I am wondering if VA "attaching" its self to the peek definition window, and thus displaying its context and definition fields, is somehow a factor.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000