Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Navigation bar does not list members properly
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

andreypir
New Member

USA
6 Posts

Posted - Sep 30 2020 :  6:02:23 PM  Show Profile  Reply with Quote
interface IDataReader
{
public:
#define PSPUREIMPL(x) =0;
virtual int getDataValSize() PSPUREIMPL({ return sizeof(int); })
virtual bool isMap1010() const PSPUREIMPL({ return false; })
virtual long getVideoSyncCount() const PSPUREIMPL({ return 0; })
};

Navigation bar dropdown lists getDataValSize twice and nothing else.
VA_X.dll file version 10.9.2380.0 built 2020.06.16
DevEnv.exe version 16.7.30413.136 Professional
msenv.dll version 16.0.30413.136
Comctl32.dll version 6.10.18362.720
Windows 10 10.0 1909 Build 18363.720
8 processors (x86-64, WOW64)
Language info: 1251, 0x419

Andrey Pirozhenko

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Oct 01 2020 :  06:04:06 AM  Show Profile  Reply with Quote
which language are you using? It looks like C++, but when I copy and paste this code into VS2019 I am getting compile errors, the IDE does not like the "interface" keyword. Replacing this with "class" allows me to compile the code.

As a first attempt, can you please try adding a semi-colon to the end of the function declarations. I know the macro adds one when it is expanded, but adding an extra semi-colon manually is fixing the problem for me here.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Oct 01 2020 :  06:48:38 AM  Show Profile  Reply with Quote
Adding the semi-colon is the only work around I can find so far. I think this is covered by the bug report:

case=88758

zen is the art of being at one with the two'ness
Go to Top of Page

andreypir
New Member

USA
6 Posts

Posted - Oct 01 2020 :  11:46:55 AM  Show Profile  Reply with Quote
Thank you for speedy response! Yes, this is C++, sorry I did not try to compile this synthetic example. Adding semi-colon makes it work properly.
You said it is covered by a bug report case=88758. Is there any way I can see that case?

Andrey Pirozhenko
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Oct 01 2020 :  1:17:36 PM  Show Profile  Reply with Quote
I like to make sure that examples compile, since sometimes the bug we are looking comes from the fact that the code does not compile, and once the code does compile it makes more sense to our parser.

Unfortunately our bug tracker isn't public, but this thread should be updated when the bug is fixed, and our release notes list what has been fixed in each new build. Sadly I don't currently have an estimate for when this will be fixed, but hopefully adding the extra semi-colons to the end of the macros is a reasonable work around for now.

As an aside I noticed that the extra semi-colons seems to fix a code indenting / formatting issue the IDE was having with the sample code, so not just VA getting a little confused.

zen is the art of being at one with the two'ness
Go to Top of Page

andreypir
New Member

USA
6 Posts

Posted - Oct 01 2020 :  1:20:29 PM  Show Profile  Reply with Quote
Thank you!

Andrey Pirozhenko
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000