Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Visual Assist is deleting code when Tab selecting
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Scipio S
New Member

USA
3 Posts

Posted - Dec 16 2019 :  05:59:28 AM  Show Profile  Reply with Quote
Hello, I'm using Visual Assist 10.9.2353.0, with Microsoft Visual Studio Community 2019 Version 16.4.1, and Unreal Engine 4.23.1

While typing inside the parenthesis of a macro, Visual Assist will give suggestions, that you can use the arrow keys to select, and either enter or tab to select, and auto complete that keyword. For me, lines of code get deleted after pressing Tab or Enter. Here is a video I made of my issue: https://youtu.be/6UX_bmFdBH8 (sorry for quality, the VA suggestion box wouldn't show for normal screen capture)

First, inside the UPROPERTY() macro, I try to type "BlueprintReadWrite", and select the suggestion, by pressing TAB, you can see the code that gets removed directly underneath.

Second, inside the UFUNCTION() macro, I delete the already existing "BlueprintCallable", and then try to replace it, using the VA suggestion box, but this time I use Enter to select the suggestion, code still gets deleted, but the () gets moved down a line.

Third, inside the UCLASS() macro, I delete "Blueprintable" then click around to different files in Visual Studio, then wait a few seconds, I don't know, just to do something different. THIS TIME, nothing gets deleted, but in addition to auto completing Blueprintable, it adds 1 tab space after the word.

I just tried uninstalling, and reinstalling via the visual studio extension manager. Why is this happening?

Edited by - Scipio S on Dec 16 2019 06:06:36 AM

feline
Whole Tomato Software

United Kingdom
16280 Posts

Posted - Dec 16 2019 :  1:14:38 PM  Show Profile  Reply with Quote
That should definitely not be happening, and it does not happen here for me.

First, just to double check, can you please go into VA options -> Suggestions, and turn Off all of the settings, except for the two settings:

VA Options -> Suggestions -> Enable Suggestion Lists

VA Options -> Suggestions -> Suggestion and Completion lists
Enable in C++

does this make any difference?

Do you have any other extensions installed that might be having an effect here? For example any extensions to make the editor behave like a different editor, e.g. Vim?

Are listboxes inserting code correctly? I am wondering if this problem is limited to just inside UE macros, or if it is happening other places as well.

zen is the art of being at one with the two'ness
Go to Top of Page

Scipio S
New Member

USA
3 Posts

Posted - Dec 16 2019 :  4:48:54 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline
VA Options -> Suggestions -> Enable Suggestion Lists

VA Options -> Suggestions -> Suggestion and Completion lists
Enable in C++

does this make any difference?

Do you have any other extensions installed that might be having an effect here? For example any extensions to make the editor behave like a different editor, e.g. Vim?

Are listboxes inserting code correctly? I am wondering if this problem is limited to just inside UE macros, or if it is happening other places as well.



Trying your first suggested settings, no, now "BlueprintReadWrite" and others do not show up now, but when I select another option, code is still getting deleted and formatted wrong.

Listboxes have the same effect..

The only VA settings I have changed are to the recommended settings on the getting started page.

This is a fresh Visual Studio, the only VS setting I have changed is comments from green to grey.

The only extensions I have installed is Visual Assist, and Incredibuild 1.5.0.10

Edited by - Scipio S on Dec 16 2019 4:50:32 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16280 Posts

Posted - Dec 17 2019 :  06:06:08 AM  Show Profile  Reply with Quote
Can you please try disabling the Incredibuild extension, and see if this makes any difference? I think this might be being caused by a bug in Incredibuild, which should be fixed in the latest version of the Incredibuild extension.

zen is the art of being at one with the two'ness
Go to Top of Page

Scipio S
New Member

USA
3 Posts

Posted - Dec 17 2019 :  5:56:37 PM  Show Profile  Reply with Quote
That fixed it! Looks like we can't use IncrediBuild with Visual Assist, since it appears there have been conflicting issues since 2013, but that's okay. I would rather have a similar IDE to what Epic Games uses, then have faster build times.

Thank you for helping me solve my issue! Without knowing that IncrediBuild was causing this, my searches were turning up nothing on this issue. Definitely consider making a Sticky about this so other noobs-like-me trying to get started don't run into what I did.

Thank you, take care, and have a great day!
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16280 Posts

Posted - Dec 18 2019 :  07:58:31 AM  Show Profile  Reply with Quote
Are you using the latest version of the IncrediBuild extension? If not, can you please look for an update? Other users who are also using IncrediBuild have reported that the latest version of their extension fixes this problem, so you can have both at once

zen is the art of being at one with the two'ness
Go to Top of Page

aurum
Starting Member

1 Posts

Posted - Jan 07 2020 :  06:07:56 AM  Show Profile  Reply with Quote
Just a shout for this issue: I was able to fix it without disabling or downgrading Incredibuild extension, just by running VisualStudio with Admin Rights.

Hope it helps.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16280 Posts

Posted - Jan 07 2020 :  11:48:52 AM  Show Profile  Reply with Quote
Thank you for the update, it is interesting to know that this helped.

Out of interest, did installing the latest version of Incredibuild make any difference, or is there a reason you are not able to try this version?

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000