Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VAX Highlighting... Just Stopped Working?
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

PeterGV@osr.com
New Member

USA
7 Posts

Posted - Mar 13 2019 :  6:03:22 PM  Show Profile  Reply with Quote
I don't know why, but... suddenly... my syntax highlighting stopped working. Particularly, I'm missing my "Highlight write references using" and "read references using" (see below).

When I hover over a variable... no highlights (but I see the declaration in a "little window". When I click on a variable, I get VS light gray highlights.

Other highlighting features ALSO appear to be no longer working: Mismatching brace highlighting, solution file paths in the Build Output window both seem to NOT be working (though checked).

Yes, I've restarted VS multiple times. Rebooted my system... no change.

Windows 1803, latest version of VAX (10.9.2324.0 updated minutes ago), latest version of VS 2017 (15.9.9)

(for some reason, the PNG I've tried to upload hasn't worked... but in any case, the description should be pretty clear above).

PeterGV@osr.com/201931318410_Capture.PNG" border="0">



Edited by - PeterGV@osr.com on Mar 13 2019 6:15:32 PM

accord
Whole Tomato Software

United Kingdom
3153 Posts

Posted - Mar 13 2019 :  7:44:34 PM  Show Profile  Reply with Quote
First of all, can you please try disabling Visual Assist and then enable it again?

1. Go to the extension manager: Tools -> Extensions and Updates...
2. Find Visual Assist in the list
3. Click Visual Assist and then click Disable
4. Restart Visual Studio
5. Enable Visual Assist through the extension manager the same way
6. Restart Visual Studio again

Sometimes color priorities get messed up by VS and this usually helped in the past. Let us know whether this fixed your problems you are seeing.

Edited by - accord on Mar 13 2019 7:45:53 PM
Go to Top of Page

PeterGV@osr.com
New Member

USA
7 Posts

Posted - Mar 13 2019 :  9:58:18 PM  Show Profile  Reply with Quote
OK!

The procedure above, alone, did not fix the problem. But AFTER the procedure above, I went to Visual Assist options, and disabled syntax highlighting. Closed the options dialog. Saw that VS highlighting still was enabled. I opened the Visual Assist options dialog again, and ENABLED syntax highlighting... a Visual Assist dialog popped telling me that "Visual Studio highlighting was also enabled, did I want to disable VS highlighting" -- I clicked YES, and... BINGO! My pink and blue highlights are back.

THANK YOU for your very rapid reply to my post. You know... I bet most Visual Assist users have one feature that they love the most, and for me (believe it or not) is that pink and blue highlighting. Seriously. Such a small thing, but I hate to live without it.

So... thanks for helping me get back my favorite feature!

Peter
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3153 Posts

Posted - Mar 13 2019 :  10:01:29 PM  Show Profile  Reply with Quote
I'm glad it is working now. Thank you for the follow up. This was one of the possible things to try among several, but I didn't want to flood you with all of them at once.

What about the () highlighting? Did it start working?
Go to Top of Page

PeterGV@osr.com
New Member

USA
7 Posts

Posted - Mar 13 2019 :  10:03:43 PM  Show Profile  Reply with Quote
Thank you for asking, and sorry for neglecting to mention that. Yes, indeed! My mismatched brace highlighting it WORKING again.

Oh, happy day :-)

Peter
(and if your location is correct and you really ARE in the UK... you're working awfully late. Heck, I'm on the East Coast of the US and it's 10PM HERE)...

Edited by - PeterGV@osr.com on Mar 13 2019 10:04:34 PM
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000