Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Snippet Input Placeholder Issue
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jharder
New Member

2 Posts

Posted - Apr 28 2022 :  11:51:09 AM  Show Profile  Reply with Quote
Hey everyone,

I am currently trying to add new Snippets and can't get the Input Placeholders working. I am using Visual Studio 2019 and am using the Visual Assist version: 10.9.2443.0 built 2022.01.21.

Any snippet with defined input placeholders, e.g. $varname$, does not open a popup for me to enter a text. This happens with newly created and already existing snippets.

But I think this is the correct syntax when reading the documentation. Could this be a bug, or am I using the snippet tool wrong?

Any help would be appreciated.

accord
Whole Tomato Software

United Kingdom
3280 Posts

Posted - Apr 28 2022 :  12:10:18 PM  Show Profile  Reply with Quote
In-line Prompt may be used while using input placeholders, see the In-line Prompt section of this document:

https://docs.wholetomato.com/default.asp?W264

Do you get something like this? When in-line prompt is used, you get to the editor immediately and the text is selected for you to overwrite. When multiple placeholders are used, you can navigate through them via tab. Enter exits this mode.

You can force VA to always use dialogs:
https://docs.wholetomato.com/default.asp?W672

If you don't get the inline snippet either, can you please paste the exact snippet you are trying to use to your reply so I can test it on my side?
Thanks.

Edited by - accord on Apr 28 2022 12:12:11 PM
Go to Top of Page

jharder
New Member

2 Posts

Posted - Apr 29 2022 :  04:34:04 AM  Show Profile  Reply with Quote
Hey accord and thanks for the quick response.

Then it was indeed a misunderstanding on my side. The In-line Prompt was working as intended, but I wasn't aware of it. Also the registry entry to enable prompt dialogs works well.

Sorry for the inconvenience and thanks for clarification! I am looking forward to now being able to use the snippet tool and save a lot of time.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000