Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VA 2375 / VS 16.6.0 Poor typing performance
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Biohazard
New Member

Germany
5 Posts

Posted - Jun 01 2020 :  3:52:26 PM  Show Profile  Reply with Quote
Hello,
since updating to 2375 I am experiencing horrendous auto completion/typing performance in Visual Studio.

Disabling VA or unchecking "Suggestion and Completion list - enable in C++" solves this issue.

I'd really like to have this fixed. At least my keypresses are not being swallowed, but the unresponsiveness of Visual Studio is quite an impediment.

Please let me know if there is anything I can do/try to solve this or what kind of information I can send you to help look into this.

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 02 2020 :  08:40:27 AM  Show Profile  Reply with Quote
Are you working only in C++, or other programming languages as well?

Can you check your CPU usage and see if you are seeing a CPU usage spike, perhaps only on one core, when this slow down happens? CPU is the obvious concern here, but I don't want to just assume this is the problem.

How many files do you have in your solution?

If you open VA's Open File in Solution dialog (Alt-Shift-O) the title bar contains two numbers. The first number is the number of files currently listed, which changes as you filter the list. The second number is the total number of files in the list, which is normally the number of files in your solution. What is this second number?

I am wondering if solution size could be a factor.

If you create / open a new, blank .cpp or .h file, do you still get the slowdown there as well? It is possible that this problem is file or even solution specific, so this might help to tell us if that is the case.

zen is the art of being at one with the two'ness
Go to Top of Page

Biohazard
New Member

Germany
5 Posts

Posted - Jun 02 2020 :  08:55:39 AM  Show Profile  Reply with Quote
Thanks for replying.

Yes, I can see one CPU thread spiking seemingly at the same time auto complete is working on generating a list.

The solution has 540 files in 38 projects. It's solely C++ and I'm using CMake to generate the solution.

When typing in an empty file, I can observe the same problem as soon as I type anything that would trigger the auto completion box to pop up. For example when adding an include.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 03 2020 :  08:52:19 AM  Show Profile  Reply with Quote
The CPU spike at least makes sense here. The solution size is far to small for this to be a solution size, or number of files problem. The fact that this happens in an empty file means we can rule out something further up the file being the trigger as well.

Have you had the time to see if this is solution specific?

A silly question, but have you tried a reboot yet? I am just wondering if something, perhaps another IDE process, is somehow open in the background and causing problems.

If this doesn't help, can you please try closing all instances of the IDE and then running the command:

"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\devenv.exe" /RootSuffix VATest

if you are not using the Professional version of VS2019 you will need to adjust the path to "devenv.exe" accordingly. This will create and load the IDE with a new, default profile, separate from your normal default profile. So none of your settings, and most of your extensions won't carry across.

Can you please load your solution in this instance, and just check that there is no slow down when typing. The downloaded VA installer won't install into a second instance, so can you instead use the:

IDE Extensions menu -> Manage Extensions

dialog to download and install Visual Assist into this test profile, and see if you get the same performance problem here? I am trying to find out if there is something about your profile, perhaps an extension, or perhaps your settings, that is the trigger here.

To return to your normal default profile just load the IDE normally. To return to this test profile you need to pass the command line switches again. You can even run both profiles at the same time, in two instances of the IDE, but this can get confusing

zen is the art of being at one with the two'ness
Go to Top of Page

Biohazard
New Member

Germany
5 Posts

Posted - Jun 03 2020 :  10:07:53 AM  Show Profile  Reply with Quote
I had already fully restarted before and this did not help unfortunately.

I have experienced the same issue in other solutions since updating to 2375. The only other extension I have is VMicro, disabling it didn't help, and the solutions I am working with right now are not Arduino related (which is all VMicro should ideally care about).

Creating a new profile and installing Visual Assist there seems to work, the typing performance isn't affected anymore with VA enabled. Even my initial solution that I had this issue with seems to work without notable performance degradation.

How can I clean up this new profile later? Is all I need to do delete the VATest folders from my appdata folder?

Please let me know what to try next. I'm happy to reset the settings of VA, just don't know where. I would like to avoid resetting the settings of VS though.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 03 2020 :  12:07:02 PM  Show Profile  Reply with Quote
The trigger is something in your default profile. This could be a settings problem, something due to VMicro, or possibly a corruption problem inside your default profile, which I have occasionally seen happen.

If you export your IDE settings from your default profile:

IDE tools menu -> Import and Export Settings -> Export selected environment settings

you can then import them into your test profile, and see if this makes any difference. Your IDE configuration should now be the same in both profiles, but hopefully the typing speed will still be correct. Your VA settings should already be present, since these are stored in the registry, so will be picked up and shared by both profiles.

zen is the art of being at one with the two'ness
Go to Top of Page

Biohazard
New Member

Germany
5 Posts

Posted - Jun 09 2020 :  2:54:47 PM  Show Profile  Reply with Quote
Sorry for my late reply. It looks like importing my existing settings into the VATest profile still allows typing to work sufficiently well.

How would I go about fully resetting the default profile of VS? Disabling VMicro makes no difference like I mentioned, so I assume the next step would be properly deleting the default profile and starting anew?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 10 2020 :  06:04:53 AM  Show Profile  Reply with Quote
Just make sure you have saved a copy of your exported IDE and VA settings before starting this, just to be safe. Now close all instances of the IDE and locate your default profile directory, which should be named something like:

C:\Users\%USERNAME%\AppData\Local\Microsoft\VisualStudio\16.0_*

the test profile directory should be next to this directory, but it's directory name should end with "VATest", making it easy to tell the two apart.

Inside your default profile directory look for a file called either "privateregistry.bin" or "privateregistry.user.bin", and delete this file.

This should have the same effect as a full profile reset, but when deleting just this file your installed extensions are still installed, but disabled. You can go to:

IDE tools menu -> Extensions and Updates...

and enable the disabled extensions. After an IDE reset they are back to working normally.

Hopefully this will fix the typing speed problem for you in your default profile, and you can simply import your IDE settings to get back to where you were before.

zen is the art of being at one with the two'ness

Edited by - feline on Jun 10 2020 06:05:32 AM
Go to Top of Page

Biohazard
New Member

Germany
5 Posts

Posted - Jun 11 2020 :  1:29:48 PM  Show Profile  Reply with Quote
Removing privateregistry.bin didn't help unfortunately. It also looks like it pulled some settings back from my Microsoft account shortly after using VS. The layout and theme and possibly other settings were automatically restored after opening a solution. But I'm not sure whether that's related to the issue or not.

The extensions were disabled though like you said.

Edited by - Biohazard on Jun 11 2020 1:30:19 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 12 2020 :  05:20:44 AM  Show Profile  Reply with Quote
Not quite the result we were hoping for. There are a couple of command line switches for the IDE to reset your default profile. The "milder" reset is:

"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\devenv.exe" /ResetSettings

if this doesn't help, a more complete reset can be done via:

"C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE\devenv.exe" /ResetUserData

although I have never seen much difference between these two when testing them here. Both should remove all extensions you have installed, so you will need to reinstall VA, and any other extensions you want.

Hopefully one of these will properly fix this performance problem for you.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000