Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Ctrl-H in VsVim Insert-Mode doesn't work
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

riandrake
New Member

New Zealand
9 Posts

Posted - Feb 19 2020 :  6:44:22 PM  Show Profile  Reply with Quote
Using VsVim, Ctrl-H should be backspacing characters while in insert mode. However, this doesn't work while Visual Assist is enabled.

I don't know of any Visual Assist hotkeys using Ctrl-H, and I'm certain I have nothing bound to Ctrl-H. 3 of my other colleagues with fresh installs have the same issue - resolved by disabling Visual Assist.

feline
Whole Tomato Software

United Kingdom
17108 Posts

Posted - Feb 20 2020 :  05:58:02 AM  Show Profile  Reply with Quote
Which IDE and version of VA are you using? If you disable VA, is CTRL-H working as expected?

Testing VS2019 here, VA not installed at all, CTRL-H is bringing up the IDE quick find and replace dialog, and looking in the menus, it is mapped to:

Edit menu -> Find and Replace -> Quick Replace

by default. Even after installing VsVim, it is still bringing up the IDE quick find and replace dialog, when in Insert mode.

zen is the art of being at one with the two'ness
Go to Top of Page

riandrake
New Member

New Zealand
9 Posts

Posted - Feb 20 2020 :  2:44:05 PM  Show Profile  Reply with Quote
Microsoft Visual Studio Community 2019, Version 16.4.5
Visual Assist 10.9.2358.0


I might have needed to unbind Ctrl-H through VS Keyboard options, but my Ctrl-H doesn't open a replace dialog.

I checked the menu option as you suggested, neither Quick Find or Quick Replace have a bound hotkey for me - just Ctrl-Shift-F and Ctrl-Shift-H for the non-quick variants.

Disabling VA makes Ctrl-H work as expected, I can enable/disable multiple times to reproduce/fix the issue. If I start editing a text file quick enough, Ctrl-H will typically work once before the VA-syntax highlighting kicks in.
Go to Top of Page

riandrake
New Member

New Zealand
9 Posts

Posted - Feb 20 2020 :  2:45:36 PM  Show Profile  Reply with Quote
As an additional test, I also tried unbinding Ctrl-Shift-H. Still no luck!
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Feb 20 2020 :  2:55:17 PM  Show Profile  Reply with Quote
Note: I don't use VsVim

VsVim appears to be hosted at two different places:
https://marketplace.visualstudio.com/items?itemName=JaredParMSFT.VsVim
http://vsixgallery.com/extension/VsVim.Microsoft.e214908b-0458-4ae2-a583-4310f29687c3/

One is reported as version 2.8 and the other is 2.9.471

2.8 is known to have errors in code that checks for the presence of VA.
2.9.471 probably has the fixes.
Go to Top of Page

riandrake
New Member

New Zealand
9 Posts

Posted - Feb 20 2020 :  3:34:09 PM  Show Profile  Reply with Quote
Ahh good idea, was hyped for that to work! But I installed 2.9.471, still seeing same issue :( still only working with VA disabled.

I also have an open issue in VsVim's github here, just in case it's a VsVim problem after all: https://github.com/VsVim/VsVim/issues/2779
Will update that issue with this information too, thanks!
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Feb 20 2020 :  5:24:36 PM  Show Profile  Reply with Quote
That's a shame, thanks for trying.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17108 Posts

Posted - Feb 21 2020 :  09:08:40 AM  Show Profile  Reply with Quote
I had to go into the VsVim options and make sure it was set to handle CTRL-H its self, now done.

Just to be sure, I tried disabling all VA options, but CTRL-H still does not work when VA is installed and enabled. I have added this to our bug report for VsVim compatibility:

case=141246

zen is the art of being at one with the two'ness
Go to Top of Page

riandrake
New Member

New Zealand
9 Posts

Posted - Feb 21 2020 :  2:29:48 PM  Show Profile  Reply with Quote
Ah sorry, I should have thought of that. Thank you for your help!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000