Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VS2017 hang when running more than 14 instances
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

satom
New Member

4 Posts

Posted - Jan 23 2020 :  12:13:45 AM  Show Profile  Reply with Quote
Hello.

When I have running 14 Visual Studio projects and starting 15th one project, VS2017 GUI hangs. The same issue with VS2019.
But, VS2013 have no any issues in same case.

Is it bug or feature? Trial limitation?
Thanks.

accord
Whole Tomato Software

United Kingdom
3277 Posts

Posted - Jan 23 2020 :  2:00:55 PM  Show Profile  Reply with Quote
We don't have this kind of limitation in trial mode.

Is this something that only happens with VA installed?

Can you please save out a minidump file and send it to support?
https://docs.wholetomato.com/default.asp?W303

Please copy-paste the URL of this topic to the email so we can match it up.
You can reach us here: support at wholetomato dot com
Go to Top of Page

satom
New Member

4 Posts

Posted - Jan 23 2020 :  5:07:02 PM  Show Profile  Reply with Quote
Yes, this is only when VA is installed.

You can simply reproduce this in your test environment by following these steps:

1. In test environment I use Windows Server 2012 R2 Datacenter, but the same correct for Server 2019, that is installed as Guest VM in Hyper-V.
2. Install VS2017
3. Install latest VA(VA_X_Setup2358_0)
4. Try simply run 14 processes of devenv.exe without opening any *.sln file, just Visual Studio 2017 itself.
5. Trying to run 15th process of devenv.exe cause new Visual Studio running, but after few seconds it's hang and become unresponsive and could be only terminated.
6. 14 processes working properly and 15th is hanged.

Just terminate 15th process and properly closing, for example, 14th process of devenv.exe allows you to run new process that is become 14th in total, and trying to run 15th one again cause the same behavior.

Even disabling VA in VS2017 with help of "Enable/Disable Visual Assist" menu have no result for trying to run 15th process. Only completely uninstalling VA allows running more then 14 devenv.exe processes.

Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Jan 23 2020 :  5:53:28 PM  Show Profile  Reply with Quote
Thanks for taking the time to report the problem. We've never encountered the issue before, but it will be fixed in the next update. case=141791
Go to Top of Page

satom
New Member

4 Posts

Posted - Jan 23 2020 :  6:29:03 PM  Show Profile  Reply with Quote
Anyway, thank for your attention.
I've sent dump.
Looking forward for update and fix!
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Feb 20 2020 :  11:04:52 PM  Show Profile  Reply with Quote
case=141791 is fixed in build 2366.
https://support.wholetomato.com/default.asp?W404#2366
Go to Top of Page

satom
New Member

4 Posts

Posted - Feb 21 2020 :  01:59:16 AM  Show Profile  Reply with Quote
Awesome!
Thanks for fast fix!
VA is the best Visual Studio extension I have ever used!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000