Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 "open folder" exclude items
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

schoenherr
Tomato Guru

Germany
160 Posts

Posted - Dec 05 2019 :  06:45:29 AM  Show Profile  Reply with Quote
visual assist, eg."Open File In Solution" seems to ignore excluded items.
I specified to exclude *.o files in VSWorkspaceSettings.json but VAX still offers to open these files.

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Dec 05 2019 :  07:42:55 AM  Show Profile  Reply with Quote
Which IDE are you using?

How are you opening your folder / solution? I have never heard of the "VSWorkspaceSettings.json" file before, so I am reading up on it now. Is this automatically read if it exists and you simply open a folder in the IDE?

I would not expect VA to list .o files normally, since these are not going to be code files.

For now, can you please make sure you are looking at VA's Open File in Solution dialog, now right click on the dialog and turn On:

Open File in Solution dialog -> Right Click -> Apply persistent filter

this will show a filter field where you can add the rule:

-.o


which will tell VA to filter out all files ending with .o from the list. The persistent filter is always applied, even when the field is not showing.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Dec 05 2019 :  10:03:11 AM  Show Profile  Reply with Quote
Can you explain what you are doing, and how you are doing it? As far as I can tell this file is only checked, if it is checked at all, in Visual Studio Code, which is a different IDE to Visual Studio, which is what VA supports:

https://stackoverflow.com/questions/30140112/how-do-i-hide-certain-files-from-the-sidebar-in-visual-studio-code

Using VS2019 I have a folder that I am opening, and in the root of this folder I have created a VSWorkspaceSettings.json file, which now contains:

"files.exclude": {
"**/.o": true
}


but this has no effect on the files that are listed in Solution Explorer after opening the folder.

zen is the art of being at one with the two'ness
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Dec 05 2019 :  10:29:32 AM  Show Profile  Reply with Quote
VA does not read that file, but does use the VS Workspace API.

According to this github issue, VSWorkspaceSettings.json is not supposed to be user editable:
https://github.com/MicrosoftDocs/visualstudio-docs/pull/3499

An additional workaround might be to add .o to:
Tools | Options | Projects and Solutions | VC++ Project Settings | Extensions to Hide

VA does honor that list when "Include all files in solution directories" is enabled -- but it might not take effect if the VS Workspace API exposes the .o files.

Edited by - sean on Dec 05 2019 10:32:03 AM
Go to Top of Page

schoenherr
Tomato Guru

Germany
160 Posts

Posted - Dec 16 2019 :  06:29:21 AM  Show Profile  Reply with Quote
Hi sorry for the long delay.

I'm using VisualStudio2019 - "Open Folder".
And according to "https://docs.microsoft.com/de-de/visualstudio/extensibility/workspaces?view=vs-2019" I placed an VSWorkspaceSettings.json in my local AppData directory for visual studio "C:\Users\...\AppData\Local\Microsoft\VisualStudio\16.0_ba92ef64\OpenFolder" which will be used as most non specific settings file.

this file contains somthing like
...
"ExcludedItems": [
".git",
".vs/",
".vscode",
"*.a",
".cmake.state",
"*.o",
"*.updt",
"*.dat",
"*.bak",
"Makefile.*"
],
...

and this is obviously used by VisualStudio2019 to determine the content of the "OpenFolder-Workspace"
the suggested workaround "Extension to hide" does not seem to work.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16947 Posts

Posted - Dec 16 2019 :  2:10:22 PM  Show Profile  Reply with Quote
OK, thank you for the clear description. Now I am seeing these files being filtered out of the Solution Explorer view of the folder.

If you go to VA's Open File in Solution dialog, right click and select "Display edit control for persistent filter" a second filter field will be shown. If you now set this field to be:

-.o

this will stop VA from listing any of these .o files in this dialog, so you don't have to work around them.

zen is the art of being at one with the two'ness
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Dec 16 2019 :  2:35:38 PM  Show Profile  Reply with Quote
Thanks for the follow-up. I've opened case=141644 to address the issue.
Go to Top of Page

schoenherr
Tomato Guru

Germany
160 Posts

Posted - Dec 17 2019 :  03:07:08 AM  Show Profile  Reply with Quote
Thanks for addressing the issue,
the persistent filter workaround works :-)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000