Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Open File Dialog has parts missing
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

marovira
New Member

8 Posts

Posted - Oct 07 2019 :  5:42:21 PM  Show Profile  Reply with Quote
I'm using Visual Studio 2019 Enterprise 16.3.2, with Visual Assist version 10.9.2341.2. This problem just appeared today when I started Visual Studio after installing the latest version of my graphics driver. I also have two 1080p screens connected with a 4k monitor. I opened the "Open File Dialog" and the entire lower part of the dialog including the text bar, buttons, and other options is missing. Has anyone seen this before? Or does anyone have any clue of what is going on?

It also has the tendency to open across my 4k and one of my 1080 screens and is massive initially until I resize it. The bottom half is still missing though.





Edited by - marovira on Oct 07 2019 5:42:42 PM

feline
Whole Tomato Software

United Kingdom
16105 Posts

Posted - Oct 08 2019 :  07:23:58 AM  Show Profile  Reply with Quote
Unfortunately no, I don't recognise this problem at all. The only thing it reminds me of is the IDE running out of resources, so some GUI items cannot be displayed, but given your solution only has 11 items, this does not make any sense at all.

Are you able to disable all but one of your monitors, then close and reload the IDE, and see what happens? It sounds like the different monitors, with different resolution settings is somehow a factor, but I would like to test this, not just assume it.

Do you have any other versions of Visual Studio installed, VS2017 for example? I am just wondering if this is an IDE specific problem or not.

Are you seeing problems with any other VA dialogs? Options dialog? Find Symbol dialog? Rename dialog?

zen is the art of being at one with the two'ness
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3223 Posts

Posted - Oct 08 2019 :  12:18:08 PM  Show Profile  Reply with Quote
Does toggling persistent filter help? Maybe back and forth?

Right click over the list -> Display edit control for persistent filter
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3223 Posts

Posted - Oct 08 2019 :  12:20:34 PM  Show Profile  Reply with Quote
Another thing to try is to exit all instances of Visual Studio, rename the below registry value, and then start VS again.

Computer\HKEY_CURRENT_USER\Software\Whole Tomato\Visual Assist X\VaNet16\va_x.INI\WindowPositions
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3223 Posts

Posted - Oct 08 2019 :  12:21:36 PM  Show Profile  Reply with Quote
Also, if none of the above has helped, does it make any difference if you move the window to a different monitor? Or if you to resize the window there?

Edited by - accord on Oct 08 2019 12:29:53 PM
Go to Top of Page

marovira
New Member

8 Posts

Posted - Oct 08 2019 :  1:17:28 PM  Show Profile  Reply with Quote
@feline
I'll answer your questions in order:
1. If I disable all of my screens, the problem goes away and the Open File dialog displays correctly.
2. I do not have another version installed, so I can't check if it's IDE specific.
3. The problem also exists in the Rename and Find Symbol dialogs. It does not exist in the options dialog.

The problem seems to be when changing resolutions. If the dialog initially spawns on one of my 1080p screens, then it renders correctly. But if I then move it onto the 4k, the dialogs start displaying artifacts (text boxes not fully rendered, and white spaces appear). If I then close it and re-open the dialog, they render correctly but the entire right and bottom section of the dialogs is missing.
Go to Top of Page

marovira
New Member

8 Posts

Posted - Oct 08 2019 :  1:26:44 PM  Show Profile  Reply with Quote
@accord
I'll also reply in the same order.
1. Toggling persistent filter has no effect on the dialog.
2. Deleting that registry key fixes the problem to an extent. The dialog does appear fully (it defaults to appearing on my 1080p monitor where I have my main VS window), however the fonts render incorrectly. If I then move the dialog over to my 4k screen then the fonts fix themselves, but the rest of the dialog disappears.

I tried reverting to a previous build of VA and the issue still appears. I have also tried reverting my graphics driver but that didn't help either. It's weird because this issue didn't happen before.




Edited by - marovira on Oct 08 2019 1:38:16 PM
Go to Top of Page

marovira
New Member

8 Posts

Posted - Oct 08 2019 :  1:46:51 PM  Show Profile  Reply with Quote
Update: If I place the main window of VS in my 4k screen and I open the Open File dialog, it displays correctly. No artifacts, weird fonts, or missing parts. The issue appears only when the main VS window is in one of my 1080p screens and I open the Open File dialog in my 4k.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3223 Posts

Posted - Oct 08 2019 :  5:17:08 PM  Show Profile  Reply with Quote
I'm happy about the improvements. I hope it will make it usable for now. Do the improvements stay if you restart Visual Studio?

I've put in a bug report for the incorrect UI elements:

case=141344
Go to Top of Page

marovira
New Member

8 Posts

Posted - Oct 11 2019 :  2:05:23 PM  Show Profile  Reply with Quote
@feline
Yes, the behaviour is consistent if I restart Visual Studio. I hope this can get fixed, as it is a bit limiting that I can only have Visual Studio's main window on my 4k screen instead of the 1080p like I'm used to.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000