Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Smart Select Not Working in VS2019
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jase439
Senior Member

37 Posts

Posted - Sep 27 2019 :  4:02:12 PM  Show Profile  Reply with Quote
Version: 2431.2
VS: 16.3.1

The keys for smart selection ([SHIFT]+Alt+'[' or ']') do not appear to be working in VS2019. Seems to work OK in VS2017.

I also do not get the "keystroke collision" message about the SmartSelect key bindings at startup that I did in VS2017 when turning this feature on.

UPDATE: it may just be the "incremental" (SHIFT+ALT) selection aspect of it is not working as expected.

Edited by - jase439 on Sep 27 2019 6:17:52 PM

accord
Whole Tomato Software

United Kingdom
3223 Posts

Posted - Sep 27 2019 :  9:43:50 PM  Show Profile  Reply with Quote
Can you please make sure that the shortcuts are set correctly?

Extensions -> VAssistX -> Help -> Keyboard shortcuts

Here, press the Recommended... button. Now tick the checkboxes next to VAssistX.SmartSelectExtend and VAssistX.SmartSelectShrink and press OK.

Does this help?

Edited by - accord on Sep 27 2019 9:45:36 PM
Go to Top of Page

jase439
Senior Member

37 Posts

Posted - Sep 28 2019 :  03:12:41 AM  Show Profile  Reply with Quote
That's the screen I was looking for (thanks for pointing it out), but in any event, unfortunately I just got the message box that all the VAX key bindings were already (correctly) assigned.

Good news, however, after bringing up this dialog and pressing OK, the key bindings seemed to take after that. Maybe something isn't getting pushed to the registry at install time?

Edited by - jase439 on Sep 28 2019 03:18:51 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16105 Posts

Posted - Sep 28 2019 :  07:16:03 AM  Show Profile  Reply with Quote
The keyboard settings should have been set correctly by the installer, but obviously something went wrong here. Hopefully everything is now working correctly for you, and will stay working correctly.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000