Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Problems with new Visual studio 2019 16.2.0
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

proglore
New Member

Italy
4 Posts

Posted - Aug 01 2019 :  06:21:45 AM  Show Profile  Reply with Quote
Hi,
Yesterday I updated visual studio, now I have the community 2019 16.2.0 version.

After the update the autocomplete layer works bad, the layer come out properly, it seems to have the focus, I can use the arrow keys to move the selected option, but also the cursor on the code is moving, so if I press 3 time the up arrow the cursor goes 3 row above and when I confirm the selection it mess up with the code.

When I press enter to confirm the selection on the same row, the system put the right code as usual but it add the carriage return, It seems to not prevent default behavior, also if you use the tab key to confirm the selectio, it put the right code but then add a tab character in the code.

Has anyone else had this problem?

Thanks in advance.
Lorenzo.

schoenherr
Tomato Guru

Germany
156 Posts

Posted - Aug 01 2019 :  07:31:41 AM  Show Profile  Reply with Quote
Hi,
you probably have IncrediBuild installed. See the following thread:

https://forums.wholetomato.com/forum/topic.asp?TOPIC_ID=16657

Also there is a suggestion to work around the problem, on my machine it didn't work.
I work around the problem with deactivate incredibuild addin and build via context menu on the incredibuild agent icon in the taskbar --- very annoying

hope that helps
m.schoenherr
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3195 Posts

Posted - Aug 01 2019 :  08:29:56 AM  Show Profile  Reply with Quote
I wasn't able to reproduce the problem using VS 16.2.
As schoenherr mentioned, Incredibuild caused keyboard/listbox related problems.

Do you have the VS IncrediBuild extension installed? If so, revert to the previous version. They are aware of the problem and are working on a fix.

Go to Tools -> Extensions.
Find Incredibuild Build Acceleration.
Click revert.
Restart Visual Studio.
Go to Top of Page

proglore
New Member

Italy
4 Posts

Posted - Aug 01 2019 :  08:45:31 AM  Show Profile  Reply with Quote
Thanks for the advice. I did not find the revert button, I have Extensions -> Manage Extension, but I don't have the revert.

But I tried to unistall visual assistant, disabled the incredibuild extension, installed again the Visual assistant and it works just fine.

Then for curiosity I re-enabled the incredibuild extension and Visual assistant continued to works well.

I don't know if it can be helpful to someone.

Thanks again.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3195 Posts

Posted - Aug 01 2019 :  08:49:41 AM  Show Profile  Reply with Quote
oh wow I'm glad it has worked out for you.
Go to Top of Page

schoenherr
Tomato Guru

Germany
156 Posts

Posted - Aug 01 2019 :  09:26:07 AM  Show Profile  Reply with Quote
I hope the effect stays persistent for you. I did the same thing many times with the same observation. but shortly after that the problem reappeared. further investigation showed that it was only functioning as long vax was rebuilding the symbol data base and the completion boxes seemed to be provide by VisualStudio.
Go to Top of Page

proglore
New Member

Italy
4 Posts

Posted - Aug 01 2019 :  11:28:46 AM  Show Profile  Reply with Quote
quote:
Originally posted by schoenherr

I hope the effect stays persistent for you. I did the same thing many times with the same observation. but shortly after that the problem reappeared. further investigation showed that it was only functioning as long vax was rebuilding the symbol data base and the completion boxes seemed to be provide by VisualStudio.



You are right, It's already broken... I can disable incredibuild, in my case is not very effective, so no problem now, but it's really weird this behavior.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3195 Posts

Posted - Aug 01 2019 :  12:03:37 PM  Show Profile  Reply with Quote
I'm not being an IB user but this thread may be useful about rollback options:
https://forums.wholetomato.com/forum/topic.asp?TOPIC_ID=16657

So you don't need to disable it.
Go to Top of Page

sean
Whole Tomato Software

USA
2689 Posts

Posted - Aug 01 2019 :  1:35:36 PM  Show Profile  Reply with Quote
IncrediBuild support sent this message out this morning:
We've just released a new official version (9.42) which should solve the issue you had -
Please use the following link to download the new version -
https://www.incredibuild.com/downloads/incredibuild9_42.exe

Release Notes:
https://www.incredibuild.com/incredibuild-version-history.html

Please note the following:
1) The new build will require an upgrade of the Coordinator and all Agents.
2) In order to upgrade, run the setup file on the computer on which the Coordinator is installed and follow the instructions.
Go to Top of Page

proglore
New Member

Italy
4 Posts

Posted - Aug 02 2019 :  08:28:35 AM  Show Profile  Reply with Quote
quote:
Originally posted by sean

IncrediBuild support sent this message out this morning:
We've just released a new official version (9.42) which should solve the issue you had -
Please use the following link to download the new version -
https://www.incredibuild.com/downloads/incredibuild9_42.exe

Release Notes:
https://www.incredibuild.com/incredibuild-version-history.html

Please note the following:
1) The new build will require an upgrade of the Coordinator and all Agents.
2) In order to upgrade, run the setup file on the computer on which the Coordinator is installed and follow the instructions.




Thank you, I'll take a shot.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000