Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Parsing whole solution very often
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

Pascal Mueller
New Member

Germany
2 Posts

Posted - Jan 24 2019 :  03:57:02 AM  Show Profile  Reply with Quote
Hi,

I am experiencing a very bad performance of visual studio, because of visual assist parsing the whole project, quite often. Because it includes the Unreal Engine source code, parsing the solution takes 12-15 minutes. This happens almost every second day when I start my project for the first time. In these two days only a handful of files have changed, so a whole parsing of the project is not necessary. In general I am very happy with visual assist, but at the moment I am loosing 30-60 min every week because of this. Is there an option to not reparse the whole solution?? What can be done to solve this?

Cheers Pascal

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jan 24 2019 :  08:52:53 AM  Show Profile  Reply with Quote
This should not be happening. At a guess, VA is not picking up that you are working with Unreal. First up, can you please go to:

VA Options -> System Info -> Copy Info

and paste the details (from the clipboard) into your reply. This will give us the basic information about your setup.

Next, can you please look and see what you have set in the VA Options page:

VA Options -> Unreal Engine -> Enable support for Unreal Engine 4

Did you download the Unreal Engine source from Github, or did you get Unreal Engine via the Epic game launcher, that downloaded the engine for you?

zen is the art of being at one with the two'ness
Go to Top of Page

Pascal Mueller
New Member

Germany
2 Posts

Posted - Feb 05 2019 :  05:48:36 AM  Show Profile  Reply with Quote
HI,

thanks for the answer. Here are the system infos. Unreal Support was activated. I am using a custom engine version of 4.20 but rarely do any changes. Maybe every two weeks or so. It seems to happen after a visual studio crash quite often and sometime when I use the generate project files option of unreal.


VA_X.dll file version 10.9.2302.0 built 2018.12.13
DevEnv.exe version 15.9.28307.280 Community
msenv.dll version 15.0.28307.208
Comctl32.dll version 6.10.17134.523
Windows 10 10.0 1803 Build 17134.523
4 processors (x86-64, WOW64)
Language info: 1252, 0x409

Platform: Project defined
Stable Includes:
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.6.1\Include\um;
C:\Program Files (x86)\Windows Kits\8.1\Include\winrt;
C:\Program Files (x86)\Windows Kits\8.1\Include\shared;
C:\Program Files (x86)\Windows Kits\8.1\Include\um;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.10240.0\ucrt;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\VS\include;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\atlmfc\include;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\include;
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.6\include\um;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\ucrt;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\shared;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\um;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\winrt;
C:\Program Files\Common Files;

Other Includes:

Stable Source Directories:
C:\Program Files (x86)\Windows Kits\10\Source\10.0.10240.0\ucrt;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\VS\src;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\crt\src;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\atlmfc\src\atl;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\atlmfc\src\mfcm;
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.16.27023\atlmfc\src\mfc;

Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Feb 05 2019 :  07:26:14 AM  Show Profile  Reply with Quote
Everything here seems normal enough.

If you turn On:

VA Options -> Coloring and Attributes -> Show stable symbols in italics

are the following symbols shown in italic inside the editor window, "UCLASS", "GENERATED_BODY", "TArray" and "TMap"? I am just double checking that VA things that the symbols coming from Unreal are being treated as stable symbols.

I wonder if the IDE crashing is the clue here. As a test, I have just loaded VS2015, and loaded an Unreal solution, and then used task manager to kill off the IDE, emulating a crash.

When I now reload the IDE and the solution, a large and slow parse is happening. This is not coming from VA though. The status bar message starts "Parsing files in solution...", which is from the IDE.

Also opening VA's Find Symbol dialog or Open File is listing all of the expected symbols and files, even though the parsing is still going on. If VA was parsing the status bar message would say that it was VA doing the parsing.

This might also explain why making changes in the Unreal Editor has a similar effect, since this will regenerate the IDE projects, which could well trigger another parse.

To test this theory can you please set the IDE option:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

this will stop the IDE from parsing your solution. This should only leave VA's parser to consider, so if this fixes the problem we can be fairly sure it was down to the IDE parsing that you had this problem.

Another thought on the crashes, VA stores one copy of its symbol database per running IDE process. So, if the crash that you are seeing is leaving a "devenv.exe" process running in the background, and you then "reload" the IDE, VA will conclude that you are actually running two instances of the IDE, not just one instance. As a result the new instance will get its own database, and if this does not exist yet, it will require a full parse.

To check for evidence this has been happening, please have a look for VA's install directory, which should be under:

%USERPROFILE%\AppData\Local\Microsoft\VisualStudio\15.0_xxxxx\Extensions
where the 15.0_xxxxx directory has a hashed name. Under the "Extensions" directory there will be more hashed directory names. Look for the directory containing "va_x.dll". In this directory look in the "Data" subdirectory.

The folders "vs15" and "vs15_1" are for the first instance of VS2017 that you have loaded. If you have a "vs15_2" directory then VA has seen two instances of VS2017 open at the same time, and so on. So if you have a lot of these numbered directories, this will help to explain why VA is doing so much extra parsing.

zen is the art of being at one with the two'ness
Go to Top of Page

bart
New Member

Netherlands
2 Posts

Posted - Apr 21 2020 :  06:50:19 AM  Show Profile  Reply with Quote
As of today, I have this issue almost everyday with Unreal.
There are 2 strange things.

I have a medium size file (1000+ lines) which takes constantly 33% of my 4 core CPU and is very slow to scroll and type in, in VS 2019.

The other problem is that VA thinks that VS crashes on exit and starts reparsing (thats what I assume).
Because sometimes VS does indeed crash and VA also restarts parsing.

I am working on exactly the same solution/project/folder every day.
Yet, I ahve to reparse everyday again at 100% CPU and it takes like 30 minutes or so.


VA_X.dll file version 10.9.2366.0 built 2020.02.20
DevEnv.exe version 16.5.30002.166 Community
msenv.dll version 16.0.29931.138
Comctl32.dll version 6.10.17134.345
Windows 10 10.0 1803 Build 17134.345
4 processors (x86-64, WOW64)
Language info: 1252, 0x409
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Apr 21 2020 :  07:16:34 AM  Show Profile  Reply with Quote
This shouldn't be happening. First, can you please close all instances of the IDE and set this registry key:

https://docs.wholetomato.com/default.asp?W651

it tells VA not to reparse after the IDE has crashed. There is a small chance that this will cause your VA symbol database to become a bit out of date, but for now this is a minor concern.

Next can you please go into the VA Options dialog, and the Performance page of settings. Here you can limit the number of threads VA's parser uses, and change their thread priority, even disabling multithreaded parsing entirely. This will slow down parsing on your system, but will stop VA consuming so much CPU time while it is parsing, so this should also help a bit.

The slow file, can you please try making a new, default Unreal Engine game project, and copy this slow file across to the new test solution, and open it there? I am wondering if the slow scrolling and typing is file specific, and if it can be reproduced in isolation, or if it is related to the rest of the solution. If you can reproduce the slow scrolling and typing is there any change of getting a copy of the file for testing purposes only? I appreciate this is often not possible, but it's worth asking in case it is possible.

If you are able to send me the file, please send me the files via email:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

bart
New Member

Netherlands
2 Posts

Posted - Apr 24 2020 :  04:36:24 AM  Show Profile  Reply with Quote
Thanks for your reply.

I changed the values to 0 in the registry for all IDE's.
But VA still starts reparsing upon reload of IDE. Or actually, always the next day on first launch..

THe Slow file is only temporary, so I think it is correct. Although it appears strange that if you await it to become ~1 % CPU then
switch to a different file and switch back, it also restarts this expensive 'scanning' process. So basically VA is constantly
at ~30% CPU when navigating through files. Don'nt know if that is suppososed to. But that combined with VS2019 not being the lightest
makes it become slow at somewhat larger files on my computer.

Code: https://paste.ofcode.org/CF8SvFpbmg44esRMWve7cp
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Apr 24 2020 :  09:37:22 AM  Show Profile  Reply with Quote
Do you have:

VA Options -> Performance -> Parse all files when opening a project

turned On or Off? It is possible turning this Off will help.

Is the code on your machine being updated / touched nightly? Perhaps by a full sync with source control? Closing and reloading the IDE over night, by its self, should be no different to closing and reloading the IDE during the day. But if something else is happening this might help to explain the effect.

The CPU usage you are seeing is definitely not normal, not for a file this small. My test file to stress VA when parsing a cpp file is 23,000 lines long! I have copied the file you pasted here, and am not seeing any signs of high CPU usage, and the code looks normal on a quick scan.

Do you have:

VA Options -> Code Inspection (beta) -> Enable Code Inspection

turned On or Off? It is possible this is a factor, if enabled.

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - May 29 2020 :  07:40:37 AM  Show Profile  Reply with Quote
quote:
Originally posted by feline

can you please close all instances of the IDE and set this registry key:
https://docs.wholetomato.com/default.asp?W651



If I set VerifyDbOnLoad to 00, does that mean that VA will not re-parse files that have been modified outside Visual Studio when opening a solution?

Or it will still re-parse as long as "parse all files when opening a project" is enabled?

By the way, for some reason none of the Unreal Engine symbols show in italics for me such as GENERATED_BODY(), UCLASS, and UOBJECT.

I'm using a source compiled version of Unreal Engine from their git release branch which is version 4.25.0.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - May 29 2020 :  07:47:41 AM  Show Profile  Reply with Quote
Firstly, you should only need to set VerifyDbOnLoad if your IDE is crashing, is this something you are seeing? If so, it would be good to try and get to the bottom of the crash, in case VA has any part in it.

I am not sure of the exact effect of this setting, but I would expect VA to still re-parse any files that it realises have been modified since they were last parsed.

For your Unreal symbols, if you look in:

VA Options -> C/C++ Directories

are all of your Unreal Engine directories listed here as stable include directories?

If not, can you please look and see if you have:

VA Options -> Unreal Engine -> Enable support for Unreal Engine 4
When a solution contains a project named UE4
Always

turned On or Off, and if it is turned On, check what it is set to?

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - May 29 2020 :  08:17:29 AM  Show Profile  Reply with Quote
quote:
Firstly, you should only need to set VerifyDbOnLoad if your IDE is crashing, is this something you are seeing?


I'm not crashing but setting that registry key to 00 seems to have stopped VA from reparsing when reopening a solution.

quote:
are all of your Unreal Engine directories listed here as stable include directories?

There's several hundred directories that start with "C:\repos\UnrealEngine\Engine" that were added there automatically so I think that is working.

quote:
can you please look and see if you have:
VA Options -> Unreal Engine -> Enable support for Unreal Engine 4


I have mine enabled support for UE4 and set to "When a solution contains a project named UE4"

Edited by - Jorge24 on May 29 2020 08:19:00 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - May 30 2020 :  08:34:16 AM  Show Profile  Reply with Quote
Sometimes the Unreal Engine symbols are not shown in italics, even with Unreal Engine support active. I am currently looking into this.

Are other VA features for Unreal Engine working correctly for you? These are described here:

https://docs.wholetomato.com/default.asp?W812

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - May 31 2020 :  06:19:15 AM  Show Profile  Reply with Quote
I see. The suggestions inside the UE4 macros work but the Enhanced Syntax Coloring doesn't seem to be working. I opened the file "UnrealEngine\Engine\Source\Runtime\Engine\Classes\Engine\SubsurfaceProfile.h" and went to line 130 as you can see here:



In the VA settigns, only my "Variables" color is set to white
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - May 31 2020 :  08:04:51 AM  Show Profile  Reply with Quote
And by the way, I opened the UE4 solution that contains the UE source code and VA has been parsing the entire repository again. I think this is like the 3rd time it does it. I'm pretty sure it finished last time it was parsing since I left visual studio open for several hours even after VA finished parsing. I havent modified any of the files in the UE source code since the last time VA parsed the whole thing.

If I have 3 instances of visual studio open at the same time, each with a UE project loaded, it will parse the entire UE source code 3 times right?

But after doing that, I should be able to open 3 instances of Visual Studio, load any UE project on each of the 3 instances, and not have to reparse the entire UE source code again, right?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 02 2020 :  10:25:57 AM  Show Profile  Reply with Quote
You understand what happens with 3 instances of the IDE open at once correctly. This is by design, to stop the instances of the IDE pulling in symbols from another instance. But this should not cause VA to re-parse the Unreal Engine source code.

I have just run the following test. Using VS2017 and VA 2375.0, I set up two simple Unreal Engine projects, both using UE version 4.24.

I loaded VS2017, and told VA to do a symbol database rebuild. This was to make sure I started with a known, blank state.

Close the IDE and load a single instance of VS2017, and load the first UE project. VA took under 8 minutes to parse everything, which was mainly Unreal Engine its self, since it is a new, and very small game project.

I then closed this single instance of VS2017, then loaded a new instance of VS2017, still only one instance loaded, and opened the second Unreal Engine project. This time parsing took under 30 seconds.

This version of Unreal Engine was downloaded via the Epic Games Launcher, but this should not really be relevant here, but it could be.

How does this compare to your experiences? It sounds like you are seeing something quite different.

Do you have IDE intellisense enabled or disabled? Normally VA does not underline symbols in the editor if the IDE intellisense is enabled, so I am wondering if this underlining is coming from VA or from the IDE. VA should not be underlining "UObject", especially not if it is being coloured correctly.

You can turn off the IDE intellisense parser via:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

and just rely on VA's parsing if you want. This should help to speed things up when working with Unreal Engine, but doesn't explain any extra parsing VA is doing.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 02 2020 :  11:04:15 AM  Show Profile  Reply with Quote
As for your picture, with VS2017, VA 2375 and Unreal Engine 4.24, I am seeing the following:



several differences here, including that I have italic and you don't. Clearly something to look into here.

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 02 2020 :  12:34:36 PM  Show Profile  Reply with Quote
I see, I will be creating a new UE project in the next few days and will note how long it takes to parse to see how does my experiences compare.

I disabled the intellisense from the VS IDE and now it looks like this:


The squiggly lines are gone. I also noticed some of my classes now show in italics but "SubsurfaceProfile" in line 130 still doesn't show in italics and when I hover over it, nothing pops up. Is something supposed to pop up when I hover over SubsurfaceProfile?

I'm wondering if maybe I'm missing some directories in:
VA Settings > C/C++ Directories

I pasted the list of directories here in case you could spot something I didn't:
https://pastebin.com/05Zmvc8P

Edited by - Jorge24 on Jun 02 2020 12:36:41 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 03 2020 :  08:28:18 AM  Show Profile  Reply with Quote
Thank you for the directory listing. On a quick look this looks correct, and it is the right sort of size of directory listing. Basically VA should be doing a recursive scan of your Unreal Engine directory tree, and adding every directory it finds to this directory list.

I am confused that turning off IDE intellisense caused symbols to start appearing in italic for you. The italic setting comes from VA, so is independent of the IDE intellisense parser.

Are you using the default IDE dark theme, with the default VA colours for a dark theme? Or have you customised your colour settings? As it stands its not obvious why some symbols have one colour for you, but a different colour for me, especially when I am using a different theme

For mouse hover over the parameters to the UCLASS macro, this is correct, we are not trying to show any tooltips here. Should we be doing so? I don't actually use Unreal Engine myself, so I don't always know what you would want / hope to happen.

If you use Alt-G on the UCLASS parameter "SubsurfaceProfile" on line 130, what happens? For me I get a list of 4 possible destinations to jump to.

If I use Alt-Shift-G instead, and select to go to the declaration, I am taken to the block:

/** From the GBufferD RGB Channels. */
UPROPERTY(VisibleAnywhere, category = GBufferD)
FVector SubsurfaceProfile;

in the file "PixelInspectorView.h".

The fact that you have different behaviour for italic symbols may be related to the fact that Unreal Engine is not located under "C:\Program Files\Epic Games\", but you have some Unreal Engine symbols in italic, so I am not sure yet what is happening here.

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 03 2020 :  12:11:07 PM  Show Profile  Reply with Quote
I forgot to mention, the classes that show up in italic actually started showing up in italics about a day before I turned off the IDE intellisense. About 2 days ago, the italics for classes like FString USubsurfaceProfile were showing permanently. However, for some reason, now the italics for FString only show up for a few seconds after Visual Studio loads, then the italics are gone.

I think what made the italics start to show is that I added the folder "C:\repos\UnrealEngine\Engine\Source" to "C/C++ Directories > Custom". It seems like after I added that directory to custom, then it caused VA to add some directories to "Project Defined" automatically. After I removed the folder from "Custome" now the folders in Project Defined do not include the folders in "C:\repos\UnrealEngine\Engine\Source". The only folders there now are the ones in "C:\repos\UnrealEngine\Engine\Intermediate". Without adding folders to custom I dont get any italics. After adding the folder to custom I get italics for USubsurfaceProfile permanently but only temporary italics for FString.

I'm using Visual Studio's dark theme but I also customized a few of the VS colors like I made the background darker and my "#include" pink, etc.

I am also using custom coloring settings for Visual Assist as you can see here:


I also get a list of 4 possible destinations to jump to when I press Alt-G over SubsurfaceProfile but nothing if I hover over it.

Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 03 2020 :  12:23:14 PM  Show Profile  Reply with Quote
Also, since enabling or disabling IDE intellisense didn't affect the italics, I ended up re-enabling it because without it Visual Assist doesn't underline errors such as passing the wrong type of argument to a function.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 08 2020 :  11:22:07 AM  Show Profile  Reply with Quote
Now I have applied your colours I am getting a very similar result here. The only obvious difference, apart from the italic, is "meta". For me this is being coloured as an enum member, while it is shown as white for you.

Have you had a chance to see if you are still getting very slow parsing problems? This is the most important problem here to focus on.

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 12 2020 :  7:02:56 PM  Show Profile  Reply with Quote
I will be creating a new UE project tomorrow to test the parsing time of a new project that references UE source files that have been previously parsed. I will try both, creating a new project that uses the precompiled source files and one that uses the source-compiled files.

However, I just installed the precompiled version of UE from the Epic Launcher and confirmed that the problem detecting symbols only happens in my source-compiled version. As you can see, in the screenshot below, SubsurfaceProfile shows in italics on the right side (precompiled version) but not in the left side (source-compiled version).





and a comparison of UnrealString.h:




Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 13 2020 :  07:00:58 AM  Show Profile  Reply with Quote
What is the path to the two versions of Unreal Engine in these screen shots? I am guessing that the Epic Launcher version is installed to something like:

C:\Program Files\Epic Games\UE_4.24
while the version compiled from source code is installed to a quite different base directory, outside of "C:\Program Files\"

One factor that VA considers when working out if symbols should be in italic is the location of the stable include libraries.

Things are more complex when it comes to Unreal Engine, but the directory does have some effect.

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 13 2020 :  1:12:46 PM  Show Profile  Reply with Quote
The path of the UE from the Epic Launcher (right side of screenshot) is installed to:
C:\Program Files\UE_4.25

The version I compiled from source code (left side of screenshot) is installed to:
C:\repos\UnrealEngine

Should I move my UE repository to something like:
C:\Program Files\UE_4.25_source
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 14 2020 :  01:51:44 AM  Show Profile  Reply with Quote
I just created 2 new blank projects. The project I created with the UE from the Epic Launcher didn't have to re-parse. It just loaded the symbols and that was it. However, the new project I created with the UE I compiled from source, spent like 21 minutes parsing the entire UE source code. I have a very good desktop CPU (it's an Intel i7-9700K) and it was running at 100% throughout those 21 minutes. Prior to this test, VA had already parsed the entire engine for both versions, the Epic Launcher one, and the one I compiled from source. I only had 1 instance of Visual Studio open at a time during the tests. Both engines are version 4.25.1.

It seems like all the problems I've had only happen in the version I compiled from source.

Edited by - Jorge24 on Jun 14 2020 02:00:30 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 15 2020 :  08:34:30 AM  Show Profile  Reply with Quote
At least the behaviour with the Epic Launcher version is what I would expect.

For your two solutions using the source code compiled from GitHub, are you using the same source tree and location for both? Have you updated the Unreal Engine source code in the last couple of days?

I will set up a similar test here, and see what I see.

If you want to try telling VA that your source code version of Unreal Engine lives in a different directory, without actually moving any of your files, you can try the following. Open a command prompt in the directory:

C:\Program Files\Epic Games
and a command like:

mklink /J UE_4.25_source "C:\repos\UnrealEngine"

this will create a junction point at the file system level, making the directory tree appear to be in both locations at the same time. Now go into the director that holds your source code based solution. From here you should find the following files:

Intermediate\ProjectFiles\UE4.vcxproj
Intermediate\ProjectFiles\UE4.vcxproj.filters

Open both files in a text editor, and do a search and replace for the old Unreal Engine path to the new Unreal Engine path, so in this case search

"C:\repos\UnrealEngine"

And turn all instances into:

"C:\Program Files\Epic Games\UE_4.25_source\"

Save the changes and now reload the IDE and your solution.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 17 2020 :  11:46:16 AM  Show Profile  Reply with Quote
OK, this might be a silly question, but how do you download and compile the Unreal Engine source code from GitHub?

Following the steps on this page:

https://docs.unrealengine.com/en-US/GettingStarted/DownloadingUnrealEngine/index.html

I have the GitHub download done, all nice and straight forward.

Then I have followed the steps on this page:

https://docs.unrealengine.com/en-US/GettingStarted/DownloadingUnrealEngine/index.html

first running "Setup.bat" and then "GenerateProjectFiles.bat"

Now load VS2017, open the UE4 solution, and build the UE4 project node. It compiled without any errors. I have set the start up project, several times over.

When I try to run the solution, I get the error message:

Unable to start debugging. Check your debugger settings by
opening project properties and navigating to 'Configuration
Properties-->Debugging'

which isn't all that helpful. I have tried several searches, unsuccessfully, for help on this. The nearest solution was to set the startup project, which I have already done.

Better pictures here, so I am sure I am doing this right:

https://docs.unrealengine.com/en-US/Programming/Development/BuildingUnrealEngine/index.html

When I check the debugging settings, there are only two settings obviously set:

Command = $(TargetPath)
Amp Default Accelerator = WARP software accelerator

the rest are blank. Nothing obviously wrong or invalid here.

And yes, I have even tried a reboot, just in case

zen is the art of being at one with the two'ness
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 19 2020 :  11:20:56 PM  Show Profile  Reply with Quote
Hi, thanks again for replying and sorry it's been a few days.
quote:
Originally posted by feline
For your two solutions using the source code compiled from GitHub, are you using the same source tree and location for both? Have you updated the Unreal Engine source code in the last couple of days?


Yes, I have only had 1 repo of the UE at a time. The first time I tried using VA, I had the release branch of UE which at that time was at 4.25.0. Now I have the release branch which is at 4.25.1. I have tried creating new projects while I had 4.25.0 and also with 4.25.1 but both lead to the same re-parsing.

The version I have now is:
https://github.com/EpicGames/UnrealEngine/tree/4.25.1-release
Go to Top of Page

Jorge24
Junior Member

USA
23 Posts

Posted - Jun 19 2020 :  11:38:12 PM  Show Profile  Reply with Quote
quote:
Originally posted by feline

OK, this might be a silly question, but how do you download and compile the Unreal Engine source code from GitHub?



Hmm, my first question would be: What version of Visual Studio are you running? I have read posts before where updating visual studio fixes things. I'm using VS 2019 v16.6. Note that updating VS will probably mean you will have to recompile the entire engine again so try updating VS if all the stuff below fails.

Also, which branch did you check out from the UE GitHub repo? Are you on the release branch that I linked in the previous post which has UE 4.25.1?

These are my UE4 project properties:


Is your build configuration set like this too?



Lastly, if it did build successfully but you just can't run the UE editor through Visual Studio, you can just run the editor's EXE manually by going to:
"\UnrealEngine\Engine\Binaries\Win64\UE4Editor.exe"

Edited by - Jorge24 on Jun 19 2020 11:43:54 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 22 2020 :  05:40:37 AM  Show Profile  Reply with Quote
Thank you for the information. I have the correct IDE settings, but I do have different debugger settings. I am building with VS2017, as you say, I probably should have remembered to mention that

I found the "UE4Editor.exe" file myself, and just ran this directly, which does load. But I was caught out by it building all of the shaders while loading, which looked exactly like it had hung and was not working. I will start running tests on what is happening here soon.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16732 Posts

Posted - Jun 24 2020 :  11:49:48 AM  Show Profile  Reply with Quote
When you load your solution in Visual Studio, how are you doing so?

Do you first load Visual Studio, then open the Unreal solution you are working on?
Do you launch the Unreal Editor first and open the solution from here?

It is starting to look like how the IDE is loaded is somehow a factor here.

zen is the art of being at one with the two'ness
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000