Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 quick info hover tooltips all green
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

CliffyP
Senior Member

47 Posts

Posted - Jan 12 2019 :  2:08:54 PM  Show Profile  Reply with Quote
This is not a new bug, been seeing it for as long as I have used VA. When I mouse over things to get the quick info tooltips often the tooltip is not properly syntax highlighted instead showing code as comment (all green).

For example in UE4, it happens everywhere, try for example mousing over this type: SEditableTextBox

It would be good if this was fixed, as it is quite annoying. I like VA primarily for the syntax highlighting so it needs to work!

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Jan 14 2019 :  08:11:31 AM  Show Profile  Reply with Quote
I have seen these all green tooltips occasionally, but they seem to be fairly rare and random in my experience. Can you please go to:

VA Options -> System Info -> Copy Info

and paste the details (from the clipboard) into your reply. This will give us the basic information about your setup.

So far I am not seeing the all green tooltip here, using Unreal, VS2017 and VA 2302, so I am wondering if there is an obvious difference between your system setup and mine.

If not, settings might be a factor here.

zen is the art of being at one with the two'ness
Go to Top of Page

CliffyP
Senior Member

47 Posts

Posted - Jan 26 2019 :  5:07:08 PM  Show Profile  Reply with Quote
License: **** (Non-renewable Personal License) Support ends 2019.05.25
VA_X.dll file version 10.9.2302.0 built 2018.12.13
DevEnv.exe version 15.9.28307.280 Professional
msenv.dll version 15.0.28307.208
Comctl32.dll version 6.10.17134.523
Windows 10 10.0 1803 Build 17134.523
8 processors (x86-64, WOW64)
Language info: 1252, 0x409

Platform: Project defined
Stable Includes:
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.6.1\Include\um;
C:\Program Files (x86)\Windows Kits\8.1\Include\winrt;
C:\Program Files (x86)\Windows Kits\8.1\Include\shared;
C:\Program Files (x86)\Windows Kits\8.1\Include\um;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Auxiliary\VS\UnitTest\include;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.10240.0\ucrt;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Auxiliary\VS\include;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\atlmfc\include;
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.6\include\um;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\ucrt;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\shared;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\um;
C:\Program Files (x86)\Windows Kits\10\include\10.0.16299.0\winrt;
C:\Program Files\Common Files;

Other Includes:

Stable Source Directories:
C:\Program Files (x86)\Windows Kits\10\Source\10.0.10240.0\ucrt;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Auxiliary\VS\src;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\crt\src;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\atlmfc\src\atl;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\atlmfc\src\mfcm;
D:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Tools\MSVC\14.16.27023\atlmfc\src\mfc;
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Jan 27 2019 :  11:07:45 AM  Show Profile  Reply with Quote
Nothing obviously different in our settings, but testing this again, I have seen an all green tooltip appear a couple of times, but only a couple of times.

Do you know if you have disabled the IDE's intellisense parser? So that all tooltips are coming from VA and not from the IDE? This might be a key difference here.

zen is the art of being at one with the two'ness
Go to Top of Page

CliffyP
Senior Member

47 Posts

Posted - Jan 28 2019 :  1:55:18 PM  Show Profile  Reply with Quote
Yes, I have Visual Studio's intellisense feature disabled entirely. Btw we have had this exact same conversation before. I have used VA since 2015. This problem has been happening consistently since then across all updates and different version of VS. It happens 98% of the time such that when I see a tooltip that is colorized properly I think Oh! that is weird!

I don't care how infrequently it happens for you, that fact that it happens sometimes means you can catch the case and debug it, please do that!
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Jan 29 2019 :  09:20:45 AM  Show Profile  Reply with Quote
Apologies for this problem. It turns out it is a known bug, but it only happens under certain circumstances. Unfortunately UE is often matching these conditions. I have increased the priority on this bug for you:

case=96301

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000