Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Cannot open the Options menu
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 2

Velaris
New Member

Canada
5 Posts

Posted - Mar 02 2018 :  01:52:54 AM  Show Profile  Reply with Quote
Hi,

I'm using the latest version of Visual Assist, as well as VS 2017 community edition. I'm on Windows 10 and I have the latest updates.

I'm unable to open the options menu in Visual Assist. Clicking on it does nothing - the cursor seems to be loading, but nothing ends up happening.

Is there any log file that I can provide you with ?

Thanks

Edited by - Velaris on Mar 02 2018 01:53:21 AM

Velaris
New Member

Canada
5 Posts

Posted - Mar 02 2018 :  02:05:30 AM  Show Profile  Reply with Quote
Alright, so uninstalling and cleaning the registry solved it.
Go to Top of Page

Velaris
New Member

Canada
5 Posts

Posted - Mar 02 2018 :  02:15:22 AM  Show Profile  Reply with Quote
.... And the issue re-appeared by itself. This is getting very frustrating.
Go to Top of Page

steel9b
New Member

2 Posts

Posted - Mar 02 2018 :  05:02:55 AM  Show Profile  Reply with Quote
I'm getting exactly the same issue on VS 2015 and 2017 pro editions with build 2258. This was not happening in 2248.

DevEnv.exe version 14.0.25420.1 Professional
msenv.dll version 14.0.25431.1
Comctl32.dll version 6.10.16299.248
Windows 10 10.0 Build 16299 (remote)
8 processors (x86-64, WOW64)
Language info: 1252, 0x809
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17012 Posts

Posted - Mar 02 2018 :  10:05:28 AM  Show Profile  Reply with Quote
When you have this problem, does the VAssistX menu disappear? Or does the menu remain visible, as if you have not selected any menu items?

If the menu is disappearing, as normal, but there is no sign of the VA Options dialog, then my first thought is to see if there are any new Windows Updates available. Velaris, I know you say you have the latest updates, but can you double check?

There is a known problem with the Windows 10 Fall Creators Update that can cause window creation to fail in the IDE. If you are seeing this problem, it would explain what is happening here. Microsoft have fixed this problem in a subsequent windows update.

If you are seeing this problem, then sometimes, when opening a new code file, instead of the VA Context and Definition fields showing at the top of the editor window, there will simply be a blank space where they should be.

zen is the art of being at one with the two'ness
Go to Top of Page

steel9b
New Member

2 Posts

Posted - Mar 02 2018 :  11:29:11 AM  Show Profile  Reply with Quote
quote:
If the menu is disappearing, as normal, but there is no sign of the VA Options dialog, then my first thought is to see if there are any new Windows Updates available


Menu disappears, wait cursor appears, then nothing. I have 2 PCs, one using VS 2017 and the other 2015, both fully up to date according to Windows Update, and both show the same issue.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17012 Posts

Posted - Mar 02 2018 :  11:47:08 AM  Show Profile  Reply with Quote
I am not seeing any sign of this, having checked on several different machines, but obviously something is going on here. I am wondering if for some reason the options dialog dll is not loading on your system. Can you please download and run Process Monitor from here:

https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

when the program loads, in the Filter dialog, please add the filter:

Process Name is devenv.exe then Include

add this filter and accept the dialog. Now stop capture by pressing Ctrl+E. Make sure the IDE is loaded, and you are ready to reproduce the problem. Go to process monitor, enable capture with Ctrl+E, reproduce the problem, then press Ctrl+E in process monitor again to stop the capture. Process Monitor captures a lot of activity, so keeping the capture short just helps.

Does the log suggest any reasons for the problem? If you want to just send me the log, so I can have a look through it, then just save it out and submit the files via the form:

http://www.wholetomato.com/support/contact.asp

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

ChrisG
Whole Tomato Software

USA
220 Posts

Posted - Mar 02 2018 :  1:04:30 PM  Show Profile  Reply with Quote
Hi Velaris and steel9b,

Could you please try enabling VA logging through the registry using the information in the following article.
https://docs.wholetomato.com/default.asp?W305

Ensure all instances of your IDE are closed when you modify the registry.

Then, start Visual Studio and reproduce the issue (attempt to open the VA options menu). Once you are finished, close your IDE and collect the logs. The location of the logs is mentioned in the article.

You can send the logs to us using the contact form feline mentioned above.

Thank you for your trouble.
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 02 2018 :  2:09:33 PM  Show Profile  Reply with Quote
Anyone that is experiencing this problem, please list what recent Windows 10 updates have been installed on your system as reported at:
Windows Settings | Update & Security | Windows Update | View installed update history

For example, I have (unfortunately, links are not selectable, but the install date can be selected with mouse):

Feature Updates:
Feature update to Windows 10, version 1709
Successfully installed on 2017.10.20

Quality Updates:
KB4074588
Successfully installed on 2018.02.13

KB4074595
Successfully installed on 2018.02.07

Edited by - sean on Mar 02 2018 2:10:35 PM
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  2:18:54 PM  Show Profile  Reply with Quote
Should we post the windows update stuff here or send via contact form?

what could possibly go wrong? :D
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 02 2018 :  2:23:27 PM  Show Profile  Reply with Quote
Either. Right now we have one log from a user that shows that an SEH exception was thrown when the dialog was opened. We have seen that before due to a bug in a Windows 10 update from around Aug/Sept of 2017. That bug was fixed in the November (?) patch Tuesday. We're wondering if there is another update rolling out that we haven't seen yet, that perhaps reintroduced the old bug.
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 02 2018 :  5:04:48 PM  Show Profile  Reply with Quote
Does the problem repro immediately after startup of VS or does it only start to occur after some time has passed (and solution load, or debugging, etc)?
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 02 2018 :  8:16:41 PM  Show Profile  Reply with Quote
To those that experience the problem, does the "About Visual Assist" dialog (VAssistX | Help | About Visual Assist) display ok?


Does rolling back to 2248 ( https://support.wholetomato.com/default.asp?W404#2248 ) restore Options dialog behavior?


Edited by - sean on Mar 02 2018 8:16:58 PM
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  8:16:51 PM  Show Profile  Reply with Quote
Doesn't seem to matter. Same thing happens right after VS starts up or if it's been open a while.

what could possibly go wrong? :D
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  8:18:46 PM  Show Profile  Reply with Quote
quote:
Originally posted by sean

To those that experience the problem, does the "About Visual Assist" dialog (VAssistX | Help | About Visual Assist) display ok?



Yes, the about dialog does display OK

quote:
Originally posted by sean

Does rolling back to 2248 ( https://support.wholetomato.com/default.asp?W404#2248 ) restore Options dialog behavior?





I'll check now.

what could possibly go wrong? :D
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  8:21:30 PM  Show Profile  Reply with Quote
quote:
Originally posted by sean


Does rolling back to 2248 ( https://support.wholetomato.com/default.asp?W404#2248 ) restore Options dialog behavior?





No, same thing happens in 2248.

what could possibly go wrong? :D
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 02 2018 :  8:23:29 PM  Show Profile  Reply with Quote
hmmmm -- thanks for checking. need to chew on this a bit more...
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  8:32:57 PM  Show Profile  Reply with Quote
quote:
Originally posted by sean

hmmmm -- thanks for checking. need to chew on this a bit more...



I submitted my va.log and vassist.log. Let me know if you need anything else. I'll be around for another hour or so.

what could possibly go wrong? :D
Go to Top of Page

ChrisG
Whole Tomato Software

USA
220 Posts

Posted - Mar 02 2018 :  8:51:46 PM  Show Profile  Reply with Quote
Did you generate that log after rolling back to 2248? If so, it still says you have build 2258 installed.

Just double checking in case the rollback failed for whatever reason.
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 02 2018 :  9:00:55 PM  Show Profile  Reply with Quote
quote:
Originally posted by ChrisG

Did you generate that log after rolling back to 2248? If so, it still says you have build 2258 installed.

Just double checking in case the rollback failed for whatever reason.



I rolled back, tried the repro, then went back up to the latest, then enabled logging and reproduced the issue again. Would it be helpful to generate a log using 2248?

what could possibly go wrong? :D

Edited by - evolution on Mar 02 2018 9:01:26 PM
Go to Top of Page

ChrisG
Whole Tomato Software

USA
220 Posts

Posted - Mar 02 2018 :  9:06:42 PM  Show Profile  Reply with Quote
No, that's okay. Thanks for helping so much!
Go to Top of Page

Velaris
New Member

Canada
5 Posts

Posted - Mar 03 2018 :  02:02:38 AM  Show Profile  Reply with Quote
I went a head and also sent my logs.

Windows updates installed:

Feature update to Windows 10, version 1709
February 13, 2018—KB4074588 (OS Build 16299.248)
January 31, 2018—KB4058258 (OS Build 16299.214)

Opening the about window of Visual Assist works.

Thanks

Edited by - Velaris on Mar 03 2018 02:11:46 AM
Go to Top of Page

wolfmouse
New Member

3 Posts

Posted - Mar 05 2018 :  01:09:10 AM  Show Profile  Reply with Quote
I have the same issue.

I used old version (I can't remember which version was) and found the issue. So I uninstalled it and upgrade to latest version. It worked fine in the beginning, but still can't show dialog after a while.

Then I tried to uninstall-reinstall it. This time the dialog never shows up, so I can't enter my activation key either. I am wondering to know is any quick fix or progress on it?

Thanks!

Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17012 Posts

Posted - Mar 05 2018 :  09:55:54 AM  Show Profile  Reply with Quote
wolfmouse, can I just double check something. Did you have the problem that you could not open the VA options dialog in the older version of VA? If so, can you please check and see if there are any pending Windows updates, and if so, install them? Does this make any difference?

I ask because it looks like this new problem, what ever it is, is specific to VA 2258. So if you are seeing this problem, it should not happen with an earlier version. The problem with earlier versions of VA is related to the Windows 10 Fall Creators Update, and has been fixed by another Windows update that has already been released.

For now, can you please try downloading and installing VA 2248, our previous version, and see if this makes any difference:

https://support.wholetomato.com/default.asp?W404#2248

zen is the art of being at one with the two'ness

Edited by - sean on Mar 05 2018 11:43:47 AM
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 05 2018 :  11:47:40 AM  Show Profile  Reply with Quote
From the information we have gathered so far, there are not any Windows updates out there that we have not tested ourselves. Multiple users have reported issues with 2248 at this point -- but also one that reports the problem only occurs with 2258 and not 2248. We will be sending out test dlls in an effort to capture the exception in the debugger.
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 05 2018 :  7:50:23 PM  Show Profile  Reply with Quote
FWIW, the options dialog does appear in 2238. (I only tried opening it twice, so possible that it's only working the first few times, as others have described)

what could possibly go wrong? :D

Edited by - evolution on Mar 05 2018 8:59:28 PM
Go to Top of Page

wolfmouse
New Member

3 Posts

Posted - Mar 05 2018 :  8:55:40 PM  Show Profile  Reply with Quote

Hi feline, sean,

Thank for your reply.
Yes, I had the same problem was I can't open the VA options dialog in an older version of VA , so I upgraded it but just works in the beginning in the first time. Then no matter I reinstall the latest version 2258, or try to install 2248, 2238_2, the problem is still there.
I install all Windows updates util no new updates. restart computer to install it, the dialog still can't be opened.

Then I found I forget to clean the registry. After clean the registry, the dialog finally shows up (at version 2258).
I don't know is any registry make it failed (I never change registry manually).

I do know will it happen again, I will reply this if it happen.

Thanks!

Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Mar 05 2018 :  9:04:10 PM  Show Profile  Reply with Quote
We have a lead on the problem and hope to have a fix ready for testing in the next day or two.

Here's a test:
If you experience the problem while an unreal engine solution is loaded, try closing the solution and opening another solution that doesn't have the unreal engine source in it. Does the options dialog open now?
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Mar 05 2018 :  9:08:09 PM  Show Profile  Reply with Quote
quote:
Originally posted by sean

We have a lead on the problem and hope to have a fix ready for testing in the next day or two.

Here's a test:
If you experience the problem while an unreal engine solution is loaded, try closing the solution and opening another solution that doesn't have the unreal engine source in it. Does the options dialog open now?



No :\

what could possibly go wrong? :D
Go to Top of Page

Velaris
New Member

Canada
5 Posts

Posted - Mar 05 2018 :  9:08:16 PM  Show Profile  Reply with Quote
quote:
Originally posted by sean

We have a lead on the problem and hope to have a fix ready for testing in the next day or two.

Here's a test:
If you experience the problem while an unreal engine solution is loaded, try closing the solution and opening another solution that doesn't have the unreal engine source in it. Does the options dialog open now?



I confirm that opening the options dialog works when not opening an Unreal solution on 2258. Note that the dialog does not appear unless a solution is selected, meaning it's not working on the Visual Studio splash page.

Thanks Sean !

Edited by - Velaris on Mar 05 2018 9:08:31 PM
Go to Top of Page

wolfmouse
New Member

3 Posts

Posted - Mar 05 2018 :  9:18:13 PM  Show Profile  Reply with Quote
Same as Velaris.

After I open a Unreal project, the dialog can't be opened again.

Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000