Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Open File in Solution is slow loading
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mark.botting
New Member

New Zealand
4 Posts

Posted - Mar 28 2017 :  7:38:08 PM  Show Profile  Reply with Quote
I was getting frustrated with Open File in Solution taking a long time. It would display "[loading...]" in the dialog title bar. Then I realised it was because "Show only files in current solution" was unchecked. Checking that and it is back to the same as before upgrading to build 2212.
I post this in the hope it saves someone anyone else who doesn't notice the new option.

accord
Whole Tomato Software

United Kingdom
3137 Posts

Posted - Mar 28 2017 :  7:51:45 PM  Show Profile  Reply with Quote
I'm glad you've found the solution.

However, I would like to also add that this is not a new option on this dialog. The reason for the slowdown with this option is probably because of its behaviour change. From the what's new page:

Open File in Solution (Shift+Alt+O) now searches for files in system include paths when "Show only files in current solution" is unchecked.
http://www.wholetomato.com/features/whats-new.asp

Hope this makes sense.

Edited by - accord on Mar 28 2017 7:52:30 PM
Go to Top of Page

mark.botting
New Member

New Zealand
4 Posts

Posted - Mar 28 2017 :  8:23:35 PM  Show Profile  Reply with Quote
Thanks for the quick reply :) It was that item in the whats-new that twigged me to try checking the option.

Is it expected to take 20 seconds each time I use the Open File in Solution dialog with the option unchecked? It does the loading again each time I open the dialog. And during that 20 seconds it doesn't show any files, not even the files from the current solution. If I check the option to try speed it up, it still takes 20 seconds before it responds. I always leave the option checked now, because otherwise I find the dialog unusable.
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3137 Posts

Posted - Mar 28 2017 :  8:29:09 PM  Show Profile  Reply with Quote
Do you have a lot of directories on your system include path?

You can check it out here:
VA Options -> C/C++ Directories

I'm wondering whether it is the number of files is what causes this or something else.

When the 20 second passes, how many files does the dialog count in the title bar, in total, with the mentioned option unticked?
Go to Top of Page

sean
Whole Tomato Software

USA
2574 Posts

Posted - Mar 28 2017 :  9:54:20 PM  Show Profile  Reply with Quote
Does the dialog respond to a press of alt+s during that load time (as opposed to clicking on the checkbox)?

20 seconds is not expected and I do see room for improvement to dialog responsiveness when there is a huge number of files -- in particular it should support cancel of the load without closing the dialog so that you can see partial results in cases like a 20 second load. case=104968
Go to Top of Page

sean
Whole Tomato Software

USA
2574 Posts

Posted - Mar 29 2017 :  1:00:28 PM  Show Profile  Reply with Quote
Also, it would be helpful if you could capture and send in a log of the dialog load. If you are willing: enable logging before you open the dialog, open the dialog, check the checkbox, wait for it to finish, uncheck the checkbox and then close the dialog and VS. Send back va.log as described here: https://support.wholetomato.com/default.asp?W305
Go to Top of Page

mark.botting
New Member

New Zealand
4 Posts

Posted - Mar 30 2017 :  7:11:19 PM  Show Profile  Reply with Quote
Sorry, I've been a bit busy to follow up your questions earlier...

VA Options > C/C++ Directories:
Stable include files:
C:\SDKs\gmock-1.7.0\include
C:\SDKs\gmock-1.7.0\gtest\include
C:\SDKs\boost_1_59_0
C:\SDKs\OpenSSL-Win32\include
C:\Program Files (x86)\Windows Kits\8.1\Include\winrt
C:\Program Files (x86)\Windows Kits\8.1\Include\shared
C:\Program Files (x86)\Windows Kits\8.1\Include\um
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\include
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include
Other include files:
<none>
Source files:
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\crt\src
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\src\atl
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\src\mfcm
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\src\mfc
C:\SDKs\Qt\Qt5.6.0\5.6\Src

Number of files in dialog title bar (with no solution loaded):
173454

Behaviour of pressing Alt-S during loading:
* Open dialog.
* Option is checked.
* Press Alt-S -> Option becomes unchecked, [loading...] begins
* Press Alt-S -> Option becomes checked, [loading...] continues, hour glass mouse cursor appears
* Press Alt-S -> no change
* Click on IDE title bar -> dialog title bar shows (Not responding)
* Becomes responsive again after the approx 20 sec has elapsed since loding began.

Generally the [loading] seems to start a background task that takes approx 20 sec to complete. Alt-S will check the box and then wait for the current loading task to finish before continuing. Typing many Alt-S will buffer them up, so that each second press will wait for the 20 sec task to finish before progresing to process the next press.

Cancelling the dialog is similar. The dialog closes, but then an hour glass appears and the IDE is blocked until the task has completed. Although sometimes I've managed to hang or crash the IDE altogether.

I've taken a log, but now what? You've given a case number, but I can't find a link to open that case.
Go to Top of Page

mark.botting
New Member

New Zealand
4 Posts

Posted - Mar 30 2017 :  7:12:45 PM  Show Profile  Reply with Quote
BTW: I've noticed the bird logo. I've always wondered, is it a Kiwi? Do you have a New Zealander working there? It doesn't seem to have much to do with tomatoes. :)
Go to Top of Page

sean
Whole Tomato Software

USA
2574 Posts

Posted - Mar 30 2017 :  8:16:18 PM  Show Profile  Reply with Quote
Thanks for the details.

Use the contact form to send in the log:
http://www.wholetomato.com/support/contact.asp

Put TOPIC_ID=12890 in the subject field of the form.

It is a Kiwi -- but not one that we put there ourselves. We use FogBugz for customer support and hosting of our wikis. The Kiwi is theirs.
Go to Top of Page

sean
Whole Tomato Software

USA
2574 Posts

Posted - Apr 26 2017 :  5:05:43 PM  Show Profile  Reply with Quote
case=104968 is fixed in build 2217.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2018 Whole Tomato Software, Inc Go To Top Of Page
Snitz Forums 2000