Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VA outline's weird font spacing.
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Rasuka
New Member

Japan
4 Posts

Posted - Jun 01 2016 :  03:37:16 AM  Show Profile  Reply with Quote
Recently I've upgraded VA to 10.9.2098.0.
Probably since then, VA outline shows some functions with weird font spacing as attached.
Sometimes it's barely readable. Are there any workarounds?





feline
Whole Tomato Software

United Kingdom
15178 Posts

Posted - Jun 01 2016 :  12:57:22 PM  Show Profile  Reply with Quote
Thank you for the clear screen shot. What is strange is that it only effects some lines. Is there any obvious pattern to the effected lines? If you jump to these lines in the file, do these code lines contain Japanese characters? What about Japanese characters on the line above or below?

Can you please go to:

IDE tools menu -> Options -> Environment -> Fonts and Colors

Show settings for = Environment Font

what font is set? My English system says "Automatic", so if you see the same thing, could you please export your VA and IDE settings and send them to me:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

I can then import them here and see if I can reproduce the problem.

Please submit the files via the form:

http://www.wholetomato.com/support/contact.asp

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

Rasuka
New Member

Japan
4 Posts

Posted - Jun 02 2016 :  09:23:28 AM  Show Profile  Reply with Quote
Uh yes I think I've found the pattern.

Looks like VA Outline doesn't like the "f" character.

If I change the struct member "lastModifiedTimeUTC" to "lastModigiedTimeUTC", that fixes the spacing. Same for other functions/defines.

The source doesn't contain Japanese characters around the lines.





I will be sending the exported settings.
Go to Top of Page

Rasuka
New Member

Japan
4 Posts

Posted - Jun 02 2016 :  09:37:44 AM  Show Profile  Reply with Quote
Done some more tests...

The following member shows correct:
EuTime lastMfdigiedTimeUTC;

This reproduces the issue:
EuTime lastMofifiedTimeUTC;

Added struct members that contain only fff...:





Go to Top of Page

sean
Whole Tomato Software

USA
2399 Posts

Posted - Jun 02 2016 :  1:07:10 PM  Show Profile  Visit sean's Homepage  Reply with Quote
Thanks for the settings. We are able to reproduce the problem by selecting "Yu Gothic UI" as the VS Environment font. A temporary workaround is to select a different font (Tools | Options | Environment | Fonts and Colors | Show settings for Environment font). (case=93507)

Edited by - sean on Jun 02 2016 1:23:25 PM
Go to Top of Page

Rasuka
New Member

Japan
4 Posts

Posted - Jun 02 2016 :  9:07:20 PM  Show Profile  Reply with Quote
Thanks for your swift support, the workaround works! :)
Go to Top of Page

sean
Whole Tomato Software

USA
2399 Posts

Posted - Jun 03 2016 :  12:24:25 AM  Show Profile  Visit sean's Homepage  Reply with Quote
case=93507 is fixed in build 2102
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2017 Whole Tomato Software, Inc Go To Top Of Page
Snitz Forums 2000