Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Flickering of the method list bar
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

samaursa
Senior Member

Canada
47 Posts

Posted - Sep 25 2014 :  09:12:19 AM  Show Profile  Reply with Quote
The drop-down method list bar, an indispensable tool in VA, flickers quite a bit (sometimes quite severely) and is incredibly distracting. Note that I am not referring to the change of information (although that should be smooth as well, and shouldn't flicker). I have tried screen capturing it. Although it doesn't capture the severity of it, you can definitely see the flickering.



This problem has been around for quite some time. It would be great if it is addressed.

*moved for Visual Assist section by feline*

Edited by - feline on Sep 25 2014 2:14:16 PM

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Sep 25 2014 :  2:16:01 PM  Show Profile  Reply with Quote
That is unexpected, so lets start with the basics.

Which IDE and version of VA are you using?

Are you using the standard IDE dark theme, or a custom theme?

Do you have any other extensions installed? Specifically any extensions that you have added to the default set of installed extensions. Some form of interaction between VA and something else is the obvious theory here, but I don't know what that something else might be off hand.

zen is the art of being at one with the two'ness
Go to Top of Page

samaursa
Senior Member

Canada
47 Posts

Posted - Sep 25 2014 :  6:08:57 PM  Show Profile  Reply with Quote
The IDE is VS 2013 with SP3. VA build is 2014.07.10


I am using the following extensions. I have disabled all of them but the flickering persists.

VisualHg
VSVim
Code Alignment
Indent Guides

Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Sep 29 2014 :  2:06:25 PM  Show Profile  Reply with Quote
I am seeing both the VA context and definition fields, and the IDE navigation bar changing / flickering in your screen shot. Is the IDE navigation bar supposed to be updating like that, or is that also flickering?

Can you please make a new shortcut, or just use the Windows key + R dialog to run the following command:

"C:\\Program Files (x86)\\Microsoft Visual Studio 12.0\\Common7\\IDE\\devenv.exe" /RootSuffix Test

this creates a new, separate VS2013 profile, which we can run some tests in without effecting your main VS2013 profile. This will have the default extensions, but none of the extensions you installed.

Can you please open the solution you were seeing the flickering with and confirm that you are not seeing any flickering with the IDE navigation bar. If you are seeing that then we are going to have to look into that first.

Assuming everything is correct please install VA from the online extension list, but don't install any other extensions yet. Do you see the flickering or not?

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Sep 29 2014 :  10:32:07 PM  Show Profile  Reply with Quote
Another thought, are you working with more than one tab group? Or are all of your tabs in one group?

zen is the art of being at one with the two'ness
Go to Top of Page

samaursa
Senior Member

Canada
47 Posts

Posted - Sep 30 2014 :  06:06:16 AM  Show Profile  Reply with Quote
I think that just might be it. There is no flickering as far as I can see with only one tab group. With multiple tab groups I see flickering (in fact, as soon as I open the group, the flickering starts in both tabs).
Go to Top of Page

sean
Whole Tomato Software

USA
2640 Posts

Posted - Sep 30 2014 :  2:03:08 PM  Show Profile  Reply with Quote
Windows 8?
Go to Top of Page

samaursa
Senior Member

Canada
47 Posts

Posted - Sep 30 2014 :  2:18:05 PM  Show Profile  Reply with Quote
I have machines with Windows 7 and Windows 8 and it happens on both machines.

And I can pretty much confirm that this happens with multiple code panes. Doesn't seem to happen with one pane on the machines that I have.
Go to Top of Page

sean
Whole Tomato Software

USA
2640 Posts

Posted - Sep 30 2014 :  2:31:27 PM  Show Profile  Reply with Quote
Does the flicker occur when the text caret and mouse cursor are not moving?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Sep 30 2014 :  3:11:49 PM  Show Profile  Reply with Quote
We have had occasional reports of this, but this should have been fixed ages ago. So far I cannot reproduce this here.

How are you opening the tab group?

Does the flickering go on for a while, or does it quickly stop?

Can you please export your VA and IDE settings and send them to me:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

I can then import them here and see if I can reproduce the problem. Please submit the files via the form:

http://www.wholetomato.com/support/contact.asp

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

samaursa
Senior Member

Canada
47 Posts

Posted - Sep 30 2014 :  3:18:28 PM  Show Profile  Reply with Quote
quote:
Does the flicker occur when the text caret and mouse cursor are not moving?


When I click on an empty area without moving the caret there is quite a bit of flickering which then stops (as if VA was updating something, issuing update calls - but the text isn't changing, just flickering). Then if I move my mouse over various items such as the tab names, the scroll bar etc. the dropdown menu flickers for a bit again. Moving the caret almost always results in flickering.

quote:
How are you opening the tab group?


Right-click > New Vertical Tab Group

quote:
Does the flickering go on for a while, or does it quickly stop?


It goes on for maybe a second or two and then stops unless my mouse and/or caret is moving.

quote:
Can you please export your VA and IDE settings and send them to me:


I'll do that today.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
15980 Posts

Posted - Sep 30 2014 :  6:17:45 PM  Show Profile  Reply with Quote
I am now creating the new tab group using the right click menu, and still no sign of the flicker problem. I have tried the dark theme, as shown in your screen shot, and Windows 7 and Windows 8.1, and still nothing.

Hopefully your settings will shed some light on this.

zen is the art of being at one with the two'ness
Go to Top of Page

sean
Whole Tomato Software

USA
2640 Posts

Posted - Oct 28 2014 :  3:48:14 PM  Show Profile  Reply with Quote
A case was opened for this but I didn't update the thread: case=85333
Go to Top of Page

sean
Whole Tomato Software

USA
2640 Posts

Posted - Nov 07 2014 :  09:57:14 AM  Show Profile  Reply with Quote
case=85333 is fixed in build 2052
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000