Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 VS 2013: Exception when opening text files
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

SvenR
Ketchup Master

95 Posts

Posted - Oct 30 2013 :  05:27:35 AM  Show Profile  Reply with Quote
On Visual Studio 2013 RTM/Windows 8.1 with VA 10.8.2001 the IDE shows an message box with an exception warning in an extension when the first file is opened in the editor. It's a fresh install with VAX only.

Activity.xml shows the following entries:


System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. bei t.TextViewCreated(IWpfTextView textView) bei
Microsoft.VisualStudio.Text.Editor.Implementation.WpfTextView.<>c__DisplayClassc.<BindContentTypeSpecificAssets>b__9() bei 
Microsoft.VisualStudio.Text.Utilities.GuardedOperations.CallExtensionPoint(Object errorSource, Action call)

The color 'Popup' in category 'de7b1121-99a4-4708-aedf-15f40c9b332f' does not exist.


Maybe it's worth to mention that the file is first colored by VA before the message box comes up.

Windows 8.1 x64, VS 2017, VAX 10.9.2302

Edited by - SvenR on Oct 30 2013 05:28:18 AM

accord
Whole Tomato Software

United Kingdom
3277 Posts

Posted - Oct 30 2013 :  12:51:27 PM  Show Profile  Reply with Quote
We have seen similar issues in the past. I'm not sure if the problem is with the VS extension cache this time, but it is possible. Can you please try deleting the cache to see if it fixes the issue?

Close Visual Studio and then delete all files including sub directories:
C:\\Users\\<username>\\AppData\\Local\\Microsoft\\VisualStudio\\11.0\\ComponentModelCache\\*

and all .cache files in the following directory and its subdirectories:
C:\\Users\\<username>\\AppData\\Local\\Microsoft\\VisualStudio\\11.0\\Extensions\\*.cache

Visual Studio will rebuild those files when it starts up, and it hopefully resolves your problem.

Edited by - accord on Oct 30 2013 12:53:28 PM
Go to Top of Page

SvenR
Ketchup Master

95 Posts

Posted - Oct 30 2013 :  1:49:22 PM  Show Profile  Reply with Quote
I have deleted the 12.0 directories, but it still crashes. I also can't see any error in VA's log files.

Is there anything else that I can do to figure it out? I'm using a German version of VS 2013, maybe there are some language dependent things?

Windows 8.1 x64, VS 2017, VAX 10.9.2302
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3277 Posts

Posted - Oct 30 2013 :  3:15:39 PM  Show Profile  Reply with Quote
*ah* It also crashes. Exceptions not always cause crash. Can you please save out a minidump of the crash and send it in?
http://docs.wholetomato.com?W303

You can send in the file using the following form:
http://www.wholetomato.com/support/contact.asp

Please paste the URL of this topic to the description field so we can match it up.
Go to Top of Page

SvenR
Ketchup Master

95 Posts

Posted - Oct 30 2013 :  4:06:54 PM  Show Profile  Reply with Quote
Sorry for choosing the wrong words. With 'crash' I meant the message box with the exception warning.


---------------------------
Microsoft Visual Studio
---------------------------
Eine Ausnahme ist aufgetreten. Dies ist m+?glicherweise auf eine Erweiterung zur++ckzuf++hren.
(An exception has occurred. This may be due to an extension.)

Weitere Informationen erhalten Sie, wenn Sie die Datei "C:\\Users\\Sven\\AppData\\Roaming\\Microsoft\\VisualStudio\\12.0\\ActivityLog.xml" ++berpr++fen.
---------------------------
OK   
---------------------------


VS 2013 is still working after the message box, but the syntax coloring by VA is not available.

Windows 8.1 x64, VS 2017, VAX 10.9.2302
Go to Top of Page

SvenR
Ketchup Master

95 Posts

Posted - Oct 31 2013 :  08:37:38 AM  Show Profile  Reply with Quote
I have run some more tests.

1) On VM1 (VS 2013 RTM/Windows 8.1) I have deinstalled/reinstalled VA. After the first restart of Visual Studio VA's syntax coloring works. Next restart - exception warning. VS 2013 is installed in E:\\Visual Studio.12.

2) On VM2 (VS 2013 RTM/Windows 7) no problems with VA. In opposite to VM1 VS 2013 is installed in standard installation path.

3) If I install VS 2013 on VM1 in standard installation path VA seems to work. I took a snapshot before installing VS 2013, so the only difference between 1 and 3 is the installation path.


Windows 8.1 x64, VS 2017, VAX 10.9.2302
Go to Top of Page

accord
Whole Tomato Software

United Kingdom
3277 Posts

Posted - Oct 31 2013 :  5:14:30 PM  Show Profile  Reply with Quote
Good spot! I was able to reproduce the problem using non-default installation dir, so I have put in a bug report for this:

case=78151

Everything works as expected when using default installation dir. Again, good job isolation the problem!
Go to Top of Page

SvenR
Ketchup Master

95 Posts

Posted - Nov 01 2013 :  02:20:00 AM  Show Profile  Reply with Quote
Great, thank you!

Windows 8.1 x64, VS 2017, VAX 10.9.2302
Go to Top of Page

sean
Whole Tomato Software

USA
2817 Posts

Posted - Nov 18 2013 :  3:12:16 PM  Show Profile  Reply with Quote
case=78151 is fixed in build 2007
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000