Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VA Find References seems to be doing find in files

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
AlexMayH13 Posted - Mar 09 2020 : 3:10:29 PM
When I select "Display references from all projects" in the VA Find References Results panel, the results that turn up seem to just be a find in files for the given token.

For instance, I just searched for a "GetString" method from our localized string database. But the results have all instances of String::GetString in them.

Is this something that VA Find References is known to do under certain circumstances?
7   L A T E S T    R E P L I E S    (Newest First)
feline Posted - May 04 2020 : 07:00:56 AM
I am glad I could help.

VA should not be finding to many question mark references, unless we are having problems understanding something in your code. If this is happening, and you can provide an example of when VA is getting confused, I will look at it with you and try to work out what is going wrong, and why.
wade.steel Posted - May 02 2020 : 12:52:38 PM
quote:
Originally posted by feline

How are the extra references marked? Do they have a question mark icon in Find References Results?

If you right click into the Find References Results window, do you have the settings:

Display unknown/guess hits
Comment and string references

turned On or Off?




Oh my God. You just turned "Find References" into something useful for me. Thanks!
feline Posted - Mar 12 2020 : 06:33:57 AM
Email is probably easier, since you can attach files if you want:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.
AlexMayH13 Posted - Mar 12 2020 : 06:05:32 AM
On the whole it's working pretty well, but it sometimes gets completely confused. I'll DM you an example.
feline Posted - Mar 11 2020 : 1:36:33 PM
Thank you for the update. If you want us to look at the deeper problem, why all of these are coming up as guesses, can you please jump to one of the places where VA is getting confused, and have a look at the code.

Does VA correctly understand the type of the symbol you are using "GetString" on? So, for example you have:

myStringType testString;
testString.GetString();


what does VA think the type for "testString" is? Are the correct members listed when you type a dot to get a member list on this variable? What does Alt-Shift-G do when triggered on the variable or the type? Does VA know about the type?
AlexMayH13 Posted - Mar 11 2020 : 11:12:36 AM
Hello!

The extra references are indeed marked with a question mark.

Deselecting guess hits makes all the difference! Thank you!
feline Posted - Mar 10 2020 : 11:20:07 AM
How are the extra references marked? Do they have a question mark icon in Find References Results?

If you right click into the Find References Results window, do you have the settings:

Display unknown/guess hits
Comment and string references

turned On or Off?

I suspect that these extra references are guess hits, but this should only be happening if VA is confused by your code. If you jump to one of these "String::GetString" function calls, and place the caret into the function name, does VA show you the correct information for this function call in it's Context and Definition fields? These are normally shown at the top of the editor window, and are where the Alt-M list appears.

When using your own string class, does VA seem to be understanding the code and working correctly?

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000