Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Strange behavior of Intellisense (vs2019)

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
obfuscate Posted - Jan 14 2020 : 06:52:11 AM
If VA is enabled I'll get the strange behavior of Intellisense:
if I try to select something in the dropped list using a keyboard, the cursor will start moving also (up or down), "tab" inserts tabulation, but not paste a selected item and so on. It is really annoying and disturbing write code. Disabling VA solves the problem, but it isn't the solution.
I'll try to record a video to show the problem:
https://www.youtube.com/watch?v=6uAUpIJTqVc&feature=youtu.be

VS2019 16.4.2
VA 2353
9   L A T E S T    R E P L I E S    (Newest First)
gamearea Posted - Jan 20 2020 : 10:18:24 AM
I spend all night on the same problem. thanks a lot for the toptic, saving my ass. World become beautiful again!!
b2soft Posted - Jan 20 2020 : 05:36:04 AM
quote:
Originally posted by feline

Since Incredibuild have already fixed this on their side, it's not something we would normally look to fix as well.

Is working with Incredibuild disabled a reasonable option for you until you are able to move to the current version of Incredibuild? VS2019 has been out for a while now, so still working with experimental support doesn't sound ideal.



yes, it's a reasonable option. Thanks
feline Posted - Jan 15 2020 : 06:59:18 AM
Since Incredibuild have already fixed this on their side, it's not something we would normally look to fix as well.

Is working with Incredibuild disabled a reasonable option for you until you are able to move to the current version of Incredibuild? VS2019 has been out for a while now, so still working with experimental support doesn't sound ideal.
b2soft Posted - Jan 14 2020 : 10:53:14 AM
quote:
Originally posted by feline

Thank you for the update. Can you please try updating to the latest version of Incredibuild, and see if this fixes the problem?



Personally, disabling IncrediBuild fixes problem for me too.

But, due to Organization restrictions, I can use only IncrediBuild version 9.3.5 which has only: "This version of IncrediBuild provides experimental support for Visual Studio 2019. " (quoted from IncrediBuild documentation).

Is it possible to have a fix on VAssistX's side?
feline Posted - Jan 14 2020 : 09:53:07 AM
Thank you for the update. Can you please try updating to the latest version of Incredibuild, and see if this fixes the problem?
obfuscate Posted - Jan 14 2020 : 09:48:41 AM
Yeah, disabling Incredibuild also solves the problem.
obfuscate Posted - Jan 14 2020 : 08:38:27 AM
Yes, I have got it. I will try to disable Incredibuild asap.
feline Posted - Jan 14 2020 : 07:20:47 AM
Do you have the Incredibuild IDE extension installed on your system? If so, can you please try disabling it, to see if this has any effect?

This looks similar to a problem that has been reported when using both Incredibuild and VA at the same time, and should be fixed in the latest version of the Incredibuild extension.
b2soft Posted - Jan 14 2020 : 06:55:00 AM
I have the same issue in Visual Studio 2019 since version 16.2, but repro is like ~70% of launches. Disabling VAssistX solves the problem, but it's not a good solution

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000