Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Visual Studio 2019 - Enhanced Listboxes

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
WolfgangVogl Posted - Jul 03 2019 : 05:50:53 AM
Hello,
I dont know when it started but if i start typing in visual studio it suggests a list of possible things i could mean (for example i declared a variable "myVar" and now i type "my" it suggests me "myVar") - this is really nice because i just press enter and thats it.. but now it adds "myVar" AND adds a new line.
This is really annoying because if you try to type
std::string myVar{"..."};
and now you write an if using the suggestions it becomes

if (myVar
.length()
<= 10)
(accepted "myVar" after typing "my", accepted ".length" after typing ".le") and so on...

How to disable this behaviour?!
23   L A T E S T    R E P L I E S    (Newest First)
schoenherr Posted - Aug 02 2019 : 01:16:08 AM
Hi,
I can confirm that version 9.42 fixes the problem :-)
sean Posted - Aug 01 2019 : 1:36:10 PM
IncrediBuild support sent this message out this morning:
We've just released a new official version (9.42) which should solve the issue you had -
Please use the following link to download the new version -
https://www.incredibuild.com/downloads/incredibuild9_42.exe

Release Notes:
https://www.incredibuild.com/incredibuild-version-history.html

Please note the following:
1) The new build will require an upgrade of the Coordinator and all Agents.
2) In order to upgrade, run the setup file on the computer on which the Coordinator is installed and follow the instructions.
sean Posted - Jul 11 2019 : 4:39:39 PM
In addition to Alex's great instructions, support also writes:
Another option is to downgrade IncrediBuild to the previous version.
This can be done from the Coordinator Monitor -> Tools -> Version Rollback

But not being an IB user, I don't know if that is overkill compared to using VS extension management.
AlexMayH13 Posted - Jul 10 2019 : 12:17:57 PM
quote:
Originally posted by schoenherr

hi, sounds interesting.
how can we revert to 1.5.0.4




To revert:

Go to Tools -> Extensions.
Find Incredibuild Build Acceleration.
Click revert.
Restart Visual Studio.
sean Posted - Jul 10 2019 : 11:46:15 AM
I've sent the question to IB support and will update this thread when they respond.
schoenherr Posted - Jul 10 2019 : 05:18:55 AM
hi, sounds interesting.
how can we revert to 1.5.0.4
sean Posted - Jul 09 2019 : 12:39:15 PM
I've received a response from IncrediBuild support:
"we are working on the fix. The problem is with the IB add-in so one of the Solutions is to revert the add-in version back to 1.5.0.4 (no need to downgrade IB)."
schoenherr Posted - Jul 09 2019 : 12:47:41 AM
double checked, downgrading from ib-version 9.4.1 to ib-version 9.4 fixes the problem, but problem reappears after reboot even with version 9.4
sean Posted - Jul 08 2019 : 5:12:44 PM
Thanks for the confirmation. I've opened an IncrediBuild support ticket.
AlexMayH13 Posted - Jul 08 2019 : 11:01:14 AM
Just another datapoint here, we have the same version of Incredibuild (the build number is for the visual studio extension, not IB itself) and Visual Assist version 10.9.2333.0. Issue is affecting multiple programmers over several locations. Trying to reach out to IB but their support provider is blocked on the company firewall >_<
schoenherr Posted - Jul 08 2019 : 10:01:27 AM
yes removing incredibuild extension seems to fix the issue.
ib-version 1.5.0.10
but removing ib permanently is not an option.
singinwhale Posted - Jul 08 2019 : 02:20:12 AM
Can confirm. Removing the Incredibuild VS extension via the Agent Settings fixed the issue for me :)
I also had version 1.5.0.10 installed.
Luckily UE4 still uses Incredibuild for building the code even without the extension but I'm not sure if other people can afford to uninstall the extension.
Thanks sean!
sean Posted - Jul 07 2019 : 07:58:30 AM
Over in https://forums.wholetomato.com/forum/topic.asp?TOPIC_ID=16658 someone else is reporting broken enter key handling caused by IncrediBuild version 1.5.0.10. What version of IncrediBuild do you have installed?

Are any of you with this problem not using IncrediBuild?
accord Posted - Jul 06 2019 : 3:55:45 PM
Do any of you have any programs installed that may capture the keyboard or modify keyboard behaviour? Something like ViEmu, or a clipboard software, etc? A different user of Visual Assist had the very same issue, and uninstalling a keyboard-related software has helped for him. He didn't mention the name of the software though.
sean Posted - Jul 05 2019 : 10:03:27 PM
The next time this happens, please try a VS settings reset just to see if that has any effect on the problem. Export your settings first so that you can restore them after the experiment. No restart of VS is necessary. See Tools | Import and Export Settings. Roughly:
- export current settings, selecting all items
- reset settings
- see if the problem still occurs
- import your saved settings to restore previous state
sean Posted - Jul 05 2019 : 9:57:24 PM
In Help | About Microsoft Visual Studio, the line beneath the SKU where it states Enterprise/Professional/Community, should be a line with the version. For example, I have "Version 16.2.0 Preview 3.0"
schoenherr Posted - Jul 05 2019 : 5:41:23 PM
immediatly recognicible after solution load.
after reinstall of VA problem disappears.
but quickly reestablishs (maybe releated to reboot)
schoenherr Posted - Jul 05 2019 : 5:38:35 PM
visual studio enterprise
vs navigation is not visible

eventual it is related to existence of other extensions
most suspiciously: nunit test adapter (installs surprisingly some graphics aware components)
followed by: incredibuild

but not sure
sean Posted - Jul 05 2019 : 2:42:01 PM
What is the visibility state of the default VS navigation bar?
sean Posted - Jul 05 2019 : 2:38:09 PM
Is the problem immediately reproducible or is it something that starts occurring some time after VS start?
sean Posted - Jul 05 2019 : 2:36:42 PM
So far, I'm not able to repro and we haven't seen anything like this in our automated tests. What version of 2019 are you using?
singinwhale Posted - Jul 05 2019 : 09:15:29 AM

Many of us have the same issue. It suuuuper annoying but disabling it just makes us notice how much better the VAX list box is and how much we miss it. One of us even forced himself to just select the items by mouseclick :


schoenherr Posted - Jul 05 2019 : 06:57:04 AM
additional info:

happened to ca 10 dev's in our team too
if you use cursor keys to navigate inside the suggestion list the cursor also moves in the document. seems to do some selection during this movement. this selection is then replaced if you hit enter.
same effect if you navigate method list (alt-m) and select with enter.

very annoying
you can disable suggestion list in c++ files
but the method list problem still remains

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000