Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VS2019: Extend multi-line comments broken

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
Michael Buschbeck Posted - Jul 04 2019 : 01:24:58 AM
Starting with VS2019 16.2.0 Preview 3.0, the C++ 'Extend multi-line comments' feature is adding an extra newline after pressing Enter, bringing the caret into a new empty line just below the auto-extended new comment line.

Before pressing Enter:



After pressing Enter:



A pity I love this feature! :-)
4   L A T E S T    R E P L I E S    (Newest First)
sean Posted - Jul 09 2019 : 12:41:28 PM
I've received a response from IncrediBuild support:
"we are working on the fix. The problem is with the IB add-in so one of the Solutions is to revert the add-in version back to 1.5.0.4 (no need to downgrade IB)."
sean Posted - Jul 08 2019 : 5:00:27 PM
Thanks for sleuthing that out. It turns out it is the cause of much trouble that started recently: https://forums.wholetomato.com/forum/topic.asp?TOPIC_ID=16657
Michael Buschbeck Posted - Jul 06 2019 : 04:55:18 AM
This is really odd.

Apparently the issue is only present when I have the "IncrediBuild Build Acceleration" (version 1.5.0.10) extension enabled. (I don't think that's the same version as the one available for download on the VS Marketplace I have mine installed through IncrediBuild's own installer.)

As far as I know, the IncrediBuild extension does nothing with the editor at all. I certainly don't know what it should be doing with the editor.

So, thanks for solving my immediate problem, though the actual issue remains a strange one...
sean Posted - Jul 05 2019 : 2:33:08 PM
I'm not able to repro this problem. Do you have any other extensions installed?

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000