Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Snippets only work half the time VS2015 + 2248

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
Amimoller Posted - Dec 28 2017 : 03:30:15 AM
After the last large win 10 update and using 2248 and VS2015, snippets now only appear about half to 3/4 of the time.
Deleting the keywords and retyping them usually works, but is very annoying.

I mainly use them when doing Unreal Engine development, where i have made snippets for a lot of macros like this:
UPROPERTY(EditAnywhere, BlueprintReadOnly, Category=Damage)
float Damage;

So i can go up -> UPROPERTY() ea -> EditAnywhere etc.

Any ideas how to solve this? Happens both at work and at home.

Cheers
Jonas
6   L A T E S T    R E P L I E S    (Newest First)
sean Posted - Feb 21 2018 : 5:46:01 PM
case=113474 is implemented in build 2258

registry value named AllowSnippetsInUnrealMarkup
defaults to 00
change to 01 to restore old behavior
Amimoller Posted - Dec 29 2017 : 02:33:01 AM
Good to know that it will be fixed, thank you!

//Jonas
feline Posted - Dec 28 2017 : 3:10:01 PM
If you are not yet using the Windows Fall Creators Update then moving back to VA 2238 may be the best solution for now, since this will restore the old VA snippet behaviour, until the new build comes out with the fix.

https://support.wholetomato.com/default.asp?W404
sean Posted - Dec 28 2017 : 2:42:51 PM
Sorry, snippet behavior in UE4 U* macros changed in build 2248 without a way to restore previous behavior. We'll address that in the next release. case=113474.
Amimoller Posted - Dec 28 2017 : 07:41:19 AM
I use up for UPROPERTY() br for BlueprintReadOnly, ea EditAnywhere etc.

After some testing, it seems to only break inside those unreal macros ( UPROPERTY / UFUNCTION) which is where i use them 99% of the time.
standard snippets if/do also do not work very well in here.

Cheers
Jonas
feline Posted - Dec 28 2017 : 05:42:39 AM
What sort of shortcuts are you using to trigger these shortcuts?

Are you seeing the same problem with the standard snippets and shortcuts, like "if", "do" and "while"?

I am trying to work out if this is all snippets, snippets you have defined, or perhaps about your position / context in the file. You have a regular enough problem that hopefully there is a pattern here to help us make sense of it.

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000