Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VA Step filter disrupts dbg visualizers in V2012

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
gdermog Posted - Aug 07 2014 : 08:38:54 AM
Hello!

I have noticed that with enabled Debug/VA Step Filter option in Visual Studio 2012 native debugging visualizers stops working in second and subsequent debugging session of the same code. This problem appears with some recent update (now I am using VA_X.dll file version 10.8.2042.0 built 2014.06.25). Does anyone know something more about this problem? Thank you!

Best regards
Vladimir
9   L A T E S T    R E P L I E S    (Newest First)
gluckett Posted - Nov 19 2014 : 07:06:46 AM
quote:
Originally posted by sean

case=85576 is fixed in build 2052



I haven't been back on here in a while, but I just installed the build 2052 update and it seems to work fine now.

Thanks!
sean Posted - Nov 07 2014 : 09:56:51 AM
case=85576 is fixed in build 2052
gluckett Posted - Oct 10 2014 : 05:58:31 AM
quote:
Originally posted by sean

Here's a workaround until the next release of VA. These directions are for vs2012+ and VA build 2048 installed via our .exe installer (not applicable to .vsix installs):

1. Disable Visual Assist in the Visual Studio Tools | Extensions and Updates dialog
2. Restart Visual Studio
3. Enable Visual Assist in the VS Tools | Extensions and Updates dialog
4. Exit Visual Studio
5. Locate the Visual Assist installation directory per http://docs.wholetomato.com/default.asp?W105
6. Edit the file named "extension.vsixmanifest" and remove the line "<Asset Type="DebuggerEngineExtension" Path="VaDebuggerPlugin.vsdconfig" />"
7. Save the file
8. Start Visual Studio

We will address the underlying issue in the next release of Visual Assist. Note that the VS natStepFilter is not supported when native edit and continue is enabled in the VS Options dialog, however the VA Step Filter does work as expected.




Hi Sean,

I just gave this a try and it works for now. Thanks so much for the workaround!

Greg
sean Posted - Oct 09 2014 : 8:23:39 PM
Here's a workaround until the next release of VA. These directions are for vs2012+ and VA build 2048 installed via our .exe installer (not applicable to .vsix installs):

1. Disable Visual Assist in the Visual Studio Tools | Extensions and Updates dialog
2. Restart Visual Studio
3. Enable Visual Assist in the VS Tools | Extensions and Updates dialog
4. Exit Visual Studio
5. Locate the Visual Assist installation directory per http://docs.wholetomato.com/default.asp?W105
6. Edit the file named "extension.vsixmanifest" and remove the line "<Asset Type="DebuggerEngineExtension" Path="VaDebuggerPlugin.vsdconfig" />"
7. Save the file
8. Start Visual Studio

We will address the underlying issue in the next release of Visual Assist. Note that the VS natStepFilter is not supported when native edit and continue is enabled in the VS Options dialog, however the VA Step Filter does work as expected.
feline Posted - Oct 09 2014 : 2:42:29 PM
I am seeing the same problem here, apologies for this, this is a regression. It is working correctly for me in VA 2043 but it has stopped working in VA 2048. For now you either need to go back to VA 2043 or add your step filter rules to VA's step filter dialog, until we can get this fixed:

case=85576
gluckett Posted - Oct 09 2014 : 07:31:33 AM
I am experiencing a similar problem using VA 2048. In both Visual Studio 2012 and 2013, any step filters I have defined in my Documents\\Visual Studio\\Visualizers folder no longer work with Visual Assist enabled. Even if I disable the VA Step Filter, my custom step filters don't work. The only way my custom filters work is if I disable VA completely. Did something break between 2043 and 2048 (I don't remember if it worked for me in 2043 or not - I just noticed that they suddenly stopped working and was able to narrow it down to VA causing the problem).
feline Posted - Aug 08 2014 : 5:07:29 PM
When you have a bit of time to try, you can simply install the new version of VA which will give you a 7 day trial, plenty of time to make sure that this fix is working for you. At the end of the trial, if you need to revert back to the old version of VA, simply uninstall VA via the:

IDE tools menu -> Extension Manager...

dialog, and reinstall your current version. If you need to redownload your current version, you can download it from here:

http://support.wholetomato.com/default.asp?W404
gdermog Posted - Aug 08 2014 : 03:53:43 AM
Not now, I am afraid, my licence does not allow this (before mentioned build is last that I can use with my current licence). I will ask my boss for renewal, but it may take a while.
feline Posted - Aug 07 2014 : 09:19:05 AM
Can you please try downloading and installing our latest version, VA 2043, this should fix this problem for you:

http://www.wholetomato.com/downloads/default.asp

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000