Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 #include intellisense does not work with C++ nuget

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
barryl72 Posted - May 09 2014 : 10:47:45 AM
Steps to reproduce:

* In VS2013
* Create a win32 exe hello world project.
* Right click on project, and manage nuget references.
* Add expat, or zlib for example.
* Type '#include <z'
* Nothing happens.
* Disable Visual Assist.
* Type '#include <z' VS built-in intellisense works.

Additionally, as Visual Assist doesn't parse the header, you can't use VAX's go to definition.


Visual Assist switched on:




Visual Assist switched off (using VS native intellisense):



I'm running the latest beta, with everything else switched off in VS2013.
14   L A T E S T    R E P L I E S    (Newest First)
sean Posted - Jul 01 2014 : 12:08:39 AM
Thanks for the confirmation.
barryl72 Posted - Jun 30 2014 : 01:00:09 AM
I've just download build 2042 and it works fine. Thanks for this.
sean Posted - Jun 26 2014 : 01:49:31 AM
case=79296 is fixed in build 2042.
barryl72 Posted - Jun 03 2014 : 03:09:47 AM
Great, thanks.
sean Posted - Jun 03 2014 : 01:39:11 AM
I believe that is the default name and location. At any rate, we are aiming to have improvements in this area for the next release.
barryl72 Posted - Jun 03 2014 : 01:22:04 AM
Hi @sean - we use a NuGet.config file at the same level/folder as our solution, which then places the packages in a folder at the same level. The contents (for us, at least) is just:


<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <config>
    <!-- See http://docs.nuget.org/docs/reference/nuget-config-file for more detail. -->
    
    <!--  CUSTOM PACKAGE PATH  -->
    <add key="repositoryPath" value="packages" />	
    
    <!-- This prevents people accidentally pushing packages. -->
    <add key="DefaultPushSource" value="http://" />
  </config>
  <packageSources>
    <add key="TeamCity" value="http://teamcity:8070/guestAuth/app/nuget/v1/FeedService.svc/" />
    <!-- Once you add a custom feed NuGet now ignores the official feed so we have to add that as well -->
    <add key="NuGet official package source" value="https://nuget.org/api/v2/" />
  </packageSources>
</configuration>

sean Posted - Jun 02 2014 : 2:15:56 PM
@barryl72 Do you use the default repository directory ("packages") or do you customize it using your nuget config file?
barryl72 Posted - Jun 02 2014 : 10:32:18 AM
@feline - thanks. Getting this working would be a big help for us. If you have anything you need testing, please let me know.
feline Posted - May 29 2014 : 3:46:42 PM
Interesting, thank you for the information. Our developers are currently looking into adding NuGet support, the trick is working out something solid and reliable, release worthy. I don't currently have an estimate for when this will be done, it partly depends on what they find, but hopefully this will appear sooner rather than later.
barryl72 Posted - May 29 2014 : 07:20:53 AM
Hi @feline - sorry for the even slower reply!

It appears that I already have that option set, and the results are still the same as shown in the screenshots above.

As far as I can tell, NuGet inserts an 'import project' directive, into the .vcxproj that includes a .targets file from the NuGet package. That in turn, is just an xml build with further msbuild (?) directives, including this:

<AdditionalIncludeDirectories>$(MSBuildThisFileDirectory)../..//build/native/include/;%(AdditionalIncludeDirectories)</AdditionalIncludeDirectories>

Do you parse those things?



feline Posted - May 17 2014 : 5:56:59 PM
Apologies for the slow reply. Turning:

VA Options -> Listboxes -> Get content from default Intellisense

on gets you most of the way there. Can you please try this and see how much this helps? With this set, what problems are you still seeing?
barryl72 Posted - May 12 2014 : 05:16:13 AM
Is there a way to disable VAX's include intellisense?
barryl72 Posted - May 12 2014 : 02:20:19 AM
Thanks.
feline Posted - May 10 2014 : 9:02:48 PM
Unfortunately this is a known problem:

case=79296

we are still trying to work out how to detect the extra include directories that nuget is adding. For now, if you only have a few projects using nuget then the best solution for now is to manually add the nuget directories to the projects additional include directories.

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000