Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 C++ highlighting issues

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
Barktroll Posted - Jun 14 2013 : 4:17:45 PM
I've noticed some small quirks with the syntax highlighting since I switched to VS2012. I'm using build 1940, and with the following code:
#include <memory>
#include <thread>
#include <exception>

using std::unique_ptr;
using std::thread;
using std::exception;

class MyClass;

void myFunction(unique_ptr<MyClass>&& rvalue)
{
}

int main(int argc, char* argv[])
{
	try
	{
		thread myThread(
		[]()
		{
		});
	}
	catch(const exception&)
	{
	}
}

... I get the following syntax highlighting:


As you may or may not see, the faults in the highlighting are:
  • Line 11: "rvalue" should be silver, not white.
  • Line 19: "thread" should be the same turquoise as the other types.
  • Line 24: "exception" should be the same turquoise as the other types.
4   L A T E S T    R E P L I E S    (Newest First)
sean Posted - Feb 26 2014 : 10:38:57 AM
case=20625 is fixed in build 2029
accord Posted - Jun 17 2013 : 5:13:57 PM
*ah* Turning off Semantic Colorization has helped. Normally VA colors are used when enabled, even with this setting turned on, but Intellisense "masked" the colors where VA had problem interpreting the symbols, it seems.

rvalue references is case=20625

std::thread is case=74979

If I use directly std::thread it seems to work though.
Barktroll Posted - Jun 15 2013 : 02:46:44 AM
The above code was in a completely new Win32 Console Application project.

I've sent you the registry file with the settings.

EDIT: Also, if it makes any difference, I have turned off Visual Studio's own "Semantic Colorization", but I still have IntelliSense enabled.
accord Posted - Jun 14 2013 : 5:55:18 PM
I am seeing the same effect here for "exception":

case=58735

However, my "rvalue" and "thread" are correct. Can you please create a clean new win32 test project, create a new file, and paste this code sample there to see if you can still see the same problems? If yes, can you please export your Visual Assist and Visual Studio settings and send them in?

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

So I can import them here to see if I can reproduce the problem.

You can send the files in using the following form:
http://www.wholetomato.com/support/contact.asp

Please paste the URL of this topic into the description field so we can match it up.

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000