Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Visual studio 2012 freeze

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
dgallo Posted - Nov 22 2012 : 09:49:00 AM
Visual studio 2012 freezes with VAssist while typing letters "~" and "^" on a french keyboard, and typing another caracter after.
For example a c++ destructor ~classname();
I'm typing the key AltGr and the key '2' to obtain the letter "~" on the french keyboard ; this cause an heavy cpu load on the Visual Studio process and i cannot type any key anymore ; sometimes i have ~cccccccccccccccccccccccccccccccccc when i type ~ and c.


I'm using Visual Studio 2012 Pro and VAssist 1918 on Windows 8 x64 on a core i7.
Tested with only VAssist extension enabled.
4   L A T E S T    R E P L I E S    (Newest First)
support Posted - Dec 17 2012 : 11:46:52 PM
case=70780 is fixed in build 1925
feline Posted - Nov 23 2012 : 5:40:08 PM
If you are using a second keyboard layout to help, on my Windows 8 system the default keyboard shortcut to swap between two different keyboard layouts is "Windows Key + Space".

You might also find this page helpful, it shows different keyboard layouts:

http://www.terena.org/activities/multiling/ml-mua/test/kbd-all.html

It helped me work out where the ~ symbol was on the French keyboard Changing keyboard layouts can be a bit of a jolt if you are not used to this.

Either way hopefully this will be fixed soon, since I have put this down as an urgent bug report.
dgallo Posted - Nov 22 2012 : 11:24:30 PM
I have only the french keyboard installed.

Thank you for the workaround.
feline Posted - Nov 22 2012 : 8:05:42 PM
I am seeing the same effect here. Thank you for the clear description.

case=70780

Interestingly this is Windows 8 specific for me, I cannot reproduce this under Windows 7.

Do you have another keyboard layout installed, or do you only have the French keyboard installed in Windows? As a temporary work around you could try swapping keyboard layouts while entering ~ for your destructors. Not ideal, but it might help.

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000