Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 [VS 2010] Visual Assist Disabled for C# project

You must be registered to post a reply.
Click here to register.

Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji

Forum code is on.
Html is off.

Check to subscribe to this topic.

T O P I C    R E V I E W
AshMcConnell Posted - Jan 26 2012 : 07:13:21 AM
Hi Folks,

I've been using Visual Assist with C++ projects for years. I've started writing from C# (for a Unity3d Project) and Visual Assist is completely disabled, everything is greyed out.

Any ideas what could be causing the problem?

14   L A T E S T    R E P L I E S    (Newest First)
sean Posted - Sep 19 2014 : 12:39:06 AM
case=64588 is fixed in build 2047
feline Posted - Apr 17 2012 : 3:19:36 PM
This is still on our list of known bugs, but unfortunately no progress on fixing this yet.

As for Unity supporting debugging in VS, that is something you would have to ask the Unity developers about. VA stays out of the way of debugging, since we are here to help you with your code, not with working out what your program is doing
NMD Posted - Apr 14 2012 : 1:07:41 PM
I have the same issue, If I load VS2010 from within unity VAX is completely disabled, cant even get at the options.

If I open the solution manually in VS, VAX works just fine... Its kind of annoying actually but still better than using Mono Develop.

Win 7 x64, VS2010 Ultimate, Unity 3.5 Pro.

I know this is the wrong forum but wouldn't it be awesome if Unity supported debugging in VS?
feline Posted - Mar 22 2012 : 4:04:26 PM
Thank you for the update, it is good to know that this work around is working.
Pathogen-David Posted - Mar 21 2012 : 02:13:42 AM
I can confirm that the same thing happens to me with Visual Studio 2010 on Windows 7 64-bit with Unity 3.5.

The workaround of launching Visual Studio via the solution file generated by Unity also works for me, opening scripts in Unity still causes them to be opened in the Visual Studio instance I started as expected, so this workaround is good enough for now.
feline Posted - Feb 09 2012 : 12:09:36 AM
Thank you for the details, I am seeing the same problem here. Interestingly there is no sign of a problem if I set the external editor to VS2008, so that is a possible work around if you have access to VS2008.

AshMcConnell Posted - Feb 07 2012 : 11:22:07 AM
Hi Feline,

Sorry I didn't get this notification for some reason. Yep Unity3d.com is correct, it can be downloaded for free. I am using Windows 7 64 bit.

I think, by default, it uses Monodevelop, but it's quite easy to switch to Visual Studio. Here is how: -


In Unity, go to Edit->Preferences, and make sure that Visual Studio is selected as your preferred external editor.
Doubleclick a C# file in your project. Visual Studio should automatically open that file for you.
You can edit the file, save, and switch back to Unity.

All the best,
feline Posted - Feb 01 2012 : 7:16:18 PM
It turns out the "-Embedding" switch does something "interesting". When I use the Windows run dialog to run the command:

devenv.exe -Embedding <path to .cs file>

the VS2010 process starts, and then exits, without ever appearing on the screen. Which makes sense if VS2010 thinks it is being embedded inside another process, but that process does not actually exist, which it doesn't here.

Is Unity something I can just download for free, perhaps a demo version, and try out here? A quick web search found this:


is this the right product? If so which version are you using? What do I need to know about getting it to use VS2010 as an editor? Also which OS are you working under? Is this a 32bit or 64bit OS?
AshMcConnell Posted - Feb 01 2012 : 08:58:59 AM
Hi Feline,

It has -Embedding as a switch. devenv.exe is listed under wininit.exe->services.exe->svchost.exe. The VA Options dialog is greyed out.
feline Posted - Jan 31 2012 : 10:25:33 AM
This is a little odd. Can you please try running Process Explorer:


and right click on the "devenv.exe" line, and select Properties. On the Image tab, you should have the command line used to launch the IDE. Are there any command line switches? Is "devenv.exe" listed as a child process of unity?

In the IDE, are you able to load VA's options dialog? If not, this would suggest VA is disabled for some reason.
AshMcConnell Posted - Jan 31 2012 : 02:41:36 AM
Hi Feline,

Yep, just tried double clicking on a .cs file in unity and it loads the solution, but VAX isn't active. It works fine if I load the solution manually. It's not a huge problem to start VS manually (and how I'd normally work in any case), just a little odd.

Thanks for your help
All the best,
feline Posted - Jan 30 2012 : 11:33:41 AM
When the problem went away, did you load the IDE yourself and then load the solution?

If there is a problem related to how unity starts visual studio then this might come back again next time unity loads the IDE. Just something to be aware of. If this problem comes back again then please let me know, and I will do what I can to help.
AshMcConnell Posted - Jan 30 2012 : 04:58:36 AM
Hi Feline,

Sorry for the late reply, I had a bit of a busy weekend.

It oddly just started working, I think perhaps when I reopened the solution. Perhaps it was the way unity starts visual studio to open a .cs file.

Not sure why, but everything works now :)

All the best,
feline Posted - Jan 26 2012 : 12:24:28 PM
I am assuming you are working in .cs files. If so can you check:

VA Options -> Projects -> File Handling -> Extensions to ignore

and see if .cs; has been added to this list? This would certainly cause the effect you are seeing.

If .cs is not in this list, can you try creating a new, default C# solution, and see if VA is active in this solution?

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000