Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Rebuild symbol databases without restarting VS

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
stirlingboy69 Posted - Aug 17 2021 : 2:12:47 PM
Hello,

Is it possible to rebuild the symbol databases without having to restart VS?
Since our project solution is generated, VA gets out of sync. It would
be nice to force a rebuild without need to click the Rebuild button and
restart Visual Studio twice.

Thanks.
Pete
2   L A T E S T    R E P L I E S    (Newest First)
accord Posted - Aug 19 2021 : 6:33:13 PM
I think we have a feature that might help:

VAssistX -> Tools -> Reload solution

Quoting from our documentation:


External Modification of Source
If external applications modify your source when your IDE is active and a project is open, you must enable "Watch for externally modified files" in the options dialog of Visual Assist if you want Visual Assist to recognize the changes immediately. If not, Visual Assist will recognize the changes when you reload your project.

Source: https://docs.wholetomato.com/default.asp?W213


This sounds like may help with your case as well, but it worth a try.

If this wouldn't help, I would try next just to close and then reopen the solution to see if it's enough without rebuilding your symbol databases. VA might pick up the changes.
feline Posted - Aug 18 2021 : 07:03:14 AM
Unfortunately no, the symbol database rebuild requires a restart. But if it is only your solution that is being generated then this should not be required. Rebuilding the VA symbol database is partly for when you have changed your stable include directories.

Can you please try the command:

VAssistX -> Tools -> Reload Solution

and see if this helps with your problem?

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000